aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
commit10f22ecd6d1808866406972dd09e2e107e41ceb2 (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /finance
parent42651c13cd4978964674808cab47a30c8726769b (diff)
downloadports-10f22ecd6d1808866406972dd09e2e107e41ceb2.tar.gz
ports-10f22ecd6d1808866406972dd09e2e107e41ceb2.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Notes
Notes: svn path=/head/; revision=381221
Diffstat (limited to 'finance')
-rw-r--r--finance/p5-Data-Currency/Makefile12
-rw-r--r--finance/p5-Finance-Currency-Convert-XE/Makefile4
-rw-r--r--finance/p5-Finance-QuoteTW/Makefile5
3 files changed, 6 insertions, 15 deletions
diff --git a/finance/p5-Data-Currency/Makefile b/finance/p5-Data-Currency/Makefile
index ba45f4164025..632643c0fcaa 100644
--- a/finance/p5-Data-Currency/Makefile
+++ b/finance/p5-Data-Currency/Makefile
@@ -11,16 +11,12 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Container class for currency conversion/formatting
-BUILD_DEPENDS= p5-Locale-Currency-Format>=0:${PORTSDIR}/finance/p5-Locale-Currency-Format \
- p5-Class-Accessor-Grouped>=0:${PORTSDIR}/devel/p5-Class-Accessor-Grouped \
+BUILD_DEPENDS= p5-Class-Accessor-Grouped>=0:${PORTSDIR}/devel/p5-Class-Accessor-Grouped \
+ p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector \
p5-Finance-Currency-Convert-WebserviceX>=0:${PORTSDIR}/finance/p5-Finance-Currency-Convert-WebserviceX \
p5-Locale-Codes>=0:${PORTSDIR}/misc/p5-Locale-Codes \
- p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector
-RUN_DEPENDS= p5-Locale-Currency-Format>=0:${PORTSDIR}/finance/p5-Locale-Currency-Format \
- p5-Class-Accessor-Grouped>=0:${PORTSDIR}/devel/p5-Class-Accessor-Grouped \
- p5-Finance-Currency-Convert-WebserviceX>=0:${PORTSDIR}/finance/p5-Finance-Currency-Convert-WebserviceX \
- p5-Locale-Codes>=0:${PORTSDIR}/misc/p5-Locale-Codes \
- p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector
+ p5-Locale-Currency-Format>=0:${PORTSDIR}/finance/p5-Locale-Currency-Format
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/finance/p5-Finance-Currency-Convert-XE/Makefile b/finance/p5-Finance-Currency-Convert-XE/Makefile
index 90359790612e..8341bf1f1760 100644
--- a/finance/p5-Finance-Currency-Convert-XE/Makefile
+++ b/finance/p5-Finance-Currency-Convert-XE/Makefile
@@ -24,13 +24,9 @@ USE_PERL5= configure
PORTDOCS= Changes README
-.include <bsd.port.options.mk>
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
-.endif
.include <bsd.port.mk>
diff --git a/finance/p5-Finance-QuoteTW/Makefile b/finance/p5-Finance-QuoteTW/Makefile
index 75f1e78d6572..d0c37b33124b 100644
--- a/finance/p5-Finance-QuoteTW/Makefile
+++ b/finance/p5-Finance-QuoteTW/Makefile
@@ -4,7 +4,7 @@
PORTNAME= Finance-QuoteTW
PORTVERSION= 0.09
DISTVERSIONPREFIX= v
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= finance perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -16,8 +16,7 @@ RUN_DEPENDS= p5-Data-TreeDumper>=0:${PORTSDIR}/devel/p5-Data-TreeDumper \
p5-HTML-Encoding>=0.6:${PORTSDIR}/www/p5-HTML-Encoding \
p5-HTML-TableExtract>=2.1:${PORTSDIR}/www/p5-HTML-TableExtract \
p5-Spiffy>=0.3:${PORTSDIR}/devel/p5-Spiffy \
- p5-WWW-Mechanize>=1.34:${PORTSDIR}/www/p5-WWW-Mechanize \
- p5-version>=0.76:${PORTSDIR}/devel/p5-version
+ p5-WWW-Mechanize>=1.34:${PORTSDIR}/www/p5-WWW-Mechanize
BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5