aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-08 22:59:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-08 22:59:05 +0000
commitabb478d3416a3ec78536998c0dd89617c5a09487 (patch)
treeb9069a5fe53d6a94b8daf5245f665d62d707ab15 /finance
parentd4475c316c73a322a4f2dfbd84cef8b51d745461 (diff)
downloadports-abb478d3416a3ec78536998c0dd89617c5a09487.tar.gz
ports-abb478d3416a3ec78536998c0dd89617c5a09487.zip
Finance::Amortization is a simple object oriented interface to an amortization
table. Pass in the principal to be amortized, the number of payments to be made, and the interest rate per payment. It will calculate the rest on demand, and provides a few methods to ask for the state of the table after a given number of periods. Authors: Nathan Wagner <nw@hydaspes.if.org> WWW: http://search.cpan.org/dist/Finance-Amortization/ PR: ports/107603 Submitted by: Christopher Boumenot <boumenot at gmail.com>
Notes
Notes: svn path=/head/; revision=181809
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/p5-Finance-Amortization/Makefile27
-rw-r--r--finance/p5-Finance-Amortization/distinfo3
-rw-r--r--finance/p5-Finance-Amortization/pkg-descr8
-rw-r--r--finance/p5-Finance-Amortization/pkg-plist5
5 files changed, 44 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index 1d647b9e08d5..cc166f64d181 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -46,6 +46,7 @@
SUBDIR += p5-Business-OnlinePayment-eSec
SUBDIR += p5-Business-OnlinePayment-iAuthorizer
SUBDIR += p5-Business-WorldPay-Junior
+ SUBDIR += p5-Finance-Amortization
SUBDIR += p5-Finance-Currency-Convert
SUBDIR += p5-Finance-Currency-Convert-WebserviceX
SUBDIR += p5-Finance-Currency-Convert-XE
diff --git a/finance/p5-Finance-Amortization/Makefile b/finance/p5-Finance-Amortization/Makefile
new file mode 100644
index 000000000000..194a95792e93
--- /dev/null
+++ b/finance/p5-Finance-Amortization/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Class-Gomor
+# Date created: 3 Jan 2007
+# Whom: Christopher Boumenot <boumenot@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Finance-Amortization
+PORTVERSION= 0.4
+CATEGORIES= finance perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= boumenot@gmail.com
+COMMENT= Simple amortization schedules
+
+PERL_CONFIGURE= yes
+
+MAN3= Finance::Amortization.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE=Needs perl 5.6.0 or higher, install lang/perl5.6 and try again.
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/finance/p5-Finance-Amortization/distinfo b/finance/p5-Finance-Amortization/distinfo
new file mode 100644
index 000000000000..f98b778baa91
--- /dev/null
+++ b/finance/p5-Finance-Amortization/distinfo
@@ -0,0 +1,3 @@
+MD5 (Finance-Amortization-0.4.tar.gz) = c8e85333348070f52a2399cbc66009b4
+SHA256 (Finance-Amortization-0.4.tar.gz) = 0777bde786071484ad2da17b9f14194897b63606d708476b500fdd491db3e1d6
+SIZE (Finance-Amortization-0.4.tar.gz) = 3505
diff --git a/finance/p5-Finance-Amortization/pkg-descr b/finance/p5-Finance-Amortization/pkg-descr
new file mode 100644
index 000000000000..cc947eb271c5
--- /dev/null
+++ b/finance/p5-Finance-Amortization/pkg-descr
@@ -0,0 +1,8 @@
+Finance::Amortization is a simple object oriented interface to an amortization
+table. Pass in the principal to be amortized, the number of payments to be
+made, and the interest rate per payment. It will calculate the rest on demand,
+and provides a few methods to ask for the state of the table after a given
+number of periods.
+
+Authors: Nathan Wagner <nw@hydaspes.if.org>
+WWW: http://search.cpan.org/dist/Finance-Amortization/
diff --git a/finance/p5-Finance-Amortization/pkg-plist b/finance/p5-Finance-Amortization/pkg-plist
new file mode 100644
index 000000000000..a5092452e778
--- /dev/null
+++ b/finance/p5-Finance-Amortization/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Finance/Amortization.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Finance/Amortization/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Finance/Amortization
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Finance
+@dirrmtry %%SITE_PERL%%/Finance