aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-11-11 08:14:29 +0000
committerJohn Marino <marino@FreeBSD.org>2015-11-11 08:14:29 +0000
commit17b3399f5fac0fb3ff6e16ac1ac0fbc920e131c9 (patch)
treeef144a0adf477d2b396dd00427f32078f7ec347f /finance
parent9916f254bd1a5fd337fa9ee6bed04606ea6029f7 (diff)
downloadports-17b3399f5fac0fb3ff6e16ac1ac0fbc920e131c9.tar.gz
ports-17b3399f5fac0fb3ff6e16ac1ac0fbc920e131c9.zip
finance/ledger: Convert to USES=libedit
Approved by: infrastructure modernization
Notes
Notes: svn path=/head/; revision=401227
Diffstat (limited to 'finance')
-rw-r--r--finance/ledger/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/finance/ledger/Makefile b/finance/ledger/Makefile
index f9a8a4ecb604..b06720ee1cc0 100644
--- a/finance/ledger/Makefile
+++ b/finance/ledger/Makefile
@@ -15,13 +15,12 @@ LICENSE_FILE= ${WRKSRC}/doc/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/include/utf8.h:${PORTSDIR}/devel/utf8cpp
LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
libmpfr.so:${PORTSDIR}/math/mpfr \
- libedit.so.0:${PORTSDIR}/devel/libedit \
libboost_system.so:${PORTSDIR}/devel/boost-libs
USE_GITHUB= yes
USE_LDCONFIG= yes
-USES= cmake compiler:c++11-lib
+USES= cmake compiler:c++11-lib libedit
CMAKE_ARGS+= -DCMAKE_INSTALL_MANDIR=${MANPREFIX}/man \
-DCMAKE_INCLUDE_PATH=${LOCALBASE}/include