aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2014-02-02 10:24:26 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2014-02-02 10:24:26 +0000
commit66d093cbcdcc926fadba1acc6936524e6d11b1c6 (patch)
tree3ca9bec497bc9001f27ff4c7f06b635f9a0fc440 /finance
parentf3f02b88177dcca6108b19bc78d34352c3784d84 (diff)
downloadports-66d093cbcdcc926fadba1acc6936524e6d11b1c6.tar.gz
ports-66d093cbcdcc926fadba1acc6936524e6d11b1c6.zip
fixc is a simple Financial Information eXchange (FIX) protocol console client.
fixc connects to remote host and sends out FIX messages it reads from local scenario file. WWW: https://github.com/blttll/fixc In addition to original submission: * stagify * Add PLIST_FILES * PORTREVISION not needed for a brand new port * Use DIST_SUBDIR as the distfile name is not indicative of which port it belongs to PR: ports/181943 Submitted by: blttll@gmail.com
Notes
Notes: svn path=/head/; revision=342263
Diffstat (limited to 'finance')
-rw-r--r--finance/Makefile1
-rw-r--r--finance/fixc/Makefile24
-rw-r--r--finance/fixc/distinfo2
-rw-r--r--finance/fixc/pkg-descr5
4 files changed, 32 insertions, 0 deletions
diff --git a/finance/Makefile b/finance/Makefile
index a648f4aab0cc..344f7ad0e6fe 100644
--- a/finance/Makefile
+++ b/finance/Makefile
@@ -25,6 +25,7 @@
SUBDIR += cbb
SUBDIR += electrum
SUBDIR += expense
+ SUBDIR += fixc
SUBDIR += frontaccounting
SUBDIR += gnucash
SUBDIR += gnucash-docs
diff --git a/finance/fixc/Makefile b/finance/fixc/Makefile
new file mode 100644
index 000000000000..34742c7f22d9
--- /dev/null
+++ b/finance/fixc/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= fixc
+PORTVERSION= 1.0
+CATEGORIES= finance
+MASTER_SITES= http://github.com/blttll/${PORTNAME}/archive/v${PORTVERSION}.tar.gz?dummy=/
+DISTFILES= v${PORTVERSION}.tar.gz
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= blttll@gmail.com
+COMMENT= Simple Financial Information eXchange (FIX) protocol console client
+
+BUILD_DEPENDS= go:${PORTSDIR}/lang/go/
+
+PLIST_FILES= bin/fixc
+
+do-build:
+ cd ${WRKSRC} && \
+ go build -o fixc main.go
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/fixc ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/finance/fixc/distinfo b/finance/fixc/distinfo
new file mode 100644
index 000000000000..88e8c6aa039a
--- /dev/null
+++ b/finance/fixc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fixc/v1.0.tar.gz) = a73b3ea2cc4440a06206d219b472096ce635d8eebfe13671e0360af2ec02923e
+SIZE (fixc/v1.0.tar.gz) = 3709
diff --git a/finance/fixc/pkg-descr b/finance/fixc/pkg-descr
new file mode 100644
index 000000000000..203c34ffbc8e
--- /dev/null
+++ b/finance/fixc/pkg-descr
@@ -0,0 +1,5 @@
+fixc is a simple Financial Information eXchange (FIX) protocol console client.
+fixc connects to remote host and sends out FIX messages it reads from local
+scenario file.
+
+WWW: https://github.com/blttll/fixc