aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-07-21 16:26:42 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-07-21 16:26:42 +0000
commitb9449dd1dfb7446b19c9b45edeb362851ea76e39 (patch)
tree779604ebba3d88056d32a8aaeb73b2e5d9254de9 /finance
parent687f43f39f932908198953ddc6ff49d66a98041c (diff)
downloadports-b9449dd1dfb7446b19c9b45edeb362851ea76e39.tar.gz
ports-b9449dd1dfb7446b19c9b45edeb362851ea76e39.zip
Update to version 0.8.4
PR: 29021 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=45313
Diffstat (limited to 'finance')
-rw-r--r--finance/qhacc/Makefile10
-rw-r--r--finance/qhacc/distinfo2
-rw-r--r--finance/qhacc/files/patch-ac13
-rw-r--r--finance/qhacc/files/patch-ad13
4 files changed, 32 insertions, 6 deletions
diff --git a/finance/qhacc/Makefile b/finance/qhacc/Makefile
index 99d248b4ed9b..42bee64949b7 100644
--- a/finance/qhacc/Makefile
+++ b/finance/qhacc/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qhacc
-PORTVERSION= 0.8
+PORTVERSION= 0.8.4
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.ostrich-emulators.cx/qhacc/
@@ -24,11 +24,11 @@ post-extract:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/qhacc ${PREFIX}/bin
- @${MKDIR} ${PREFIX}/share/qhacc
- ${INSTALL_DATA} ${FILESDIR}/config ${PREFIX}/share/qhacc/config.sample
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${FILESDIR}/config ${DATADIR}/config.sample
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/qhacc
- ${INSTALL_DATA} ${WRKSRC}/docs/*.html ${PREFIX}/share/doc/qhacc
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/*.html ${DOCSDIR}
.endif
@${SED} -e "s:/usr/X11R6:${PREFIX}:g" ${PKGMESSAGE}
diff --git a/finance/qhacc/distinfo b/finance/qhacc/distinfo
index c418d54ce890..b00c6baf56c5 100644
--- a/finance/qhacc/distinfo
+++ b/finance/qhacc/distinfo
@@ -1 +1 @@
-MD5 (qhacc-0.8.tar.gz) = 67c63b7bd16d5e0596f41a5f71304f73
+MD5 (qhacc-0.8.4.tar.gz) = 82625b2666e43b23e488103774258e64
diff --git a/finance/qhacc/files/patch-ac b/finance/qhacc/files/patch-ac
new file mode 100644
index 000000000000..94c1aee027be
--- /dev/null
+++ b/finance/qhacc/files/patch-ac
@@ -0,0 +1,13 @@
+--- src/qhaccgrapher.cpp.orig Tue May 22 06:59:42 2001
++++ src/qhaccgrapher.cpp Sat Jul 14 04:45:41 2001
+@@ -763,8 +763,8 @@
+ display->setText( makeReport( title, headings, sums, partitions, type ) );
+ }
+
+-QString Reporter::makeReport( const QString& ti, const QString*& heads,
+- const float*& floats, int parts, int type ){
++QString Reporter::makeReport( const QString& ti, QString* heads,
++ float* floats, int parts, int type ){
+ QString text=ti+": ";
+ float sums[parts];
+
diff --git a/finance/qhacc/files/patch-ad b/finance/qhacc/files/patch-ad
new file mode 100644
index 000000000000..842a55081306
--- /dev/null
+++ b/finance/qhacc/files/patch-ad
@@ -0,0 +1,13 @@
+--- src/qhaccgrapher.h.orig Tue May 22 05:12:12 2001
++++ src/qhaccgrapher.h Sat Jul 14 04:46:09 2001
+@@ -96,8 +96,8 @@
+ Reporter( QWidget * =0, const char * =0 );
+ ~Reporter();
+
+- static QString makeReport( const QString&, const QString*&,
+- const float *&, int, int );
++ static QString makeReport( const QString&, QString*,
++ float *, int, int );
+
+ protected:
+ QTextView * display;