aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2008-04-17 11:28:29 +0000
committerMichael Johnson <ahze@FreeBSD.org>2008-04-17 11:28:29 +0000
commit11504bd9ed4be38c7814f8b1fa130891197c6a21 (patch)
treedd86aea0c69f185f933663b88d7da1c3007150a0 /finance
parent1123fc850f8df49b46f020254e27d3ad8418b48b (diff)
downloadports-11504bd9ed4be38c7814f8b1fa130891197c6a21.tar.gz
ports-11504bd9ed4be38c7814f8b1fa130891197c6a21.zip
Add options for POSTGRESQL, OFX
Submitted by: Martin Lesser <ml@bettercom.de>
Notes
Notes: svn path=/head/; revision=211438
Diffstat (limited to 'finance')
-rw-r--r--finance/gnucash/Makefile32
-rw-r--r--finance/gnucash/pkg-plist12
2 files changed, 36 insertions, 8 deletions
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index 2f885878928d..7c6d3b810017 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -19,7 +19,6 @@ COMMENT= Quicken-like money and finance manager
BUILD_DEPENDS= guile>=1.6.8_2:${PORTSDIR}/lang/guile \
${LOCALBASE}/share/guile/1.8/slibcat:${PORTSDIR}/lang/slib-guile
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
- ofx.4:${PORTSDIR}/finance/libofx \
gtkhtml-3.8.15:${PORTSDIR}/www/gtkhtml38 \
goffice-0.4:${PORTSDIR}/devel/goffice04
RUN_DEPENDS= guile>=1.6.8_2:${PORTSDIR}/lang/guile \
@@ -31,7 +30,9 @@ RUN_DEPENDS= guile>=1.6.8_2:${PORTSDIR}/lang/guile \
${SITE_PERL}/Finance/QuoteHist.pm:${PORTSDIR}/finance/p5-Finance-QuoteHist \
${LOCALBASE}/share/omf/gnucash-docs/gnucash-guide-C.omf:${PORTSDIR}/finance/gnucash-docs
-OPTIONS= AQBANKING "AqBanking support (HBCI/OpenHBCI)" off
+OPTIONS= AQBANKING "AqBanking support (HBCI/OpenHBCI)" off \
+ OFX "OFX support" off \
+ POSTGRESQL "Enable Postgresql as Backend" off
USE_BZIP2= yes
USE_GETTEXT= yes
@@ -44,11 +45,10 @@ USE_GNOME= gnomeprefix libgsf_gnome libglade2 \
libgnomeprint libgnomeprintui
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
+GC_LIBS= -L${LOCALBASE}/lib -lintl
CONFIGURE_ARGS=--with-glib-config=${GLIB_CONFIG} \
- --enable-ofx \
--disable-error-on-warning
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lintl"
MAN1= gnc-prices.1 gnucash.1
INFO= gnucash-design
@@ -75,10 +75,32 @@ GCONF_SCHEMAS= apps_gnucash_dialog_business_common.schemas \
LIB_DEPENDS+= aqbanking.21:${PORTSDIR}/finance/aqbanking \
ktoblzcheck.6:${PORTSDIR}/finance/ktoblzcheck
CONFIGURE_ARGS+=--enable-hbci
+GC_LIBS+= -laqbanking
PLIST_SUB+= AQBANKING=""
.else
CONFIGURE_ARGS+=--disable-hbci
PLIST_SUB+= AQBANKING="@comment "
.endif
+.if defined(WITH_OFX)
+CONFIGURE_ARGS+=--enable-ofx
+LIB_DEPENDS+= ofx.4:${PORTSDIR}/finance/libofx
+PLIST_SUB+= OFX=""
+.else
+CONFIGURE_ARGS+=--disable-ofx
+PLIST_SUB+= OFX="@comment "
+.endif
+
+.if defined(WITH_POSTGRESQL)
+CONFIGURE_ARGS+=--enable-sql
+PLIST_SUB+= PGBACKEND=""
+USE_PGSQL+= yes
+GC_LIBS+= -lpq
+.else
+CONFIGURE_ARGS+=--disable-sql
+PLIST_SUB+= PGBACKEND="@comment "
+.endif
+
+CONFIGURE_ENV+= LIBS="${GC_LIBS}"
+
.include <bsd.port.post.mk>
diff --git a/finance/gnucash/pkg-plist b/finance/gnucash/pkg-plist
index a779ae60cdfd..e608aa91a475 100644
--- a/finance/gnucash/pkg-plist
+++ b/finance/gnucash/pkg-plist
@@ -222,14 +222,16 @@ lib/gnucash/libgncmod-gnome-search.la
lib/gnucash/libgncmod-gnome-search.so
lib/gnucash/libgncmod-gnome-utils.la
lib/gnucash/libgncmod-gnome-utils.so
+%%AQBANKING%%lib/gnucash/libgncmod-hbci.la
+%%AQBANKING%%lib/gnucash/libgncmod-hbci.so
lib/gnucash/libgncmod-ledger-core.la
lib/gnucash/libgncmod-ledger-core.so
lib/gnucash/libgncmod-locale-reports-us.la
lib/gnucash/libgncmod-locale-reports-us.so
lib/gnucash/libgncmod-log-replay.la
lib/gnucash/libgncmod-log-replay.so
-lib/gnucash/libgncmod-ofx.la
-lib/gnucash/libgncmod-ofx.so
+%%OFX%%lib/gnucash/libgncmod-ofx.la
+%%OFX%%lib/gnucash/libgncmod-ofx.so
lib/gnucash/libgncmod-qif-import.la
lib/gnucash/libgncmod-qif-import.so
lib/gnucash/libgncmod-qif.la
@@ -625,6 +627,9 @@ share/gnucash/glade/fincalc.glade
share/gnucash/glade/generic-import.glade
share/gnucash/glade/gnc-date-format.glade
share/gnucash/glade/gnc-gui-query.glade
+%%AQBANKING%%share/gnucash/glade/hbci.glade
+%%AQBANKING%%share/gnucash/glade/hbcipass.glade
+%%AQBANKING%%share/gnucash/glade/hbciprefs.glade
share/gnucash/glade/import-provider-format.glade
share/gnucash/glade/invoice.glade
share/gnucash/glade/job.glade
@@ -802,8 +807,9 @@ share/gnucash/ui/gnc-plugin-basic-commands-ui.xml
share/gnucash/ui/gnc-plugin-budget-ui.xml
share/gnucash/ui/gnc-plugin-business-ui.xml
share/gnucash/ui/gnc-plugin-file-history-ui.xml
+%%AQBANKING%%share/gnucash/ui/gnc-plugin-hbci-ui.xml
share/gnucash/ui/gnc-plugin-log-replay-ui.xml
-share/gnucash/ui/gnc-plugin-ofx-ui.xml
+%%OFX%%share/gnucash/ui/gnc-plugin-ofx-ui.xml
share/gnucash/ui/gnc-plugin-page-account-tree-ui.xml
share/gnucash/ui/gnc-plugin-page-budget-ui.xml
share/gnucash/ui/gnc-plugin-page-invoice-ui.xml