aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-08-21 06:18:49 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-08-21 06:18:49 +0000
commit741aa714833b9bb1e9afaaf5124d3f5c60b5e49c (patch)
treee9b79b363f2fc4a63535a25c71491fa49a79b556 /finance
parente6b2e4b3537ce43e377d2f4fe0ac46b6ab8c4395 (diff)
downloadports-741aa714833b9bb1e9afaaf5124d3f5c60b5e49c.tar.gz
ports-741aa714833b9bb1e9afaaf5124d3f5c60b5e49c.zip
Update CONFIGURE_ARGS for how we pass CONFIGURE_TARGET to configure script.
Specifically, newer autoconf (> 2.13) has different semantic of the configure target. In short, one should use --build=CONFIGURE_TARGET instead of CONFIGURE_TARGET directly. Otherwise, you will get a warning and the old semantic may be removed in later autoconf releases. To workaround this issue, many ports hack the CONFIGURE_TARGET variable so that it contains the ``--build='' prefix. To solve this issue, under the fact that some ports still have configure script generated by the old autoconf, we use runtime detection in the do-configure target so that the proper argument can be used. Changes to Mk/*: - Add runtime detection magic in bsd.port.mk - Remove CONFIGURE_TARGET hack in various bsd.*.mk - USE_GNOME=gnometarget is now an no-op Changes to individual ports, other than removing the CONFIGURE_TARGET hack: = pkg-plist changed (due to the ugly CONFIGURE_TARGET prefix in * executables) - comms/gnuradio - science/abinit - science/elmer-fem - science/elmer-matc - science/elmer-meshgen2d - science/elmerfront - science/elmerpost = use x86_64 as ARCH - devel/g-wrap = other changes - print/magicfilter GNU_CONFIGURE -> HAS_CONFIGURE since it's not generated by autoconf Total # of ports modified: 1,027 Total # of ports affected: ~7,000 (set GNU_CONFIGURE to yes) PR: 126524 (obsoletes 52917) Submitted by: rafan Tested on: two pointyhat 7-amd64 exp runs (by pav) Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=218938
Diffstat (limited to 'finance')
-rw-r--r--finance/aqbanking/Makefile1
-rw-r--r--finance/aqmoney/Makefile1
-rw-r--r--finance/khacc/Makefile1
-rw-r--r--finance/ledger/Makefile1
-rw-r--r--finance/openhbci/Makefile1
-rw-r--r--finance/qhacc/Makefile1
-rw-r--r--finance/quantlib/Makefile1
7 files changed, 0 insertions, 7 deletions
diff --git a/finance/aqbanking/Makefile b/finance/aqbanking/Makefile
index 9adc309623bc..428c8c50b6a6 100644
--- a/finance/aqbanking/Makefile
+++ b/finance/aqbanking/Makefile
@@ -32,7 +32,6 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -L${LOCALBASE}/lib \
${QTCPPFLAGS} ${PTHREAD_CFLAGS}"
CONFIGURE_ENV+= LIBS="${QTCFGLIBS} ${PTHREAD_LIBS}"
CONFIGURE_ENV+= QTDIR="${QT_PREFIX}"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_LDCONFIG= yes
diff --git a/finance/aqmoney/Makefile b/finance/aqmoney/Makefile
index 8c022e01c3df..b813ad426fef 100644
--- a/finance/aqmoney/Makefile
+++ b/finance/aqmoney/Makefile
@@ -16,7 +16,6 @@ COMMENT= Manage your credit institute accounts using openhbci
LIB_DEPENDS= openhbci.14:${PORTSDIR}/finance/openhbci
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= aqmoney.1
PLIST_FILES= bin/aqmoney
diff --git a/finance/khacc/Makefile b/finance/khacc/Makefile
index bc9baacbb5e5..6b7eb87d1c8a 100644
--- a/finance/khacc/Makefile
+++ b/finance/khacc/Makefile
@@ -21,7 +21,6 @@ USE_KDELIBS_VER=3
USE_PERL5_BUILD=yes
USE_GMAKE= yes
USE_AUTOTOOLS= automake:19:env autoconf:262:env libtool:15
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-qhacc-config=${LOCALBASE}/bin
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
diff --git a/finance/ledger/Makefile b/finance/ledger/Makefile
index 01ec4efe0c2f..c8fe09e3643a 100644
--- a/finance/ledger/Makefile
+++ b/finance/ledger/Makefile
@@ -24,7 +24,6 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/w3c-libwww
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_TARGET?= --build=${ARCH}-portbld-freebsd${OSREL}
NO_INSTALL_MANPAGES= yes
INFO= ledger
diff --git a/finance/openhbci/Makefile b/finance/openhbci/Makefile
index 8d13754e7f02..23bf529d2cc1 100644
--- a/finance/openhbci/Makefile
+++ b/finance/openhbci/Makefile
@@ -17,7 +17,6 @@ COMMENT= HBCI is a bank-independent homebanking standard
USE_AUTOTOOLS= libtool:15
WRKSRC= ${WRKDIR}/${PORTNAME}-0.9.17
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/finance/qhacc/Makefile b/finance/qhacc/Makefile
index ff58d3803c03..c3d83a5d74b7 100644
--- a/finance/qhacc/Makefile
+++ b/finance/qhacc/Makefile
@@ -20,7 +20,6 @@ USE_AUTOTOOLS= libtool:15
USE_QT_VER= 3
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-qt-moc=${QT_PREFIX}/bin \
--with-qt-libs=${QT_PREFIX}/lib
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
diff --git a/finance/quantlib/Makefile b/finance/quantlib/Makefile
index 9fcc0175b3d9..aad1258faf00 100644
--- a/finance/quantlib/Makefile
+++ b/finance/quantlib/Makefile
@@ -22,7 +22,6 @@ WRKSRC= ${WRKDIR}/QuantLib-${PORTVERSION}
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" LDFLAGS="${PTHREAD_LIBS} -L${LOCALBASE}/lib"
USE_LDCONFIG= yes