aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2010-10-03 17:04:08 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2010-10-03 17:04:08 +0000
commite9ddf6b3f61113bc7aa25a8c4bf17e682ed48409 (patch)
tree9b25596bb099319f75eb7ade174115c7a91cecfd /finance
parent7f1bc9ce2c3fc3d73d2e9b995ad1d5cc186e4c0b (diff)
downloadports-e9ddf6b3f61113bc7aa25a8c4bf17e682ed48409.tar.gz
ports-e9ddf6b3f61113bc7aa25a8c4bf17e682ed48409.zip
Fix the quote price editor adds price data as wrong date. Bump the
PORTREVISION. More details by the submitter: "gnucash quote price editor consume date string and convert the string by strptime(3) then get time_t by mktime(3). And struct tm, a mktime argument is not initialized and mktime detects insane structure and returns -1. So the entry is always added as epoch -1 date." PR: ports/138410 Submitted by: Takanori Watanabe <takawata@init-main.com>
Notes
Notes: svn path=/head/; revision=262355
Diffstat (limited to 'finance')
-rw-r--r--finance/gnucash/Makefile2
-rw-r--r--finance/gnucash/files/patch-src_app-utils_guile-util.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index d146f83305ca..1ccc1afac8b2 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gnucash
PORTVERSION= 2.2.9
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= finance gnome
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20%28stable%29/${PORTVERSION} \
http://www.gnucash.org/pub/gnucash/sources/stable/
diff --git a/finance/gnucash/files/patch-src_app-utils_guile-util.c b/finance/gnucash/files/patch-src_app-utils_guile-util.c
new file mode 100644
index 000000000000..de8f77cdf17d
--- /dev/null
+++ b/finance/gnucash/files/patch-src_app-utils_guile-util.c
@@ -0,0 +1,11 @@
+--- src/app-utils/guile-util.c.orig 2008-01-08 10:06:47.000000000 +0900
++++ src/app-utils/guile-util.c 2009-09-01 03:04:30.000000000 +0900
+@@ -1304,6 +1304,8 @@
+
+ g_return_val_if_fail(s && format, -1);
+
++ bzero(&tm, sizeof(tm));
++
+ if (!strptime(s, format, &tm))
+ return -1;
+