aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-12-31 05:48:35 +0000
committerWill Andrews <will@FreeBSD.org>2000-12-31 05:48:35 +0000
commit441bdcd6a5240032827d0607153516fc663b914d (patch)
treef597b110a834b4275bd1099513f2f729c41a5bf2 /finance
parent3afad9b84d9ee11aae4e6d1400063bd1e0eabb5d (diff)
downloadports-441bdcd6a5240032827d0607153516fc663b914d.tar.gz
ports-441bdcd6a5240032827d0607153516fc663b914d.zip
Add p5-Finance-Quote 1.04, a perl module to obtain stock and mutual fund
quotes from various exchanges. PR: 23854 Submitted by: Sergey Skvortsov <skv@protey.ru>
Notes
Notes: svn path=/head/; revision=36509
Diffstat (limited to 'finance')
-rw-r--r--finance/p5-Finance-Quote/Makefile39
-rw-r--r--finance/p5-Finance-Quote/distinfo1
-rw-r--r--finance/p5-Finance-Quote/output6
-rw-r--r--finance/p5-Finance-Quote/pkg-comment1
-rw-r--r--finance/p5-Finance-Quote/pkg-descr1
-rw-r--r--finance/p5-Finance-Quote/pkg-plist19
6 files changed, 67 insertions, 0 deletions
diff --git a/finance/p5-Finance-Quote/Makefile b/finance/p5-Finance-Quote/Makefile
new file mode 100644
index 000000000000..118a0c91f36d
--- /dev/null
+++ b/finance/p5-Finance-Quote/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: Finance::Quote
+# Date created: 26 Dec 2000
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Finance-Quote
+PORTVERSION= 1.04
+CATEGORIES= misc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Finance
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@protey.ru
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTML/TableExtract.pm:${PORTSDIR}/www/p5-HTML-TableExtract \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTTP/Request/Common.pm:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTML/TableExtract.pm:${PORTSDIR}/www/p5-HTML-TableExtract \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTTP/Request/Common.pm:${PORTSDIR}/www/p5-libwww
+
+USE_PERL5= yes
+
+MAN3= Finance::Quote::Tiaacref.3 Finance::Quote::Yahoo::Europe.3\
+ Finance::Quote.3 Finance::Quote::VWD.3\
+ Finance::Quote::Troweprice.3 Finance::Quote::Yahoo::Australia.3\
+ Finance::Quote::Yahoo::USA.3 Finance::Quote::Trustnet.3\
+ Finance::Quote::Yahoo::Base.3 Finance::Quote::Fidelity.3\
+ Finance::Quote::ASX.3 Finance::Quote::DWS.3
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @cd ${WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL PREFIX=${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/finance/p5-Finance-Quote/distinfo b/finance/p5-Finance-Quote/distinfo
new file mode 100644
index 000000000000..5661b4351a7a
--- /dev/null
+++ b/finance/p5-Finance-Quote/distinfo
@@ -0,0 +1 @@
+MD5 (Finance-Quote-1.04.tar.gz) = 3753e4dc730334f63cf93360d78adc86
diff --git a/finance/p5-Finance-Quote/output b/finance/p5-Finance-Quote/output
new file mode 100644
index 000000000000..7f6584c2025f
--- /dev/null
+++ b/finance/p5-Finance-Quote/output
@@ -0,0 +1,6 @@
+Add Finance-Quote 1.04, Finance::[a-z]uote - [a-z]et stock and mutual fund quotes from various exchan
+ges
+.
+
+PR: 23854
+Submitted by: Sergey Skvortsov <skv@protey.ru>
diff --git a/finance/p5-Finance-Quote/pkg-comment b/finance/p5-Finance-Quote/pkg-comment
new file mode 100644
index 000000000000..ab7c8094c7fc
--- /dev/null
+++ b/finance/p5-Finance-Quote/pkg-comment
@@ -0,0 +1 @@
+A perl module to get stock and mutual fund quotes from various exchanges
diff --git a/finance/p5-Finance-Quote/pkg-descr b/finance/p5-Finance-Quote/pkg-descr
new file mode 100644
index 000000000000..62c26f7dbd3a
--- /dev/null
+++ b/finance/p5-Finance-Quote/pkg-descr
@@ -0,0 +1 @@
+Finance::Quote - Get stock and mutual fund quotes from various exchanges
diff --git a/finance/p5-Finance-Quote/pkg-plist b/finance/p5-Finance-Quote/pkg-plist
new file mode 100644
index 000000000000..17717c7f064f
--- /dev/null
+++ b/finance/p5-Finance-Quote/pkg-plist
@@ -0,0 +1,19 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Finance/Quote/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Finance/Quote.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/Quote/ASX.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/Quote/DWS.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/Quote/Fidelity.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/Quote/Tiaacref.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/Quote/Troweprice.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/Quote/Trustnet.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/Quote/UserAgent.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/Quote/VWD.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/Quote/Yahoo/Australia.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/Quote/Yahoo/Base.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/Quote/Yahoo/Europe.pm
+lib/perl5/site_perl/%%PERL_VER%%/Finance/Quote/Yahoo/USA.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Finance/Quote/Yahoo
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Finance/Quote
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Finance/Quote
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Finance 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Finance 2>/dev/null || true