aboutsummaryrefslogtreecommitdiff
path: root/french
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-12-29 06:24:17 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-12-29 06:24:17 +0000
commit3afe2677b4d53652848af9f7a142ed608156f8ac (patch)
treedaa513af3b898b5a6cbd0e71195c5718ff6efcc6 /french
parentc2af1af70bf6ebf215e92bc05278cffc1f64b976 (diff)
downloadports-3afe2677b4d53652848af9f7a142ed608156f8ac.tar.gz
ports-3afe2677b4d53652848af9f7a142ed608156f8ac.zip
french/facturier: fixing ${APACHE_PORT} usage.
Problem reported by Matthew Seaman: The french/facturier port uses the ${APACHE_PORT} variable in a manner inconsistent with most other ports that depend on apache, and with the usage in bsd.ports.mk. (also added WWWOWN/WWWGRP) PR: ports/60665 Submitted by: Thierry Thomas <thierry@pompo.net>
Notes
Notes: svn path=/head/; revision=96850
Diffstat (limited to 'french')
-rw-r--r--french/facturier/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/french/facturier/Makefile b/french/facturier/Makefile
index 1bfd3784c8ab..113df07f5403 100644
--- a/french/facturier/Makefile
+++ b/french/facturier/Makefile
@@ -14,8 +14,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= thierry@pompo.net
COMMENT= Logiciel de facturation pour P.M.I. & P.M.E.
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${APACHE_PORT}
-RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${APACHE_PORT} \
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/${APACHE_PORT}
+RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/${APACHE_PORT} \
${LOCALBASE}/bin/htmldoc:${PORTSDIR}/textproc/htmldoc \
${PBASE}/${PERL_ARCH}/Mysql.pm:${PORTSDIR}/databases/p5-Mysql \
${PBASE}/Tie/IxHash.pm:${PORTSDIR}/devel/p5-Tie-IxHash
@@ -27,7 +27,7 @@ USE_PERL5_RUN= yes
USE_MYSQL= yes
USE_REINPLACE= yes
-APACHE_PORT?= ${PORTSDIR}/www/apache13
+APACHE_PORT?= www/apache13
APACHE_CNFDIR?= ${LOCALBASE}/etc/apache
APACHE_CONF= ${APACHE_CNFDIR}/httpd.conf
PBASE= ${SITE_PERL}
@@ -80,7 +80,7 @@ do-install:
@${RM} ${FACT_CNF}.beforeFacturier
@${CP} -p ${FACT_CNF} ${FACT_CNF}.dist
# Set perms
- @${CHOWN} -R www:www ${FACT_REP}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${FACT_REP}
@${CHMOD} -R 644 ${FACT_REP}
@${FIND} ${FACT_REP} -type d -exec ${CHMOD} a+x {} \;
@${CHMOD} -R u+x ${FACT_REP}/cgi-bin