aboutsummaryrefslogtreecommitdiff
path: root/french
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2003-07-24 15:53:43 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2003-07-24 15:53:43 +0000
commit70555809f165e09903b45f1495b9a67f385c2bd2 (patch)
tree67164f01e46e29bea0e19d80f476e0ba173c6ace /french
parent968a91ee79bf95e8cc0a43f89f5a2207982b105e (diff)
downloadports-70555809f165e09903b45f1495b9a67f385c2bd2.tar.gz
ports-70555809f165e09903b45f1495b9a67f385c2bd2.zip
1) fix "make -V PORTNAME"
2) change post-patch target to reflect distfile changes between the PR-based distfile and the Committed-distfile Submitted by: Dan Langille <dan@langille.org> [1] Thierry Thomas <thierry@pompo.net> [2]
Notes
Notes: svn path=/head/; revision=85533
Diffstat (limited to 'french')
-rw-r--r--french/homard/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/french/homard/Makefile b/french/homard/Makefile
index 83de0853a633..7a22d6dd80a4 100644
--- a/french/homard/Makefile
+++ b/french/homard/Makefile
@@ -7,6 +7,7 @@
PORTNAME= homard
PORTVERSION= 5.5
+PORTREVISION= 1
CATEGORIES= french cad linux python
MASTER_SITES= http://www.code-aster.org/FICHIERS/homard/
DISTNAME= ${PORTNAME}_linux_${PORTVERSION}
@@ -35,27 +36,29 @@ ASTER_VER= 7.1
vaster= STA${ASTER_VER}
ASTER_TOOLS= ${LOCALBASE}/aster/${vaster}/outils
HOMARDDIR= ${PREFIX}/${LHOMARDDIR}
-unames!= ${UNAME} -s
AHPY= aster_homard_py
# This name is requested to run aster's make test
HOMARDPG= ${PORTNAME:U}_V${PORTVERSION}.out
-PLIST_SUB= HOMARDDIR=${LHOMARDDIR} AHPY=${LHOMARDDIR}/${AHPY} UNAMES=${unames} \
- HOMARDPG=${HOMARDPG}
+
+.include <bsd.port.pre.mk>
+
+unames!= ${UNAME} -s
+PLIST_SUB= HOMARDDIR=${LHOMARDDIR} AHPY=${LHOMARDDIR}/${AHPY} \
+ UNAMES=${unames} HOMARDPG=${HOMARDPG}
BRANDELF?= /usr/bin/brandelf
post-patch:
- @${REINPLACE_CMD} -e "s#HOMARD_REP_PRO=/??????/homard#HOMARD_REP_PRO=${ASTER_TOOLS}#" \
- -e "s#HOMARD_REP_EXE=/??????/homard#HOMARD_REP_EXE=${PREFIX}/bin#" \
- -e "s#/??????/python#${PYTHON_CMD}#" \
+ @${REINPLACE_CMD} -e "s#HOMARD_REP_PRO=/??????#HOMARD_REP_PRO=${ASTER_TOOLS}#" \
+ -e "s#HOMARD_REP_EXE=/??????#HOMARD_REP_EXE=${PREFIX}/bin#" \
+ -e "s#/??????#${PYTHON_CMD}#" \
${WRKSRC}/${PORTNAME}
@${CHMOD} u+w ${WRKSRC}/${AHPY}
do-install:
${MKDIR} ${HOMARDDIR}
${MKDIR} ${PREFIX}/bin/${unames}
- ${INSTALL_PROGRAM} ${WRKDIR}/${HOMARDPG} \
- ${PREFIX}/bin/${unames}/${HOMARDPG}
+ ${INSTALL_PROGRAM} ${WRKDIR}/${HOMARDPG} ${PREFIX}/bin/${unames}
${BRANDELF} -t Linux ${PREFIX}/bin/${unames}/${HOMARDPG}
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${HOMARDDIR}
${CP} -R ${WRKSRC}/${AHPY} ${HOMARDDIR}
@@ -68,4 +71,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>