aboutsummaryrefslogtreecommitdiff
path: root/french
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-07 18:34:07 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-07 18:34:07 +0000
commit281a55555a7d66ba836bf27f7eb1ad250cadafa4 (patch)
treeaee2285517dec3476da0b7107d9ebce773a63698 /french
parentffdf5e4fc2c28121e636af8ef16c4715d166e533 (diff)
downloadports-281a55555a7d66ba836bf27f7eb1ad250cadafa4.tar.gz
ports-281a55555a7d66ba836bf27f7eb1ad250cadafa4.zip
PERL -> REINPLACE_CMD
PR: 40289 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=62590
Diffstat (limited to 'french')
-rw-r--r--french/xtel/Makefile6
-rw-r--r--french/xtel/files/patch-Videotex_Videotex.c11
2 files changed, 14 insertions, 3 deletions
diff --git a/french/xtel/Makefile b/french/xtel/Makefile
index a55da391b536..43c594dd5288 100644
--- a/french/xtel/Makefile
+++ b/french/xtel/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
USE_IMAKE= yes
USE_XPM= yes
+USE_REINPLACE= yes
MAN1= xtel.1 xteld.1
@@ -37,10 +38,9 @@ PATCH_FILES= Imakefile
post-patch:
.for FILE in ${PATCH_FILES}
- @${PERL} -pi -e "s:%%LOCALBASE%%:${LOCALBASE}:g" ${WRKSRC}/${FILE}
+ ${CHMOD} u+w ${WRKSRC}/${FILE}
+ ${REINPLACE_CMD} -e "s:%%LOCALBASE%%:${LOCALBASE}:g" ${WRKSRC}/${FILE}
.endfor
- find ${WRKSRC} -type f | xargs ${PERL} -pi -e \
- "s@#include.*<malloc.h>@#include <stdlib.h>@g"
pre-configure:
.if !exists(${PREFIX}/lib/X11/config/host.def)
diff --git a/french/xtel/files/patch-Videotex_Videotex.c b/french/xtel/files/patch-Videotex_Videotex.c
new file mode 100644
index 000000000000..7b5c4f9bcfd1
--- /dev/null
+++ b/french/xtel/files/patch-Videotex_Videotex.c
@@ -0,0 +1,11 @@
+--- Videotex/Videotex.c.orig Sun Feb 11 01:13:00 2001
++++ Videotex/Videotex.c Sun Jul 7 13:17:57 2002
+@@ -22,7 +22,7 @@
+ /*
+ * Widget Videotex: VideotexWidgetClass
+ */
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <ctype.h>
+ #include <X11/IntrinsicP.h>
+ #include <X11/StringDefs.h>