aboutsummaryrefslogtreecommitdiff
path: root/french
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2010-11-14 22:00:23 +0000
committerThierry Thomas <thierry@FreeBSD.org>2010-11-14 22:00:23 +0000
commit7db179edb42024999f5ac287c3d633aad02c87ca (patch)
tree8c224de6d8dc6d3ee24f9a70da7351c634faba30 /french
parent9057d8b613a28938f843b07ce1ecc519556ce99f (diff)
downloadports-7db179edb42024999f5ac287c3d633aad02c87ca.tar.gz
ports-7db179edb42024999f5ac287c3d633aad02c87ca.zip
Chase the upgrade of MPICH2.
Notes
Notes: svn path=/head/; revision=264536
Diffstat (limited to 'french')
-rw-r--r--french/aster/Makefile8
-rw-r--r--french/aster/files/patch-products.py6
2 files changed, 8 insertions, 6 deletions
diff --git a/french/aster/Makefile b/french/aster/Makefile
index 5371fa4a6ccb..3e98b7239766 100644
--- a/french/aster/Makefile
+++ b/french/aster/Makefile
@@ -7,6 +7,7 @@
PORTNAME= aster
DISTVERSION= ${ASTER_DISTVERSION}
+PORTREVISION= 1
CATEGORIES= french cad
MAINTAINER= thierry@FreeBSD.org
@@ -131,13 +132,13 @@ MUMPS_PORT= mumps
BUILD_DEPENDS+= ${LOCALBASE}/lib/libblacs.a:${PORTSDIR}/math/blacs \
${LOCALBASE}/lib/libscalapack.a:${PORTSDIR}/math/scalapack
MUMPS_PORT= mumps-mpich
-MUMPSLIB= -L${LOCALBASE}/lib -ldmumps -lzmumps -lmumps_common -lpord -lscalapack -lblacs -lblacsc -lblacs -L${LOCALBASE}/lib -lmpich
+MUMPSLIB= -L${LOCALBASE}/lib -ldmumps -lzmumps -lmumps_common -lpord -lscalapack -lblacs -lblacsc -lblacs -L${LOCALBASE}/lib -lmpich -lmpl
. endif
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcmumps.a:${PORTSDIR}/math/${MUMPS_PORT}
.endif
.if defined(WITH_MPI)
-BUILD_DEPENDS+= ${HOME_MPI}/include/mpif.h:${PORTSDIR}/net/mpich2
+LIB_DEPENDS+= mpich.2:${PORTSDIR}/net/mpich2
HOME_MPI= ${LOCALBASE}
.endif
@@ -220,7 +221,7 @@ ${WRKSRC}/instdir/${vaster}/elements: build
pre-everything::
.if defined(WITH_MPI)
- @${ECHO_MSG} "To build Code_Aster with MPI enabled, you need to run `mpd &'"
+ @${ECHO_MSG} "To build Code_Aster with MPI enabled, you need to run \`mpd &'"
.endif
pre-configure:
@@ -337,6 +338,7 @@ pre-build:
${ECHO_CMD} "#?vers : VVV?" >> ${WRKSRC}/instdir/etc/codeaster/aster
${CP} -R ${LOCALBASE}/aster/ASTK/ASTK_SERV/bin \
${LOCALBASE}/aster/ASTK/ASTK_SERV/asrun \
+ ${LOCALBASE}/aster/ASTK/ASTK_SERV/share \
${WRKSRC}/instdir/
${REINPLACE_CMD} -e 's|${LOCALBASE}/aster|${WRKSRC}/instdir|' \
${WRKSRC}/instdir/bin/as_run
diff --git a/french/aster/files/patch-products.py b/french/aster/files/patch-products.py
index f5519abafd7c..c1942733412d 100644
--- a/french/aster/files/patch-products.py
+++ b/french/aster/files/patch-products.py
@@ -1,5 +1,5 @@
---- products.py.orig 2010-07-07 18:18:13.000000000 +0200
-+++ products.py 2010-08-12 19:08:43.000000000 +0200
+--- products.py.orig 2010-09-14 10:48:26.000000000 +0200
++++ products.py 2010-10-25 22:53:13.000000000 +0200
@@ -907,16 +907,19 @@
'HOME_PYTHON', 'PYTHON_EXE', 'PYTHONLIB',
'HOME_MUMPS', 'HOME_ZMAT', 'HOME_MPI', 'INCLUDE_MUMPS', 'HOME_METIS',
@@ -40,7 +40,7 @@
+ opt['FINCLUDE'] = ''
+ cxxlibs.extend(['stdc++', 'supc++'])
+ zmat_platform=''
-+ mpilibs.extend(['mpich'])
++ mpilibs.extend(['mpich', 'mpl'])
elif cfg['IFDEF'] == 'LINUX64':
opt['SYSLIB'] = '-Wl,--allow-multiple-definition -Wl,--export-dynamic -lieee -ldl -lutil -lm'
opt['LDFLAGS'] = '-v'