aboutsummaryrefslogtreecommitdiff
path: root/ftp/axyftp/Makefile
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>1998-12-01 22:11:59 +0000
committerBill Fumerola <billf@FreeBSD.org>1998-12-01 22:11:59 +0000
commite5bf04b47faed59fd4725cd2ca5da14bbad78cf4 (patch)
treee892932302a383ea25edd94be602a6aeaeaad4a3 /ftp/axyftp/Makefile
parent4eb463c27ee73e57177f2cf33f8921a3f4fb9170 (diff)
downloadports-e5bf04b47faed59fd4725cd2ca5da14bbad78cf4.tar.gz
ports-e5bf04b47faed59fd4725cd2ca5da14bbad78cf4.zip
Initial Import.
WXftp is an X Window System FTP client Major features available in current (0.4.0) release: o User-friendly, intuitive interface (both GTK+ and Motif). o Passive data transfers o Convenient session manager window o On-line help system o Recursive downloads with resume option o Recursive uploads o Multiple delete with option to recurse o Auto-redial option WXftp is copyright (c) 1998 by Alexander Yukhimets <alexy@edgarmail.com>. All right under the copyright reserved. This committer thinks this program is really neat as well. :> PR: ports/8413 Submitted by: Dirk Froemberg <ibex@physik.TU-Berlin.de>
Notes
Notes: svn path=/head/; revision=15027
Diffstat (limited to 'ftp/axyftp/Makefile')
-rw-r--r--ftp/axyftp/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/ftp/axyftp/Makefile b/ftp/axyftp/Makefile
new file mode 100644
index 000000000000..4d197b91fce2
--- /dev/null
+++ b/ftp/axyftp/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: wxftp
+# Version required: 0.4.0
+# Date created: 22 October 1998
+# Whom: Antti Kaipila <anttik@iki.fi>
+#
+# $Id$
+#
+
+DISTNAME= wxftp-0.4.0.src
+PKGNAME= wxftp-0.4.0
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= system/network/file-transfer
+
+MAINTAINER= anttik@iki.fi
+
+LIB_DEPENDS= gtk.1:${PORTSDIR}/x11-toolkits/gtk
+
+WRKSRC= ${WRKDIR}/${PKGNAME}/src
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+MAN1= wxftp.1
+
+post-build:
+
+ @${CP} ${WRKSRC}/wf ${WRKDIR}/${PKGNAME}/wxftp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/${PKGNAME}/wxftp ${PREFIX}/bin
+ @${CP} ${WRKDIR}/${PKGNAME}/wxftp.1X ${WRKDIR}/${PKGNAME}/wxftp.1
+ ${INSTALL_MAN} ${WRKDIR}/${PKGNAME}/wxftp.1 ${PREFIX}/man/man1
+ @${MKDIR} ${PREFIX}/share/wxftp/help
+ ${INSTALL_DATA} ${WRKDIR}/${PKGNAME}/help/* ${PREFIX}/share/wxftp/help
+
+.include <bsd.port.mk>