aboutsummaryrefslogtreecommitdiff
path: root/ftp/curl/Makefile
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-06-16 13:23:13 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-06-16 13:23:13 +0000
commit5b55a8a53e383d5e641472b56a6d631e59da3967 (patch)
treef5237f7173e7b9a5cbac11e6a57f460d84e79314 /ftp/curl/Makefile
parent769a9f1570ce818b49b6170bf5745363ffbe79e0 (diff)
downloadports-5b55a8a53e383d5e641472b56a6d631e59da3967.tar.gz
ports-5b55a8a53e383d5e641472b56a6d631e59da3967.zip
Fix usage of WITH_OPENSSL_BASE, WITH_OPENSSL_PORT and OPENSSL_PORT.
WITH_OPENSSL_* can't be set after bsd.port.pre.mk. Fold all other usage into using SSL_DEFAULT == foo PR: 210149 Submitted by: mat Exp-run by: antoine Sponsored by: The FreeBSD Foundation, Absolight Differential Revision: https://reviews.freebsd.org/D6577
Notes
Notes: svn path=/head/; revision=416966
Diffstat (limited to 'ftp/curl/Makefile')
-rw-r--r--ftp/curl/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 890067ac0361..9ce59ff60b76 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -32,7 +32,10 @@ THREADED_RESOLVER_DESC= Threaded DNS resolver
TLS_SRP_DESC= TLS-SRP (Secure Remote Password) support
LOCALBASE?= /usr/local
-.if defined(WITH_OPENSSL_PORT) || (!defined(WITH_OPENSSL_BASE) && exists(${LOCALBASE}/lib/libcrypto.so))
+
+.include <${PORTSDIR}/Mk/bsd.default-versions.mk>
+
+.if ${SSL_DEFAULT} != base
OPTIONS_DEFAULT+= GSSAPI_NONE
.else
OPTIONS_DEFAULT+= GSSAPI_BASE
@@ -148,11 +151,11 @@ IGNORE= only supports TLS-SRP with either OpenSSL or GnuTLS
IGNORE= only supports LDAPS with SSL
.endif
-.if ${PORT_OPTIONS:MGSSAPI_BASE} && ${PORT_OPTIONS:MOPENSSL} && (defined(WITH_OPENSSL_PORT) || (!defined(WITH_OPENSSL_BASE) && exists(${LOCALBASE}/lib/libcrypto.so)))
+.if ${PORT_OPTIONS:MGSSAPI_BASE} && ${PORT_OPTIONS:MOPENSSL} && ${SSL_DEFAULT} != base
IGNORE= GSSAPI_BASE is not compatible with OpenSSL from ports. Use other GSSAPI options or OpenSSL from base system
.endif
-.if defined(OPENSSL_PORT) && ${OPENSSL_PORT} == "security/libressl"
+.if ${SSL_DEFAULT} == libressl
.if ${PORT_OPTIONS:MGSSAPI_BASE} && ${PORT_OPTIONS:MOPENSSL}
IGNORE= GSSAPI_BASE is not compatible with LibreSSL. Use other GSSAPI options
.endif