aboutsummaryrefslogtreecommitdiff
path: root/ftp/curl
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2003-09-01 08:47:18 +0000
committerPeter Pentchev <roam@FreeBSD.org>2003-09-01 08:47:18 +0000
commit70102cf5d0725b0dabc79cbab2d61b2e0d53eb8b (patch)
treecc7375893f048886c3c75e929aa3de5828033fd7 /ftp/curl
parentf2755a1fbdb3df0380f52e632678a8fd9091a31d (diff)
downloadports-70102cf5d0725b0dabc79cbab2d61b2e0d53eb8b.tar.gz
ports-70102cf5d0725b0dabc79cbab2d61b2e0d53eb8b.zip
Use bsd.port.mk's OpenSSL support.
Submitted by: dinoex
Notes
Notes: svn path=/head/; revision=88254
Diffstat (limited to 'ftp/curl')
-rw-r--r--ftp/curl/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index cffbe28ad47b..8ec19b6b1f27 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -44,11 +44,13 @@ PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
GNU_CONFIGURE= yes
USE_BZIP2= yes
+.if !defined(WITHOUT_SSL)
+USE_OPENSSL= yes
+.endif
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_SSL)
-.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
CONFIGURE_ARGS= --with-ssl=${OPENSSLBASE}
.else
CONFIGURE_ARGS= --without-ssl