aboutsummaryrefslogtreecommitdiff
path: root/ftp/downloader
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-06-23 00:43:50 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-06-23 00:43:50 +0000
commitba5e95a9b4b0bb58a68c7130d83282d793371908 (patch)
tree6509cbcd5b21a12e59e9dcc8371fc109e7e72c77 /ftp/downloader
parentd782b1db2a50d66126dabcd7f5e9a2d5c3169bfd (diff)
downloadports-ba5e95a9b4b0bb58a68c7130d83282d793371908.tar.gz
ports-ba5e95a9b4b0bb58a68c7130d83282d793371908.zip
Import of ``downloader''.
A GTK+ based app that allows you to download from ftp or http based servers much in the same way as "ReGet" for Windows. PR: 12345 Submitted by: Ying-Chieh Liao <ijliao@csie.nctu.edu.tw>
Notes
Notes: svn path=/head/; revision=19701
Diffstat (limited to 'ftp/downloader')
-rw-r--r--ftp/downloader/Makefile24
-rw-r--r--ftp/downloader/distinfo1
-rw-r--r--ftp/downloader/files/patch-aa19
-rw-r--r--ftp/downloader/pkg-comment1
-rw-r--r--ftp/downloader/pkg-descr20
-rw-r--r--ftp/downloader/pkg-plist1
6 files changed, 66 insertions, 0 deletions
diff --git a/ftp/downloader/Makefile b/ftp/downloader/Makefile
new file mode 100644
index 000000000000..841afe8939a0
--- /dev/null
+++ b/ftp/downloader/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: downloader
+# Version required: 0.98
+# Date Created: 23 June 1999
+# Whom: Ying-Chieh Liao <ijliao@csie.nctu.edu.tw>
+#
+# $Id$
+#
+
+DISTNAME= nt-0.98
+PKGNAME= download-0.98
+CATEGORIES= net
+MASTER_SITES= http://www.krasu.ru/soft/chuchelo/ \
+ ftp://linux.ru.net/pub/chuchelo/
+
+MAINTAINER= ijliao@csie.nctu.edu.tw
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/main
+
+do-install:
+ cd ${WRKSRC}; ${INSTALL_PROGRAM} nt ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/ftp/downloader/distinfo b/ftp/downloader/distinfo
new file mode 100644
index 000000000000..fb7c841e8d2c
--- /dev/null
+++ b/ftp/downloader/distinfo
@@ -0,0 +1 @@
+MD5 (nt-0.98.tar.gz) = 793aa48837857888ddd6fa8e3b066ac9
diff --git a/ftp/downloader/files/patch-aa b/ftp/downloader/files/patch-aa
new file mode 100644
index 000000000000..c66fce930eba
--- /dev/null
+++ b/ftp/downloader/files/patch-aa
@@ -0,0 +1,19 @@
+--- Makefile.orig Fri Jun 18 18:41:54 1999
++++ Makefile Tue Jun 22 17:32:18 1999
+@@ -1,10 +1,10 @@
+-CC = gcc
+-CCPLUS = c++
++CC ?= gcc
++CCPLUS = ${CXX}
+
+-LIBS=-lpthread
+-CFLAGS=-Wall -O2
+-GTKLIBS=`gtk-config --libs`
+-GTKFLAGS=`gtk-config --cflags`
++LIBS=-pthread
++CFLAGS?=-Wall -O2
++GTKLIBS=`gtk12-config --libs`
++GTKFLAGS=`gtk12-config --cflags`
+
+ EXECC=$(CCPLUS) $(CFLAGS)
+
diff --git a/ftp/downloader/pkg-comment b/ftp/downloader/pkg-comment
new file mode 100644
index 000000000000..8cb7fec8b8b1
--- /dev/null
+++ b/ftp/downloader/pkg-comment
@@ -0,0 +1 @@
+A program for downloading via ftp or http with GUI.
diff --git a/ftp/downloader/pkg-descr b/ftp/downloader/pkg-descr
new file mode 100644
index 000000000000..5b1c8ca29ae3
--- /dev/null
+++ b/ftp/downloader/pkg-descr
@@ -0,0 +1,20 @@
+This program is a graphical program for downloading files through the
+internet which support both ftp and http (not completed yet) protocols.
+Program also supports REGET if server side supports it too. It is like kget
+for linux and ReGet or GetRight for Windows.
+
+This program supports queue of downloads, regets files after connection break
+and many other features:
+
+ able to set limit amount of threads
+ saving list before quit
+ log for all downloads
+ limits for strings in logs
+ start stop threads, moving they in queue and other
+ recursive download via ftp (recursive http in plans)
+ auto reconnect and reget after break
+
+WWW: http://www.krasu.ru/soft/chuchelo/
+
+- Ying-Chieh Liao
+ijliao@csie.nctu.edu.tw
diff --git a/ftp/downloader/pkg-plist b/ftp/downloader/pkg-plist
new file mode 100644
index 000000000000..674ee76ebbf6
--- /dev/null
+++ b/ftp/downloader/pkg-plist
@@ -0,0 +1 @@
+bin/nt