aboutsummaryrefslogtreecommitdiff
path: root/ftp/filezilla
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2015-09-26 11:56:16 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2015-09-26 11:56:16 +0000
commitce1853bf021623ab004669e0073c29ab6a83994f (patch)
treefedadbb4a91ad286fc8cd912fdf9498f02e4eaaa /ftp/filezilla
parenteaf7f32d4b805ea5068aa5ec22a5acebcd15d2ec (diff)
downloadports-ce1853bf021623ab004669e0073c29ab6a83994f.tar.gz
ports-ce1853bf021623ab004669e0073c29ab6a83994f.zip
ftp/filezilla: update to 3.14.0
PR: 202761 Submitted by: matthew@reztek.cz (maintainer)
Notes
Notes: svn path=/head/; revision=397962
Diffstat (limited to 'ftp/filezilla')
-rw-r--r--ftp/filezilla/Makefile2
-rw-r--r--ftp/filezilla/distinfo4
-rw-r--r--ftp/filezilla/files/patch-src_interface_Makefile.am11
-rw-r--r--ftp/filezilla/files/patch-src_interface_Makefile.in11
-rw-r--r--ftp/filezilla/files/patch-src_interface_fzputtygen__interface.h43
5 files changed, 3 insertions, 68 deletions
diff --git a/ftp/filezilla/Makefile b/ftp/filezilla/Makefile
index 78948c9b4245..53f5a27d51cf 100644
--- a/ftp/filezilla/Makefile
+++ b/ftp/filezilla/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= filezilla
-PORTVERSION= 3.13.0
+PORTVERSION= 3.14.0
CATEGORIES= ftp
MASTER_SITES= SF/${PORTNAME}/FileZilla_Client/${PORTVERSION}
DISTNAME= FileZilla_${PORTVERSION}_src
diff --git a/ftp/filezilla/distinfo b/ftp/filezilla/distinfo
index 30fe21224800..e9d7f1b4eea2 100644
--- a/ftp/filezilla/distinfo
+++ b/ftp/filezilla/distinfo
@@ -1,2 +1,2 @@
-SHA256 (FileZilla_3.13.0_src.tar.bz2) = e6c21b41b1318d0d75273aca94cfda3039c9847bdb5adc4b9d480ecdcdfa4fc7
-SIZE (FileZilla_3.13.0_src.tar.bz2) = 4542742
+SHA256 (FileZilla_3.14.0_src.tar.bz2) = 92385ab4f30bc7e5e457d6a3310645cc6c4bd0e83a78e12c33f2778b73d579fd
+SIZE (FileZilla_3.14.0_src.tar.bz2) = 4415005
diff --git a/ftp/filezilla/files/patch-src_interface_Makefile.am b/ftp/filezilla/files/patch-src_interface_Makefile.am
deleted file mode 100644
index edeb8b4803f2..000000000000
--- a/ftp/filezilla/files/patch-src_interface_Makefile.am
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/interface/Makefile.am.orig 2015-07-31 03:30:02 UTC
-+++ src/interface/Makefile.am
-@@ -155,7 +155,7 @@ noinst_HEADERS = aboutdialog.h \
- filter_conditions_dialog.h \
- filteredit.h \
- file_utils.h \
-- fzputtygen_interface.cpp \
-+ fzputtygen_interface.h \
- import.h \
- inputdialog.h \
- ipcmutex.h \
diff --git a/ftp/filezilla/files/patch-src_interface_Makefile.in b/ftp/filezilla/files/patch-src_interface_Makefile.in
deleted file mode 100644
index fd55fdf56de3..000000000000
--- a/ftp/filezilla/files/patch-src_interface_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/interface/Makefile.in.orig 2015-08-18 16:03:24 UTC
-+++ src/interface/Makefile.in
-@@ -630,7 +630,7 @@ noinst_HEADERS = aboutdialog.h \
- filter_conditions_dialog.h \
- filteredit.h \
- file_utils.h \
-- fzputtygen_interface.cpp \
-+ fzputtygen_interface.h \
- import.h \
- inputdialog.h \
- ipcmutex.h \
diff --git a/ftp/filezilla/files/patch-src_interface_fzputtygen__interface.h b/ftp/filezilla/files/patch-src_interface_fzputtygen__interface.h
deleted file mode 100644
index 42e24692b188..000000000000
--- a/ftp/filezilla/files/patch-src_interface_fzputtygen__interface.h
+++ /dev/null
@@ -1,43 +0,0 @@
---- src/interface/fzputtygen_interface.h.orig 2015-08-18 16:02:52 UTC
-+++ src/interface/fzputtygen_interface.h
-@@ -0,0 +1,40 @@
-+#ifndef FILEZILLA_FZPUTTYGEN_INTERFACE_HEADER
-+#define FILEZILLA_FZPUTTYGEN_INTERFACE_HEADER
-+
-+#include <wx/process.h>
-+
-+class CFZPuttyGenInterface
-+{
-+public:
-+ CFZPuttyGenInterface(wxWindow* parent);
-+ virtual ~CFZPuttyGenInterface();
-+ bool LoadKeyFile(wxString& keyFile, bool silent, wxString& comment, wxString& data);
-+
-+ void EndProcess();
-+ void DeleteProcess();
-+ bool IsProcessCreated();
-+ bool IsProcessStarted();
-+
-+protected:
-+ // return -1 on error
-+ int NeedsConversion(wxString keyFile, bool silent);
-+
-+ // return -1 on error
-+ int IsKeyFileEncrypted(wxString keyFile, bool silent);
-+
-+ wxProcess* m_pProcess{};
-+ bool m_initialized{};
-+ wxWindow* m_parent;
-+
-+ enum ReplyCode {
-+ success,
-+ error,
-+ failure
-+ };
-+
-+ bool LoadProcess(bool silent);
-+ bool Send(const wxString& cmd);
-+ ReplyCode GetReply(wxString& reply);
-+};
-+
-+#endif /* FILEZILLA_FZPUTTYGEN_INTERFACE_HEADER */