aboutsummaryrefslogtreecommitdiff
path: root/ftp/gwget
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-02 20:41:59 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-11-02 20:41:59 +0000
commitc52560c3fefd0fad514386e4b706c1a38ab78d72 (patch)
tree87e1b69c20b5f8ebe4cfda9c1c99c9869436c934 /ftp/gwget
parent5c01bb6ed43ecc25c05d017c4140e6c927a081cd (diff)
downloadports-c52560c3fefd0fad514386e4b706c1a38ab78d72.tar.gz
ports-c52560c3fefd0fad514386e4b706c1a38ab78d72.zip
Add gwget, a download manager for GNOME which uses wget as its backend.
It supports resuming downloads as well as recursive downloading. PR: 73431 Submitted by: Radek Kozlowski <radek@raadradd.com>
Notes
Notes: svn path=/head/; revision=120653
Diffstat (limited to 'ftp/gwget')
-rw-r--r--ftp/gwget/Makefile47
-rw-r--r--ftp/gwget/distinfo2
-rw-r--r--ftp/gwget/pkg-descr5
-rw-r--r--ftp/gwget/pkg-plist48
4 files changed, 102 insertions, 0 deletions
diff --git a/ftp/gwget/Makefile b/ftp/gwget/Makefile
new file mode 100644
index 000000000000..49a88fd834ca
--- /dev/null
+++ b/ftp/gwget/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: gwget
+# Date created: 1 November 2004
+# Whom: Radek Kozlowski <radek@raadradd.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gwget
+PORTVERSION= 0.90
+CATEGORIES= ftp www gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gwget
+
+MAINTAINER= radek@raadradd.com
+COMMENT= A download manager for GNOME, based on wget
+
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnomeprefix intlhack libgnomeui
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+EPHY_VER= 1.2
+
+.include <bsd.port.pre.mk>
+
+.if exists(${X11BASE}/bin/epiphany) && !defined(WITHOUT_EPIPHANY)
+WITH_EPIPHANY= yes
+.endif
+
+.if defined(WITH_EPIPHANY)
+BUILD_DEPENDS+= epiphany:${PORTSDIR}/www/epiphany
+CONFIGURE_ARGS+= --enable-epiphany-extension \
+ --with-epiphany-version=${EPHY_VER}
+PLIST_SUB+= EPIPHANY:="" \
+ VERSION="${EPHY_VER}"
+.else
+CONFIGURE_ARGS+= --disable-epiphany-extension
+PLIST_SUB+= EPIPHANY:="@comment "
+.endif # defined(WITH_EPIPHANY)
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|epiphany/extensions|epiphany-${EPHY_VER}/extensions|' \
+ ${WRKSRC}/epiphany-extension/Makefile.in
+
+.include <bsd.port.post.mk>
diff --git a/ftp/gwget/distinfo b/ftp/gwget/distinfo
new file mode 100644
index 000000000000..c60c967475bb
--- /dev/null
+++ b/ftp/gwget/distinfo
@@ -0,0 +1,2 @@
+MD5 (gwget-0.90.tar.gz) = 44882057713aa64df9b94bbc6b678f29
+SIZE (gwget-0.90.tar.gz) = 473147
diff --git a/ftp/gwget/pkg-descr b/ftp/gwget/pkg-descr
new file mode 100644
index 000000000000..15a547859968
--- /dev/null
+++ b/ftp/gwget/pkg-descr
@@ -0,0 +1,5 @@
+Gwget is a download manager for GNOME which uses wget as its backend.
+The most important features include pause/continue support, resuming
+and recursive downloading.
+
+WWW: http://gwget.sourceforge.net/
diff --git a/ftp/gwget/pkg-plist b/ftp/gwget/pkg-plist
new file mode 100644
index 000000000000..b211b516a853
--- /dev/null
+++ b/ftp/gwget/pkg-plist
@@ -0,0 +1,48 @@
+bin/gwget
+include/gwget/custom-cell-renderer-progressbar.h
+include/gwget/eggtrayicon.h
+include/gwget/gwget_data.h
+include/gwget/main_window.h
+include/gwget/main_window_cb.h
+include/gwget/new_window.h
+include/gwget/systray.h
+include/gwget/utils.h
+include/gwget/wget-log.h
+libdata/bonobo/servers/GNOME_Gwget.server
+%%EPIPHANY:%%lib/epiphany-%%VERSION%%/extensions/libgwgetextension.a
+%%EPIPHANY:%%lib/epiphany-%%VERSION%%/extensions/libgwgetextension.so
+%%EPIPHANY:%%lib/epiphany-%%VERSION%%/extensions/libgwgetextension.so.0
+share/gnome/applications/gwget.desktop
+share/gnome/gwget/about.glade
+share/gnome/gwget/gwget-large.png
+share/gnome/gwget/gwget-off.png
+share/gnome/gwget/gwget.glade
+share/gnome/gwget/gwget.png
+share/gnome/gwget/gwget.xpm
+share/gnome/gwget/newdownload.glade
+share/gnome/gwget/preferences.glade
+share/gnome/idl/GNOME_Gwget.idl
+share/gnome/pixmaps/gwget.png
+share/locale/bg/LC_MESSAGES/gwget.mo
+share/locale/cs/LC_MESSAGES/gwget.mo
+share/locale/en_CA/LC_MESSAGES/gwget.mo
+share/locale/es/LC_MESSAGES/gwget.mo
+share/locale/eu/LC_MESSAGES/gwget.mo
+share/locale/fi/LC_MESSAGES/gwget.mo
+share/locale/fr/LC_MESSAGES/gwget.mo
+share/locale/hu/LC_MESSAGES/gwget.mo
+share/locale/ja/LC_MESSAGES/gwget.mo
+share/locale/mk/LC_MESSAGES/gwget.mo
+share/locale/nl/LC_MESSAGES/gwget.mo
+share/locale/pa/LC_MESSAGES/gwget.mo
+share/locale/pl/LC_MESSAGES/gwget.mo
+share/locale/pt/LC_MESSAGES/gwget.mo
+share/locale/pt_BR/LC_MESSAGES/gwget.mo
+share/locale/ro/LC_MESSAGES/gwget.mo
+share/locale/ru/LC_MESSAGES/gwget.mo
+share/locale/tr/LC_MESSAGES/gwget.mo
+share/locale/zh_TW/LC_MESSAGES/gwget.mo
+@dirrm include/gwget
+%%EPIPHANY:%%@unexec rmdir %D/lib/epiphany-%%VERSION%%/extensions 2>/dev/null || true
+%%EPIPHANY:%%@unexec rmdir %D/lib/epiphany-%%VERSION%% 2>/dev/null || true
+@dirrm share/gnome/gwget