aboutsummaryrefslogtreecommitdiff
path: root/ftp/gwget
diff options
context:
space:
mode:
authorAlexander Logvinov <avl@FreeBSD.org>2009-10-04 00:06:51 +0000
committerAlexander Logvinov <avl@FreeBSD.org>2009-10-04 00:06:51 +0000
commitdb6b1c9df71b48272625dbf59b62b163231fe0fc (patch)
tree11cd07a8d3da12338119d1a79cf49ae333a69519 /ftp/gwget
parent189609b5d68b80b386bd78093629d3a3676411fe (diff)
downloadports-db6b1c9df71b48272625dbf59b62b163231fe0fc.tar.gz
ports-db6b1c9df71b48272625dbf59b62b163231fe0fc.zip
- Resurrect ftp/gwget
- Update to 1.0.2 Approved by: glarkin (mentor)
Notes
Notes: svn path=/head/; revision=242419
Diffstat (limited to 'ftp/gwget')
-rw-r--r--ftp/gwget/Makefile57
-rw-r--r--ftp/gwget/distinfo3
-rw-r--r--ftp/gwget/files/patch-configure37
-rw-r--r--ftp/gwget/pkg-descr12
-rw-r--r--ftp/gwget/pkg-plist67
5 files changed, 176 insertions, 0 deletions
diff --git a/ftp/gwget/Makefile b/ftp/gwget/Makefile
new file mode 100644
index 000000000000..2a4cb75ab636
--- /dev/null
+++ b/ftp/gwget/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: gwget
+# Date created: 1 November 2004
+# Whom: Radek Kozlowski <radek@raadradd.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gwget
+PORTVERSION= 1.0.2
+CATEGORIES= ftp gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome2
+
+MAINTAINER= avl@FreeBSD.org
+COMMENT= GNOME wget front-end
+
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
+
+OPTIONS= LIBNOTIFY "Enable libnotify support" on \
+ EPIPHANY "Enable Epiphany extension" on
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_GNOME= gnomeprefix gnomehack gtk20 gconf2 libgnomeui \
+ libglade2 desktopfileutils
+INSTALLS_ICONS= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= ${PORTNAME}.schemas
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_LIBNOTIFY)
+LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+RUN_DEPENDS+= ${LOCALBASE}/libexec/notification-daemon:${PORTSDIR}/deskutils/notification-daemon
+.else
+CONFIGURE_ARGS+= --disable-libnotify
+.endif
+
+.if defined(WITH_EPIPHANY)
+BUILD_DEPENDS+= epiphany:${PORTSDIR}/www/epiphany
+RUN_DEPENDS+= epiphany:${PORTSDIR}/www/epiphany
+CONFIGURE_ARGS+= --enable-epiphany-extension
+PLIST_SUB+= EPIPHANY="" EPHY_VERSION="2.26"
+.else
+CONFIGURE_ARGS+= --disable-epiphany-extension
+PLIST_SUB+= EPIPHANY="@comment "
+.endif
+
+post-install:
+ @-update-desktop-database
+
+.include <bsd.port.post.mk>
diff --git a/ftp/gwget/distinfo b/ftp/gwget/distinfo
new file mode 100644
index 000000000000..234f647e0d28
--- /dev/null
+++ b/ftp/gwget/distinfo
@@ -0,0 +1,3 @@
+MD5 (gnome2/gwget-1.0.2.tar.bz2) = 52b518ea58b3bd618db0c58910ee5ccc
+SHA256 (gnome2/gwget-1.0.2.tar.bz2) = 2e28da869f85dcf18a38f005d58ed3470cf097a886231b000c239742a5a1dace
+SIZE (gnome2/gwget-1.0.2.tar.bz2) = 433897
diff --git a/ftp/gwget/files/patch-configure b/ftp/gwget/files/patch-configure
new file mode 100644
index 000000000000..369e2a4489a7
--- /dev/null
+++ b/ftp/gwget/files/patch-configure
@@ -0,0 +1,37 @@
+--- configure.orig 2009-10-02 13:58:38.000000000 +1000
++++ configure 2009-10-02 13:59:21.000000000 +1000
+@@ -1653,10 +1653,10 @@
+ Config database for installing schema files.
+ --with-gconf-schema-file-dir=dir
+ Directory for installing schema files.
+- --with-epiphany-version[=1.6|1.8|1.10|2.14|2.16|2.18|2.20|2.22|2.24|2.26]
++ --with-epiphany-version[=1.6|1.8|1.10|2.14|2.16|2.18|2.20|2.22|2.24|2.26|2.28]
+ Whether to use epiphany version 1.6 or 1.8 or 1.10
+ or 2.14 or 2.16 or 2.18 or 2.20 or 2.22 or 2.24 or
+- 2.26 (default 1.6)
++ 2.26 or 2.28 (default 1.6)
+ --with-extension-prefix=path Epiphany extension prefix
+
+ Some influential environment variables:
+@@ -14861,7 +14861,9 @@
+
+
+ EPHY_AUTODETECT="(autodetect)"
+-if pkg-config --exists epiphany-2.26; then
++if pkg-config --exists epiphany-2.28; then
++ EPHY_VER=2.28
++elif pkg-config --exists epiphany-2.26; then
+ EPHY_VER=2.26
+ elif pkg-config --exists epiphany-2.25; then
+ EPHY_VER=2.25
+@@ -14976,6 +14978,10 @@
+ EPIPHANY_PKGCONFIG=epiphany-2.26
+ EPIPHANY_REQUIRED=2.26
+ EPIPHANY_SHORTVER=226
++elif test "x$EPHY_VER" = "x2.28"; then
++ EPIPHANY_PKGCONFIG=epiphany-2.28
++ EPIPHANY_REQUIRED=2.28
++ EPIPHANY_SHORTVER=228
+ else
+ { $as_echo "$as_me:$LINENO: result: no epiphany installed" >&5
+ $as_echo "no epiphany installed" >&6; }
diff --git a/ftp/gwget/pkg-descr b/ftp/gwget/pkg-descr
new file mode 100644
index 000000000000..80c469aa0f30
--- /dev/null
+++ b/ftp/gwget/pkg-descr
@@ -0,0 +1,12 @@
+Gwget is a download manager for the Gnome Desktop. The main features are:
+
+* Resume: By default, gwget tries to continue any download.
+* Notification: Gwget tries to use the Gnome notification area support,
+ if available. You can close the main window and gwget runs in the background.
+* Recursivity: Gwget detects when you put a html, php, asp or a web page dir in
+ the url to download, and ask you to only download certain files (multimedia,
+ only the index, and so on).
+* Drag & Drop: You can d&d a url to the main gwget window or the notification
+ area icon to add a new download.
+
+WWW: http://projects.gnome.org/gwget/
diff --git a/ftp/gwget/pkg-plist b/ftp/gwget/pkg-plist
new file mode 100644
index 000000000000..449e8e82756b
--- /dev/null
+++ b/ftp/gwget/pkg-plist
@@ -0,0 +1,67 @@
+bin/gwget
+share/applications/gwget.desktop
+share/dbus-1/services/org.gnome.gwget.service
+%%DATADIR%%/gwget.xpm
+%%DATADIR%%/gwget.png
+%%DATADIR%%/gwget-off.png
+%%DATADIR%%/gwget-large.png
+%%DATADIR%%/downloading.png
+%%DATADIR%%/newdownload.png
+%%DATADIR%%/preferences.glade
+%%DATADIR%%/gwget.glade
+%%EPIPHANY%%lib/epiphany/%%EPHY_VERSION%%/extensions/gwget.xml
+%%EPIPHANY%%lib/epiphany/%%EPHY_VERSION%%/extensions/libgwgetextension.a
+%%EPIPHANY%%lib/epiphany/%%EPHY_VERSION%%/extensions/libgwgetextension.la
+%%EPIPHANY%%lib/epiphany/%%EPHY_VERSION%%/extensions/libgwgetextension.so
+share/locale/ar/LC_MESSAGES/gwget.mo
+share/locale/bg/LC_MESSAGES/gwget.mo
+share/locale/ca/LC_MESSAGES/gwget.mo
+share/locale/cs/LC_MESSAGES/gwget.mo
+share/locale/da/LC_MESSAGES/gwget.mo
+share/locale/de/LC_MESSAGES/gwget.mo
+share/locale/dz/LC_MESSAGES/gwget.mo
+share/locale/el/LC_MESSAGES/gwget.mo
+share/locale/en_CA/LC_MESSAGES/gwget.mo
+share/locale/en_GB/LC_MESSAGES/gwget.mo
+share/locale/es/LC_MESSAGES/gwget.mo
+share/locale/eu/LC_MESSAGES/gwget.mo
+share/locale/fi/LC_MESSAGES/gwget.mo
+share/locale/fr/LC_MESSAGES/gwget.mo
+share/locale/he/LC_MESSAGES/gwget.mo
+share/locale/hu/LC_MESSAGES/gwget.mo
+share/locale/it/LC_MESSAGES/gwget.mo
+share/locale/ja/LC_MESSAGES/gwget.mo
+share/locale/lt/LC_MESSAGES/gwget.mo
+share/locale/lv/LC_MESSAGES/gwget.mo
+share/locale/mk/LC_MESSAGES/gwget.mo
+share/locale/nb/LC_MESSAGES/gwget.mo
+share/locale/ne/LC_MESSAGES/gwget.mo
+share/locale/nl/LC_MESSAGES/gwget.mo
+share/locale/oc/LC_MESSAGES/gwget.mo
+share/locale/pa/LC_MESSAGES/gwget.mo
+share/locale/pl/LC_MESSAGES/gwget.mo
+share/locale/pt/LC_MESSAGES/gwget.mo
+share/locale/pt_BR/LC_MESSAGES/gwget.mo
+share/locale/ro/LC_MESSAGES/gwget.mo
+share/locale/ru/LC_MESSAGES/gwget.mo
+share/locale/rw/LC_MESSAGES/gwget.mo
+share/locale/sk/LC_MESSAGES/gwget.mo
+share/locale/sq/LC_MESSAGES/gwget.mo
+share/locale/sv/LC_MESSAGES/gwget.mo
+share/locale/th/LC_MESSAGES/gwget.mo
+share/locale/tr/LC_MESSAGES/gwget.mo
+share/locale/uk/LC_MESSAGES/gwget.mo
+share/locale/vi/LC_MESSAGES/gwget.mo
+share/locale/zh_CN/LC_MESSAGES/gwget.mo
+share/locale/zh_HK/LC_MESSAGES/gwget.mo
+share/locale/zh_TW/LC_MESSAGES/gwget.mo
+share/pixmaps/gwget.png
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@dirrm %%DATADIR%%
+@dirrmtry share/applications
+@dirrmtry share/dbus-1/services
+@dirrmtry share/dbus-1
+%%EPIPHANY%%@dirrmtry lib/epiphany/%%EPHY_VERSION%%/extensions
+%%EPIPHANY%%@dirrmtry lib/epiphany/%%EPHY_VERSION%%
+%%EPIPHANY%%@dirrmtry lib/epiphany