aboutsummaryrefslogtreecommitdiff
path: root/ftp/junglemonkey
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-18 18:37:18 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-18 18:37:18 +0000
commit5b92600edbf22fc5f049e9f99229b42440275a82 (patch)
tree1e339f8f207e07f62042c660a5b22e05ffbcba68 /ftp/junglemonkey
parent9f6b3d9731438428be73b68da75c95c99bfa59fe (diff)
downloadports-5b92600edbf22fc5f049e9f99229b42440275a82.tar.gz
ports-5b92600edbf22fc5f049e9f99229b42440275a82.zip
- Fixes a linker problem when not using libtool 15
- Fixes a bug causing the program to crash on exit if the hostname was not set yet PR: 118797 Submitted by: Pietro Cerutti <gahr@gahr.ch>
Notes
Notes: svn path=/head/; revision=204015
Diffstat (limited to 'ftp/junglemonkey')
-rw-r--r--ftp/junglemonkey/Makefile3
-rw-r--r--ftp/junglemonkey/files/patch-src-util_sha_cache.c11
2 files changed, 12 insertions, 2 deletions
diff --git a/ftp/junglemonkey/Makefile b/ftp/junglemonkey/Makefile
index 7ec56346ca2b..d3fc7081fd33 100644
--- a/ftp/junglemonkey/Makefile
+++ b/ftp/junglemonkey/Makefile
@@ -17,11 +17,10 @@ COMMENT= A distributed file sharing program for GNOME
LIB_DEPENDS= gnet.7:${PORTSDIR}/net/gnet
-BROKEN= Does not build
-
USE_X_PREFIX= yes
USE_GNOME= gnomehack gnomeprefix libglade
USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gnome=yes --enable-debug=no
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/ftp/junglemonkey/files/patch-src-util_sha_cache.c b/ftp/junglemonkey/files/patch-src-util_sha_cache.c
new file mode 100644
index 000000000000..313e6e82e72e
--- /dev/null
+++ b/ftp/junglemonkey/files/patch-src-util_sha_cache.c
@@ -0,0 +1,11 @@
+--- src/util/sha_cache.c.orig 2007-12-17 23:04:06.000000000 +0100
++++ src/util/sha_cache.c 2007-12-17 23:09:16.000000000 +0100
+@@ -213,7 +213,7 @@
+ g_return_if_fail (sha_cache);
+ g_return_if_fail (file);
+
+- g_hash_table_foreach (sha_cache->path_to_sha, write_hfunc, file);
++ if(sha_cache) g_hash_table_foreach (sha_cache->path_to_sha, write_hfunc, file);
+ }
+
+