aboutsummaryrefslogtreecommitdiff
path: root/ftp/linux-f8-curl/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2009-04-01 15:25:39 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2009-04-01 15:25:39 +0000
commit824eda00fccb57b36978b562ecfc6572fa5de766 (patch)
treedddb20be9539275c41e943b4763c0b29ba61151d /ftp/linux-f8-curl/Makefile
parent8217c4dd1dea5cbe146907f97afb3e458208ec77 (diff)
downloadports-824eda00fccb57b36978b562ecfc6572fa5de766.tar.gz
ports-824eda00fccb57b36978b562ecfc6572fa5de766.zip
Here are new Linux Fedora 8 infrastructure ports.
The recommended version of FreeBSD to use them is 8-CURRENT. FreeBSD-7.x is not fully compatible with compat.linux.osrelease 2.6.16. Some syscalls cannot be MFCed due to native FreeBSD ABI breakage. Usage (and package building): 1. define compat.linux.osrelease=2.6.16; 2. add following variables to /etc/make.conf: . OVERRIDE_LINUX_BASE_PORT=f8; . OVERRIDE_LINUX_NONBASE_PORTS=f8. Approved by: bsam (me) ;-)
Notes
Notes: svn path=/head/; revision=231438
Diffstat (limited to 'ftp/linux-f8-curl/Makefile')
-rw-r--r--ftp/linux-f8-curl/Makefile27
1 files changed, 17 insertions, 10 deletions
diff --git a/ftp/linux-f8-curl/Makefile b/ftp/linux-f8-curl/Makefile
index ee494bbbcfb6..502c4a442352 100644
--- a/ftp/linux-f8-curl/Makefile
+++ b/ftp/linux-f8-curl/Makefile
@@ -1,23 +1,30 @@
-# New ports collection makefile for: linux-curl
-# Date created: 2006-08-04
-# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+# New ports collection makefile for: ftp/linux-f8-curl
+# Date created: 2009-03-30
+# Whom: bsam
#
# $FreeBSD$
#
PORTNAME= curl
-PORTVERSION= 7.13.1
+PORTVERSION= 7.18.2
CATEGORIES= ftp linux
-PKGNAMEPREFIX= linux-
-DISTNAME= ${PORTNAME}-${PORTVERSION}-5.fc4
+PKGNAMEPREFIX= linux-f8-
+DISTNAME= ${PORTNAME}-${PORTVERSION}-${RPMVERSION}
-MAINTAINER= acm@FreeBSD.org
-COMMENT= Curl linux version
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= The command line tool for transferring files with URL syntax (Linux Fedora 8)
USE_LINUX_RPM= yes
-LINUX_DIST_VER= 4
+LINUX_DIST_VER= 8
+RPMVERSION= 7.fc8
USE_LDCONFIG= yes
-AUTOMATIC_PLIST= yes
+BRANDELF_FILES= usr/bin/curl
DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+PLIST_FILES= usr/bin/curl usr/lib/libcurl.so.4 usr/lib/libcurl.so.4.1.0
+DOCSDIR= usr/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= BUGS COPYING FEATURES README TODO CHANGES FAQ MANUAL RESOURCES TheArtOfHttpScripting
+MANPREFIX= ${PREFIX}/usr/share
+MAN1= curl.1
+
.include <bsd.port.mk>