aboutsummaryrefslogtreecommitdiff
path: root/ftp/ocaml-ocurl
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2015-06-24 08:11:00 +0000
committerJohan van Selst <johans@FreeBSD.org>2015-06-24 08:11:00 +0000
commitb9dfae68a344f9407e8cad85814c9c2b40484e98 (patch)
tree494196a9fd5e7f173f06b1cd555d9344c91f358b /ftp/ocaml-ocurl
parentf116dbbb3bc8bbe81cfffeab0f5f771248704aa9 (diff)
downloadports-b9dfae68a344f9407e8cad85814c9c2b40484e98.tar.gz
ports-b9dfae68a344f9407e8cad85814c9c2b40484e98.zip
- Update to ocurl 0.7.3
- Add support for threading using LWT (and enable by default)
Notes
Notes: svn path=/head/; revision=390472
Diffstat (limited to 'ftp/ocaml-ocurl')
-rw-r--r--ftp/ocaml-ocurl/Makefile21
-rw-r--r--ftp/ocaml-ocurl/distinfo4
-rw-r--r--ftp/ocaml-ocurl/pkg-plist5
3 files changed, 25 insertions, 5 deletions
diff --git a/ftp/ocaml-ocurl/Makefile b/ftp/ocaml-ocurl/Makefile
index a552b0afe471..8111072c9bc0 100644
--- a/ftp/ocaml-ocurl/Makefile
+++ b/ftp/ocaml-ocurl/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= ocurl
-PORTVERSION= 0.7.2
-PORTREVISION= 1
+PORTVERSION= 0.7.3
CATEGORIES= ftp
-MASTER_SITES= https://forge.ocamlcore.org/frs/download.php/1463/ \
+MASTER_SITES= https://forge.ocamlcore.org/frs/download.php/1521/ \
http://ygrek.org.ua/p/release/ocurl/
PKGNAMEPREFIX= ocaml-
@@ -27,7 +26,23 @@ USE_OCAML_FINDLIB= yes
USE_OCAML_LDCONFIG= yes
OCAML_PKGDIRS= curl
+OPTIONS_DEFINE= LWT
+OPTIONS_DEFAULT=LWT
+OPTIONS_SUB= yes
+LWT_DESC= Include threading support (ocaml-lwt)
+LWT_RUN_DEPENDS=${LOCALBASE}/${OCAML_SITELIBDIR}/lwt/lwt.a:${PORTSDIR}/devel/ocaml-lwt
+LWT_BUILD_DEPENDS=${LWT_RUN_DEPENDS}
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${OCAML_SITELIBDIR}/curl/dllcurl-helper.so
+.include <bsd.port.options.mk>
+
+.if ! ${PORT_OPTIONS:MLWT}
+# Override auto-detection
+post-configure:
+ ${REINPLACE_CMD} 's/(lwt,no)/(no,no)/' ${WRKSRC}/Makefile \
+ ${WRKSRC}/examples/Makefile
+.endif
+
.include <bsd.port.mk>
diff --git a/ftp/ocaml-ocurl/distinfo b/ftp/ocaml-ocurl/distinfo
index adc1782e98c8..3031fd4c4d01 100644
--- a/ftp/ocaml-ocurl/distinfo
+++ b/ftp/ocaml-ocurl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ocurl-0.7.2.tar.gz) = 39635fbd1fcef20f9fd31e4f590061efc19813be4d99033bb6486d5ede70c77a
-SIZE (ocurl-0.7.2.tar.gz) = 108530
+SHA256 (ocurl-0.7.3.tar.gz) = 7228acf91a0c521eb4db5c65638e525d8cb111206a88e9d754f1536fb4489523
+SIZE (ocurl-0.7.3.tar.gz) = 104619
diff --git a/ftp/ocaml-ocurl/pkg-plist b/ftp/ocaml-ocurl/pkg-plist
index 609f2673785e..d9ae83cceb6b 100644
--- a/ftp/ocaml-ocurl/pkg-plist
+++ b/ftp/ocaml-ocurl/pkg-plist
@@ -4,5 +4,10 @@
%%OCAML_SITELIBDIR%%/curl/curl.cmi
%%OCAML_SITELIBDIR%%/curl/curl.cmxa
%%OCAML_SITELIBDIR%%/curl/curl.mli
+%%LWT%%%%OCAML_SITELIBDIR%%/curl/curl_lwt.cmi
+%%LWT%%%%OCAML_SITELIBDIR%%/curl/curl_lwt.cmo
+%%LWT%%%%OCAML_SITELIBDIR%%/curl/curl_lwt.cmx
+%%LWT%%%%OCAML_SITELIBDIR%%/curl/curl_lwt.mli
+%%LWT%%%%OCAML_SITELIBDIR%%/curl/curl_lwt.o
%%OCAML_SITELIBDIR%%/curl/dllcurl-helper.so
%%OCAML_SITELIBDIR%%/curl/libcurl-helper.a