aboutsummaryrefslogtreecommitdiff
path: root/ftp/paraget
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-05 18:03:58 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-06-05 18:03:58 +0000
commit5b42f6acea4451f391fc0213c9de2210d3ee9d56 (patch)
treebc73aa46d173515797edb78c9db51dc008ecf205 /ftp/paraget
parent8ea52382c670179f3b36138d12fc9fdb38504953 (diff)
downloadports-5b42f6acea4451f391fc0213c9de2210d3ee9d56.tar.gz
ports-5b42f6acea4451f391fc0213c9de2210d3ee9d56.zip
add paraget
Parallel ftp-fetching program
Notes
Notes: svn path=/head/; revision=43546
Diffstat (limited to 'ftp/paraget')
-rw-r--r--ftp/paraget/Makefile25
-rw-r--r--ftp/paraget/distinfo1
-rw-r--r--ftp/paraget/pkg-comment1
-rw-r--r--ftp/paraget/pkg-descr18
-rw-r--r--ftp/paraget/pkg-plist22
5 files changed, 67 insertions, 0 deletions
diff --git a/ftp/paraget/Makefile b/ftp/paraget/Makefile
new file mode 100644
index 000000000000..7ec435df253d
--- /dev/null
+++ b/ftp/paraget/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# New ports collection makefile for: paraget
+# Date created: Apr 18, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= paraget
+PORTVERSION= 0.3.0
+CATEGORIES= ftp perl5
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Net/FTP.pm:${PORTSDIR}/net/p5-Net \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= paraget.1
+
+.include <bsd.port.mk>
diff --git a/ftp/paraget/distinfo b/ftp/paraget/distinfo
new file mode 100644
index 000000000000..0fc548d30612
--- /dev/null
+++ b/ftp/paraget/distinfo
@@ -0,0 +1 @@
+MD5 (paraget-0.3.0.tar.gz) = 30e5975c40a443d43022bd912dfbc199
diff --git a/ftp/paraget/pkg-comment b/ftp/paraget/pkg-comment
new file mode 100644
index 000000000000..bd6b6f1510c0
--- /dev/null
+++ b/ftp/paraget/pkg-comment
@@ -0,0 +1 @@
+Parallel ftp-fetching program
diff --git a/ftp/paraget/pkg-descr b/ftp/paraget/pkg-descr
new file mode 100644
index 000000000000..64ecc8d9e3d2
--- /dev/null
+++ b/ftp/paraget/pkg-descr
@@ -0,0 +1,18 @@
+Paraget implements getting a single file in parallel from different mirror
+sites.
+
+Given that there are mirror-sites for the file one is downloading, one can
+in principle accomplish a much greater bandwidth by downloading from all
+the sites in parallel . This is accomplished by dividing the file being
+fetched into several pieces, and by getting each piece from a different
+server, and then re-assembling them.
+
+If there are enough mirror sites, this partitioning makes it so that the
+bottleneck is now placed at the client end, maxing the client's connection.
+
+Paraget is designed to not only do basic n -equal-piece partitioning of a
+file and sending requests out to n servers for data, but to also be dynamic
+during the downloading process. For example if one server is too slow, and
+paraget was done with faster server downloading its piece
+
+WWW: http://paraget.sourceforge.net/
diff --git a/ftp/paraget/pkg-plist b/ftp/paraget/pkg-plist
new file mode 100644
index 000000000000..d8da9ac41d6a
--- /dev/null
+++ b/ftp/paraget/pkg-plist
@@ -0,0 +1,22 @@
+bin/paraget
+bin/paraget-child
+lib/perl5/site_perl/%%PERL_VER%%/Net/Paraget/Assignment.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Paraget/AssignmentManager.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Paraget/Client.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Paraget/ClientManager.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Paraget/Context.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Paraget/Display.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Paraget/Interval.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Paraget/IntervalList.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Paraget/IntervalManager.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Paraget/Mirror.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Paraget/MirrorSet.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Paraget/MirrorSetGatherer.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Paraget/PerformanceReport.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Paraget/Server.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Paraget/ServerList.pm
+lib/perl5/site_perl/%%PERL_VER%%/Net/Paraget/ServerQueue.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Net/Paraget
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/paraget/.packlist
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/paraget 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net 2>/dev/null || true