aboutsummaryrefslogtreecommitdiff
path: root/ftp/phpwebftp
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-05-31 13:02:33 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-05-31 13:02:33 +0000
commit16ef18761fcebeb5b9aa52482c8ef5d603aaab53 (patch)
tree7848136ff35a57416d8aded251276db6f3879ce2 /ftp/phpwebftp
parentb247306d8a25fe063aa832f77a4c80753f6dd420 (diff)
downloadports-16ef18761fcebeb5b9aa52482c8ef5d603aaab53.tar.gz
ports-16ef18761fcebeb5b9aa52482c8ef5d603aaab53.zip
- Change installation directory
- Various minor fixes PR: ports/97145 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe> Approved by: krion (mentor)
Notes
Notes: svn path=/head/; revision=164074
Diffstat (limited to 'ftp/phpwebftp')
-rw-r--r--ftp/phpwebftp/Makefile25
-rw-r--r--ftp/phpwebftp/pkg-descr10
-rw-r--r--ftp/phpwebftp/pkg-plist1
3 files changed, 22 insertions, 14 deletions
diff --git a/ftp/phpwebftp/Makefile b/ftp/phpwebftp/Makefile
index bb6b376cc14c..23282547a4cb 100644
--- a/ftp/phpwebftp/Makefile
+++ b/ftp/phpwebftp/Makefile
@@ -7,10 +7,11 @@
PORTNAME= phpwebftp
PORTVERSION= 3.3
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= phpwebftp
-DISTNAME= ${PORTNAME}33
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
MAINTAINER= acardenas@bsd.org.pe
COMMENT= A set of PHP-scripts to manage FTP over the web
@@ -18,19 +19,19 @@ COMMENT= A set of PHP-scripts to manage FTP over the web
USE_ZIP= yes
NO_BUILD= yes
USE_PHP= ftp
-PHPWEBFTPDIR?= www/data-dist/${PORTNAME}
-PLIST_SUB+= PHPWEBFTPDIR=${PHPWEBFTPDIR}
-WRKSRC= ${WRKDIR}/${PORTNAME}
+PHPWEBFTPDIR?= www/${PORTNAME}
+PLIST_SUB+= PHPWEBFTPDIR=${PHPWEBFTPDIR} WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+INSTALL_DIRE= ${INSTALL} -d -m 0755 -o ${WWWOWN} -g ${WWWGRP}
+INSTALL_FILE= ${INSTALL} -m 0644 -o ${WWWOWN} -g ${WWWGRP}
-do-configure:
- @${FIND} -d ${WRKSRC} -name CVS -type d -print0 | ${XARGS} -0 ${RM} -R
+post-extract:
+ @${FIND} -d ${WRKSRC} -name CVS -type d -exec ${RM} -R "{}" \;
do-install:
- ${MKDIR} ${PREFIX}/${PHPWEBFTPDIR}
+ ${INSTALL_DIRE} ${PREFIX}/${PHPWEBFTPDIR}
@cd ${WRKSRC} && \
- ${FIND} * -type d -exec ${MKDIR} "${PREFIX}/${PHPWEBFTPDIR}/{}" \; && \
+ ${FIND} * -type d -exec ${INSTALL_DIRE} "${PREFIX}/${PHPWEBFTPDIR}/{}" \; && \
${FIND} -E * -type f -iregex ".*\.(php|html|css|gif|js)" \
- -exec ${INSTALL_DATA} "{}" "${PREFIX}/${PHPWEBFTPDIR}/{}" \;
- @${CHGRP} -R ${WWWGRP} ${PREFIX}/${PHPWEBFTPDIR}
-
+ -exec ${INSTALL_FILE} "{}" "${PREFIX}/${PHPWEBFTPDIR}/{}" \;
.include <bsd.port.mk>
diff --git a/ftp/phpwebftp/pkg-descr b/ftp/phpwebftp/pkg-descr
index e18e753f50e4..d5b9e3ad68be 100644
--- a/ftp/phpwebftp/pkg-descr
+++ b/ftp/phpwebftp/pkg-descr
@@ -1,3 +1,9 @@
-phpWebFTP - Free web based FTP client
+phpWebFTP offers a way of connecting to you FTP server, even when you
+are behind a firewall or proxy not allowing traffic to FTP servers.
+This is very common in business networks. phpWebFTP overcomes this
+issue by making a FTP connection from your webserver to your FTP server
+and transfering the files from this web server to your webclient over
+the standard http protocol. phpWebFTP is free software and the source
+is available under GNU license.
-WWW: http://www.v-wijk.net/
+WWW: http://www.phpwebftp.com/
diff --git a/ftp/phpwebftp/pkg-plist b/ftp/phpwebftp/pkg-plist
index 7657c6b91482..8ef32cb9701c 100644
--- a/ftp/phpwebftp/pkg-plist
+++ b/ftp/phpwebftp/pkg-plist
@@ -70,3 +70,4 @@
@dirrm %%PHPWEBFTPDIR%%/style
@dirrm %%PHPWEBFTPDIR%%/tmp
@dirrm %%PHPWEBFTPDIR%%
+@exec find %D/%%PHPWEBFTPDIR%% -type d -print0 | xargs -0 chown %%WWWOWN%%:%%WWWGRP%%