aboutsummaryrefslogtreecommitdiff
path: root/ftp/proma
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-25 22:47:49 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-05-25 22:47:49 +0000
commit0948f98e864b3f24af6d6842778ba09ca4c2620d (patch)
treedca2c02a0e4635b2d268ee8793acbc8239cba04e /ftp/proma
parent2ab1379533b77035c6025f64de6ededd9cb0ad1f (diff)
downloadports-0948f98e864b3f24af6d6842778ba09ca4c2620d.tar.gz
ports-0948f98e864b3f24af6d6842778ba09ca4c2620d.zip
- convert to USE_APACHE/USE_MYSQL/USE_PHP
- install -> mkdir - move perms to post-install - Cleanup config.php.inc and -example handling PR: ports/134452 Approved by: maintainer timeout (2 weeks) Submitted by: me
Notes
Notes: svn path=/head/; revision=234556
Diffstat (limited to 'ftp/proma')
-rw-r--r--ftp/proma/Makefile23
-rw-r--r--ftp/proma/pkg-plist4
2 files changed, 13 insertions, 14 deletions
diff --git a/ftp/proma/Makefile b/ftp/proma/Makefile
index ec9b80b5be6d..99af5968932f 100644
--- a/ftp/proma/Makefile
+++ b/ftp/proma/Makefile
@@ -32,37 +32,36 @@ SUB_FILES= pkg-message
RUN_DEPENDS+= proftpd:${PORTSDIR}/ftp/proftpd-mysql
.endif
.if defined(WITH_APACHE)
-RUN_DEPENDS+= apachectl:${PORTSDIR}/www/apache22
+USE_APACHE= 2.2
.endif
.if defined(WITH_MYSQL)
-RUN_DEPENDS+= mysql:${PORTSDIR}/databases/mysql50-server
+USE_MYSQL= yes
.endif
.if defined(WITH_PHP)
-RUN_DEPENDS+= php:${PORTSDIR}/lang/php5
+USE_PHP= mysql pcre xml gd
.endif
do-install:
.if !defined(NOPORTDOCS)
- @${INSTALL} -d ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}/
@cd ${WRKSRC}/docs && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
.endif
- @${INSTALL} -d ${WWWDIR}
+ @${MKDIR} ${WWWDIR}/
@${INSTALL_DATA} ${FILES:S,^,${WRKSRC}/,} ${WWWDIR}/
@${INSTALL} -d ${WWWDIR}/libs
@${INSTALL_DATA} ${LIBS:S,^,${WRKSRC}/libs/,} ${WWWDIR}/libs/
@${INSTALL} -d ${WWWDIR}/pages
@${INSTALL_DATA} ${PAGES:S,^,${WRKSRC}/pages/,} ${WWWDIR}/pages/
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
- @${FIND} ${WWWDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
- @${FIND} ${WWWDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
- @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} \
- ${WWWDIR}' >> ${TMPPLIST}
post-install:
@if [ ! -f ${WWWDIR}/config.inc.php ]; then \
- ${CP} -p ${WWWDIR}/config.inc.php-example ${WWWDIR}/config.inc.php ; \
- ${CHMOD} 640 ${WWWDIR}/config.inc.php ; \
+ ${CP} -p ${WRKSRC}/config.inc.php-example ${WWWDIR}/config.inc.php ; \
+ ${CP} -p ${WRKSRC}/config.inc.php-example ${WWWDIR}/config.inc.php-example ; \
+ ${CHMOD} 640 ${WWWDIR}/config.inc.php* ; \
fi
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${WWWDIR}
+ @${FIND} ${WWWDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
+ @${FIND} ${WWWDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/ftp/proma/pkg-plist b/ftp/proma/pkg-plist
index 7ef5811833f1..49a910792d38 100644
--- a/ftp/proma/pkg-plist
+++ b/ftp/proma/pkg-plist
@@ -1,6 +1,6 @@
-@unexec if cmp -s %D/%%WWWDIR%%/config.inc.php-example %D/%%WWWDIR%%/config.inc.php; then rm -f %D/%%WWWDIR%%/config.inc.php; fi
+@unexec if cmp %B/%%WWWDIR%%/config.inc.php-example %B/%%WWWDIR%%/config.inc.php; then rm -f %B/%%WWWDIR%%/config.inc.php; fi
+@exec if [ ! -f %B/%%WWWDIR%%/config.inc.php ] ; then cp -p %D/%F %B/config.inc.php; fi
%%WWWDIR%%/config.inc.php-example
-@exec if [ ! -f %D/%%WWWDIR%%/config.inc.php ] ; then cp -p %D/%F %B/config.inc.php; fi
%%WWWDIR%%/index.php
%%WWWDIR%%/style.css
%%WWWDIR%%/libs/admin.lib.php