aboutsummaryrefslogtreecommitdiff
path: root/ftp/py-tftpy
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-03-13 17:48:56 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-03-13 17:48:56 +0000
commitc0b98685aa9ac7616d97838866b499a6e404bd34 (patch)
tree781b8c759b5bd966b706934b0441d28f2fb24b4b /ftp/py-tftpy
parent58cc818a88f35a939f00ce30b84d4ed924fb6844 (diff)
downloadports-c0b98685aa9ac7616d97838866b499a6e404bd34.tar.gz
ports-c0b98685aa9ac7616d97838866b499a6e404bd34.zip
Update to latest snapshot which supports Python 3
- Change MASTER_SITES to GitHub - Add LICENSE_FILE - Add NO_ARCH - Allow concurrent installation (USE_PYTHON=concurrent) - Bump PORTREVISION for package change Changes: https://github.com/msoulier/tftpy/commits/master
Notes
Notes: svn path=/head/; revision=436099
Diffstat (limited to 'ftp/py-tftpy')
-rw-r--r--ftp/py-tftpy/Makefile11
-rw-r--r--ftp/py-tftpy/distinfo5
-rw-r--r--ftp/py-tftpy/files/patch-tftpy-TftpServer.py13
-rw-r--r--ftp/py-tftpy/files/patch-tftpy-TftpStates.py11
4 files changed, 35 insertions, 5 deletions
diff --git a/ftp/py-tftpy/Makefile b/ftp/py-tftpy/Makefile
index fe260dd4892e..2d4009d2975f 100644
--- a/ftp/py-tftpy/Makefile
+++ b/ftp/py-tftpy/Makefile
@@ -3,17 +3,22 @@
PORTNAME= tftpy
PORTVERSION= 0.6.2
+PORTREVISION= 1
CATEGORIES= ftp python
-MASTER_SITES= CHEESESHOP \
- SF/${PORTNAME}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Pure Python TFTP Implementation
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+NO_ARCH= yes
USE_PYTHON= autoplist distutils
-USES= python:2
+USES= python
+
+GH_ACCOUNT= msoulier
+GH_TAGNAME= c5a7b52
+USE_GITHUB= yes
.include <bsd.port.mk>
diff --git a/ftp/py-tftpy/distinfo b/ftp/py-tftpy/distinfo
index fbab2e503ba0..9104601b2f8e 100644
--- a/ftp/py-tftpy/distinfo
+++ b/ftp/py-tftpy/distinfo
@@ -1,2 +1,3 @@
-SHA256 (tftpy-0.6.2.tar.gz) = 9bc2bd77113b31b55c12b7298cc2b1cc3c55a8cef9f5f76518ed17e575591b43
-SIZE (tftpy-0.6.2.tar.gz) = 26107
+TIMESTAMP = 1489402358
+SHA256 (msoulier-tftpy-0.6.2-c5a7b52_GH0.tar.gz) = d294e263b181e35327d4f316d7fd13295056a0ea03b1187836d54496a0a9863c
+SIZE (msoulier-tftpy-0.6.2-c5a7b52_GH0.tar.gz) = 820065
diff --git a/ftp/py-tftpy/files/patch-tftpy-TftpServer.py b/ftp/py-tftpy/files/patch-tftpy-TftpServer.py
new file mode 100644
index 000000000000..ade11f443ff4
--- /dev/null
+++ b/ftp/py-tftpy/files/patch-tftpy-TftpServer.py
@@ -0,0 +1,13 @@
+--- tftpy/TftpServer.py.orig 2016-07-07 08:32:15 UTC
++++ tftpy/TftpServer.py
+@@ -53,8 +53,8 @@ class TftpServer(TftpSession):
+ for name in 'dyn_file_func', 'upload_open':
+ attr = getattr(self, name)
+ if attr and not callable(attr):
+- raise TftpException, "%s supplied, but it is not callable." % (
+- name,)
++ raise TftpException("%s supplied, but it is not callable." % (
++ name))
+ if os.path.exists(self.root):
+ log.debug("tftproot %s does exist", self.root)
+ if not os.path.isdir(self.root):
diff --git a/ftp/py-tftpy/files/patch-tftpy-TftpStates.py b/ftp/py-tftpy/files/patch-tftpy-TftpStates.py
new file mode 100644
index 000000000000..5967afc2c6df
--- /dev/null
+++ b/ftp/py-tftpy/files/patch-tftpy-TftpStates.py
@@ -0,0 +1,11 @@
+--- tftpy/TftpStates.py.orig 2016-07-07 08:32:15 UTC
++++ tftpy/TftpStates.py
+@@ -368,7 +368,7 @@ class TftpStateServerRecvWRQ(TftpServerS
+ f = self.context.upload_open(path, self.context)
+ if f is None:
+ self.sendError(TftpErrors.AccessViolation)
+- raise TftpException, "Dynamic path %s not permitted" % path
++ raise TftpException("Dynamic path %s not permitted" % path)
+ else:
+ self.context.fileobj = f
+ else: