aboutsummaryrefslogtreecommitdiff
path: root/ftp/sftp
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-01-24 06:21:47 +0000
committerSteve Price <steve@FreeBSD.org>2000-01-24 06:21:47 +0000
commit09f0c958f00146186b15e10c65cf8de51e0e3aef (patch)
tree17d2bf642c0c55608d1bb35a66d8dc300152020e /ftp/sftp
parentd80572ef7327df981c91c314d7a450e3a9684ea1 (diff)
downloadports-09f0c958f00146186b15e10c65cf8de51e0e3aef.tar.gz
ports-09f0c958f00146186b15e10c65cf8de51e0e3aef.zip
Update to version 0.6.
PR: 16069 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=25022
Diffstat (limited to 'ftp/sftp')
-rw-r--r--ftp/sftp/Makefile23
-rw-r--r--ftp/sftp/distinfo2
-rw-r--r--ftp/sftp/files/patch-aa40
3 files changed, 58 insertions, 7 deletions
diff --git a/ftp/sftp/Makefile b/ftp/sftp/Makefile
index 50751402111d..337f94b20971 100644
--- a/ftp/sftp/Makefile
+++ b/ftp/sftp/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: sftp
-# Version required: 0.5
+# Version required: 0.6
# Date created: 30 December 1999
# Whom: Cy Shubert <Cy.Shubert@uumail.gov.bc.ca>
#
# $FreeBSD$
#
-DISTNAME= sftp-0.5
+DISTNAME= sftp-0.6
CATEGORIES= ftp security
MASTER_SITES= ftp://ftp.xbill.org/pub/sftp/
@@ -21,12 +21,23 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --prefix=${PREFIX} \
--enable-remotepath=${PREFIX}/libexec
-MAN1= sftp.1
+MAN1= secftp.1
+
+PLIST= ${WRKDIR}/PLIST
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/sftp ${PREFIX}/bin/sftp
- ${LN} -s ${PREFIX}/bin/sftp ${PREFIX}/bin/rsftp
+ ${INSTALL_PROGRAM} ${WRKSRC}/sftp ${PREFIX}/bin/secftp
+ ${LN} -s ${PREFIX}/bin/secftp ${PREFIX}/bin/rsftp
${INSTALL_PROGRAM} ${WRKSRC}/sftpserv ${PREFIX}/libexec/sftpserv
- ${INSTALL_MAN} ${WRKSRC}/sftp.1 ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/sftp.1 ${PREFIX}/man/man1/secftp.1
+ @${CP} ${PKGDIR}/PLIST ${PLIST}
+ @if [ ! -f ${PREFIX}/bin/sftp ]; then \
+ ${ECHO} "No other sftp found, linking sftp to secftp"; \
+ ${LN} -s ${PREFIX}/bin/secftp ${PREFIX}/bin/sftp; \
+ ${LN} -s ${PREFIX}/man/man1/secftp.1.gz ${PREFIX}/man/man1/sftp.1.gz; \
+ @${ECHO} bin/sftp >> ${PLIST}; \
+ else \
+ ${ECHO} "Other sftp found, not linking sftp to secftp"; \
+ fi
.include <bsd.port.mk>
diff --git a/ftp/sftp/distinfo b/ftp/sftp/distinfo
index 1390ed2b22f6..e8abb7f0ea7b 100644
--- a/ftp/sftp/distinfo
+++ b/ftp/sftp/distinfo
@@ -1 +1 @@
-MD5 (sftp-0.5.tar.gz) = 8070983234f1a872b969f8eebe24b84d
+MD5 (sftp-0.6.tar.gz) = 0412d22e066223890f99e8aeafc8160c
diff --git a/ftp/sftp/files/patch-aa b/ftp/sftp/files/patch-aa
new file mode 100644
index 000000000000..18a7df3a8051
--- /dev/null
+++ b/ftp/sftp/files/patch-aa
@@ -0,0 +1,40 @@
+--- sftp.1.orig Tue Dec 28 11:44:39 1999
++++ sftp.1 Tue Jan 11 11:14:23 2000
+@@ -1,11 +1,19 @@
+ .Dd November 26, 1999
+-.Dt sftp 1
++.Dt secftp 1
+ .Os POSIX
+ .Sh NAME
++.Nm secftp
+ .Nm sftp
+ .Nd
+ ftp replacement over ssh/rsh
+ .Sh SYNOPSIS
++.Nm secftp
++.Op Ar -P remotepath
++.Op Ar -l user
++.Op Ar -p port
++.Op Ar -C
++.Op Ar -s sshargs
++.Op Ar hostname
+ .Nm sftp
+ .Op Ar -P remotepath
+ .Op Ar -l user
+@@ -18,6 +26,7 @@
+ .Op Ar -l user
+ .Op Ar hostname
+ .Sh DESCRIPTION
++.Nm secftp,
+ .Nm sftp
+ and
+ .Nm rsftp
+@@ -25,7 +34,7 @@
+ programs allows files to be transferred to and from remote servers.
+ Authentication is provided by the underlying ssh/rsh connection.
+ .Pp
+-When sftp or rsftp is run, the server
++When secftp, sftp or rsftp is run, the server
+ .Nm (sftpserv)
+ is automatically run on the remote end.
+ .Pp