aboutsummaryrefslogtreecommitdiff
path: root/ftp/spegla/Makefile
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2008-10-05 12:30:44 +0000
committerHiroki Sato <hrs@FreeBSD.org>2008-10-05 12:30:44 +0000
commit37d5e627fdd6805c2dfad3edba485c4e1b639181 (patch)
treec227f161324dfcc0b0823f187efc8cf59bade4a2 /ftp/spegla/Makefile
parent657501c6d38188d772000dbdabd2c5ce870c8712 (diff)
downloadports-37d5e627fdd6805c2dfad3edba485c4e1b639181.tar.gz
ports-37d5e627fdd6805c2dfad3edba485c4e1b639181.zip
- Fix NOPORTEXAMPLES=yes case.
- Add WITH_IPV6 option.
Notes
Notes: svn path=/head/; revision=221234
Diffstat (limited to 'ftp/spegla/Makefile')
-rw-r--r--ftp/spegla/Makefile29
1 files changed, 17 insertions, 12 deletions
diff --git a/ftp/spegla/Makefile b/ftp/spegla/Makefile
index 07544307d1bc..764aa3cf359a 100644
--- a/ftp/spegla/Makefile
+++ b/ftp/spegla/Makefile
@@ -8,7 +8,7 @@
PORTNAME= spegla
PORTVERSION= 1.1p4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= ftp ipv6
MASTER_SITES= ftp://subzero.campus.luth.se/pub/spegla/ \
ftp://ftp.luth.se/pub/unix/mirror/
@@ -20,21 +20,26 @@ MAINTAINER= hrs@FreeBSD.org
COMMENT= A mirror program for FTP sites (written in C)
MAKE_ARGS= MANDIR=${MAN1PREFIX}/man/man
+PLIST_FILES= bin/spegla
+PORTEXAMPLES= freebsd.org spegla.conf spegla.sh
MANCOMPRESSED= yes
MAN1= spegla.1
-post-extract:
-.for file in engine.c regcomp.c regerror.c regexec.c regfree.c cclass.h cname.h regex.h regex2.h utils.h
- @${CP} ${WRKSRC}/regex/${file} ${WRKSRC}
-.endfor
-
-pre-install:
- @${MKDIR} ${EXAMPLESDIR}
+OPTIONS= IPV6 "IPv6 support" on
+.if !defined(NOPORTEXAMPLES)
post-install:
- ${INSTALL_DATA} ${WRKSRC}/freebsd.org ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/spegla.conf ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/spegla.sh ${EXAMPLESDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC} && \
+ ${INSTALL_DATA} freebsd.org spegla.conf ${EXAMPLESDIR} && \
+ ${INSTALL_SCRIPT} spegla.sh ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_IPV6)
+MAKE_ARGS+= -DINET6
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>