aboutsummaryrefslogtreecommitdiff
path: root/ftp/tnftpd/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-23 22:56:46 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-23 22:56:46 +0000
commit2056d34e2e893acb1a24f0ac8d7b3014ecdf8148 (patch)
tree4850c0dc5a2963a2db17fac273bb8a9e310d4319 /ftp/tnftpd/Makefile
parent6fac5f5979b159b42fc637496ea6ee19bd7edc47 (diff)
downloadports-2056d34e2e893acb1a24f0ac8d7b3014ecdf8148.tar.gz
ports-2056d34e2e893acb1a24f0ac8d7b3014ecdf8148.zip
- Rip post-install echo block into standalone pkg-message
- Quiet portlint on RUN_DEPENDS
Notes
Notes: svn path=/head/; revision=98929
Diffstat (limited to 'ftp/tnftpd/Makefile')
-rw-r--r--ftp/tnftpd/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/ftp/tnftpd/Makefile b/ftp/tnftpd/Makefile
index e21fd7d5a56c..71712e687c55 100644
--- a/ftp/tnftpd/Makefile
+++ b/ftp/tnftpd/Makefile
@@ -17,9 +17,10 @@ COMMENT= Enhanced ftp server from NetBSD
USE_REINPLACE= yes
GNU_CONFIGURE= yes
+PKGMESSAGE= ${WRKDIR}/pkg-message
.if defined(WITH_SOCKS5)
-BUILD_DEPENDS= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
CONFIGURE_ARGS+= --with-socks5
.endif
@@ -49,6 +50,9 @@ pre-patch:
"s@^#define _DEFAULT_CONFDIR \"/etc\"@#define _DEFAULT_CONFDIR \"${PREFIX}/etc\"@" \
${WRKSRC}/src/pathnames.h
+post-build:
+ @${CAT} pkg-message | ${SED} -e 's|%%PREFIX%%|${PREFIX}|' > ${PKGMESSAGE}
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/tnftpd ${PREFIX}/libexec
${INSTALL_MAN} ${WRKSRC}/src/ftpd.8 ${PREFIX}/man/man8/tnftpd.8
@@ -62,14 +66,6 @@ do-install:
.endif
post-install:
- @${ECHO} "================================================================================"
- @${ECHO} "This port relies on a number of configuration files in ${PREFIX}/etc."
- @${ECHO} "At the very least, create a ftpusers file with the usernams of users you don't"
- @${ECHO} "want to connect (root, toor, etc.). This will allow non-listed users to log in."
- @${ECHO} "Copying /etc/ftpusers to ${PREFIX}/etc/ftpusers should be sufficient."
- @${ECHO}
- @${ECHO} "See the man files for more information. The man- and configuration files for"
- @${ECHO} "FreeBSD's built-in ftpd can also be of use as examples/additional info."
- @${ECHO} "================================================================================"
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>