aboutsummaryrefslogtreecommitdiff
path: root/ftp/wget
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2005-06-10 08:14:48 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2005-06-10 08:14:48 +0000
commit99dd8b5ba24d42cd3455c4f2f17eaccb930bb081 (patch)
tree51643b58b41f89ce077f1dc5df2bc5a859bfe141 /ftp/wget
parentb46c25f52706a1e5cb46a38746b0bd81335c24de (diff)
downloadports-99dd8b5ba24d42cd3455c4f2f17eaccb930bb081.tar.gz
ports-99dd8b5ba24d42cd3455c4f2f17eaccb930bb081.zip
update to 1.10.
Notes
Notes: svn path=/head/; revision=137164
Diffstat (limited to 'ftp/wget')
-rw-r--r--ftp/wget/Makefile35
-rw-r--r--ftp/wget/distinfo6
-rw-r--r--ftp/wget/files/patch-CAN-2004-148751
-rw-r--r--ftp/wget/pkg-descr29
-rw-r--r--ftp/wget/pkg-plist9
5 files changed, 46 insertions, 84 deletions
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index b99e64b12742..d1dad95af350 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -5,21 +5,12 @@
# $FreeBSD$
#
-# NOTE: I would like to skip wget-1.9 and wait for stabilization.
-# Please don't push me to update. Thank you.
-
PORTNAME= wget
-PORTVERSION= 1.8.2
-PORTREVISION= 7
+DISTVERSION= 1.10
CATEGORIES= ftp www ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= wget
-PATCH_SITES= ${MASTER_SITE_LOCAL}
-PATCH_SITE_SUBDIR= sf
-PATCHFILES= wget_${PORTVERSION}-12.diff.gz
-PATCH_DIST_STRIP= -p1
-
MAINTAINER= sf@FreeBSD.org
COMMENT= Retrieve files from the Net via HTTP and FTP
@@ -27,33 +18,37 @@ COMMENT= Retrieve files from the Net via HTTP and FTP
USE_GETTEXT= yes
.endif
-CONFLICTS= wget-devel-*
+CONFLICTS= wget-devel-[0-9]*
-USE_REINPLACE= yes
+USE_REINPLACE= yes
USE_PERL5_BUILD= yes
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
+GNU_CONFIGURE= yes
.if defined(WITHOUT_SSL)
CONFIGURE_ARGS= --with-ssl=no
.else
USE_OPENSSL= yes
.endif
-CONFIGURE_ENV+= CPPFLAGS=-I${LOCALBASE}/include \
- LIBS=-L${LOCALBASE}/lib
-PLIST_SUB= NLS=""
+
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB= NLS="@comment "
+.else
+CONFIGURE_ARGS+= --enable-nls
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ "LDFLAGS=${LDFLAGS}"
+PLIST_SUB= NLS=""
.endif
MAN1= wget.1
INFO= wget
post-patch:
- ${RM} -f ${WRKSRC}/doc/wget.info*
-# we don't need to run autoconf.
- ${TOUCH} ${WRKSRC}/configure
+ ${RM} -f ${WRKSRC}/doc/wget.info* ${WRKSRC}/po/*.mo ${WRKSRC}/po/*.gmo
+# eliminate gmakism
+ ${REINPLACE_CMD} -e 's,$$<,$$(srcdir)/wget.texi,' \
+ ${WRKSRC}/doc/Makefile.in
${REINPLACE_CMD} -e 's,/etc/wgetrc,${PREFIX}/etc/wgetrc,' \
-e 's,@file{},@file{${PREFIX}},' \
${WRKSRC}/doc/sample.wgetrc* ${WRKSRC}/doc/wget.texi
diff --git a/ftp/wget/distinfo b/ftp/wget/distinfo
index 82d410413c59..5a5c3a75f01a 100644
--- a/ftp/wget/distinfo
+++ b/ftp/wget/distinfo
@@ -1,4 +1,2 @@
-MD5 (wget-1.8.2.tar.gz) = a2473d7a53ebaf0a1bdb06f17059e8f1
-SIZE (wget-1.8.2.tar.gz) = 1154648
-MD5 (wget_1.8.2-12.diff.gz) = 6017ad7231afb85ac37a2b975203fc40
-SIZE (wget_1.8.2-12.diff.gz) = 34921
+MD5 (wget-1.10.tar.gz) = caddc199d2cb31969e32b19fd365b0c5
+SIZE (wget-1.10.tar.gz) = 1593119
diff --git a/ftp/wget/files/patch-CAN-2004-1487 b/ftp/wget/files/patch-CAN-2004-1487
deleted file mode 100644
index d37947a1c88f..000000000000
--- a/ftp/wget/files/patch-CAN-2004-1487
+++ /dev/null
@@ -1,51 +0,0 @@
-diff -ruN wget-LFS-20040909/src/http.c wget-LFS-20040909.patched/src/http.c
---- src/http.c.orig 2004-09-09 19:28:26.000000000 -0700
-+++ src/http.c 2005-02-21 04:13:05.000000000 -0800
-@@ -1719,6 +1719,7 @@
- /* Open the local file. */
- if (!output_stream)
- {
-+ sanitize_path(*hs->local_file);
- mkalldirs (*hs->local_file);
- if (opt.backups)
- rotate_backups (*hs->local_file);
-diff -ruN wget-LFS-20040909/src/utils.c wget-LFS-20040909.patched/src/utils.c
---- src/utils.c.orig 2004-09-09 13:32:07.000000000 -0700
-+++ src/utils.c 2005-02-21 04:11:54.000000000 -0800
-@@ -368,6 +368,25 @@
- #endif
- }
-
-+
-+char *
-+sanitize_path(char *path)
-+{
-+ char *str = NULL;
-+
-+ /* evilhost/../ */
-+ while ((str = strstr(path, "..")) != NULL)
-+ memcpy(str, "__", 2);
-+ /* evilhost/.bashrc */
-+ while ((str = strstr(path, "/.")) != NULL)
-+ str[1] = '_';
-+ /* .bashrc */
-+ if (*path == '.')
-+ *path = '_';
-+ return path;
-+}
-+
-+
- /* Returns 0 if PATH is a directory, 1 otherwise (any kind of file).
- Returns 0 on error. */
- int
-diff -ruN wget-LFS-20040909/src/utils.h wget-LFS-20040909.patched/src/utils.h
---- src/utils.h.orig 2004-09-09 21:05:36.000000000 -0700
-+++ src/utils.h 2005-02-21 04:04:07.000000000 -0800
-@@ -83,6 +83,7 @@
- int make_directory PARAMS ((const char *));
- char *unique_name PARAMS ((const char *, int));
- char *file_merge PARAMS ((const char *, const char *));
-+char *sanitize_path PARAMS ((char *));
-
- int acceptable PARAMS ((const char *));
- int accdir PARAMS ((const char *s, enum accd));
diff --git a/ftp/wget/pkg-descr b/ftp/wget/pkg-descr
index 6ed5aa61e463..20f3f5800811 100644
--- a/ftp/wget/pkg-descr
+++ b/ftp/wget/pkg-descr
@@ -1,11 +1,22 @@
-Wget [formerly known as Geturl] is a freely available network utility
-to retrieve files from the World Wide Web using HTTP and FTP, the two
-most widely used Internet protocols. It works non-interactively, thus
-enabling work in the background, after having logged off.
+GNU wget is a free software package for retrieving files using HTTP,
+HTTPS and FTP, the most widely-used Internet protocols. It is a
+non-interactive command-line tool, so it may easily be called from
+scripts, cron jobs, terminals without X-Windows support, etc.
-The recursive retrieval of HTML pages, as well as FTP sites is
-supported -- you can use Wget to make mirrors of archives and home
-pages, or traverse the web like a WWW robot (Wget understands
-/robots.txt).
+GNU wget has many features to make retrieving large files or mirroring
+entire web or FTP sites easy, including:
-WWW: http://sunsite.auc.dk/wget/
+ o Can resume aborted downloads, using REST and RANGE
+ o Can use filename wild cards and recursively mirror directories
+ o NLS-based message files for many different languages
+ o Optionally converts absolute links in downloaded documents to
+ relative, so that downloaded documents may link to each other locally
+ o Supports HTTP and SOCKS proxies
+ o Supports HTTP cookies
+ o Supports persistent HTTP connections
+ o Unattended / background operation
+ o Uses local file timestamps to determine whether documents need to
+ be re-downloaded when mirroring
+ o GNU wget is distributed under the GNU General Public License.
+
+WWW: http://www.gnu.org/software/wget/wget.html
diff --git a/ftp/wget/pkg-plist b/ftp/wget/pkg-plist
index f727e8112db9..bce1e9adf77a 100644
--- a/ftp/wget/pkg-plist
+++ b/ftp/wget/pkg-plist
@@ -6,9 +6,14 @@ etc/wgetrc
%%NLS%%share/locale/da/LC_MESSAGES/wget.mo
%%NLS%%share/locale/de/LC_MESSAGES/wget.mo
%%NLS%%share/locale/el/LC_MESSAGES/wget.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/wget.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/wget.mo
%%NLS%%share/locale/es/LC_MESSAGES/wget.mo
%%NLS%%share/locale/et/LC_MESSAGES/wget.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/wget.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/wget.mo
%%NLS%%share/locale/fr/LC_MESSAGES/wget.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/wget.mo
%%NLS%%share/locale/gl/LC_MESSAGES/wget.mo
%%NLS%%share/locale/he/LC_MESSAGES/wget.mo
%%NLS%%share/locale/hr/LC_MESSAGES/wget.mo
@@ -19,10 +24,14 @@ etc/wgetrc
%%NLS%%share/locale/no/LC_MESSAGES/wget.mo
%%NLS%%share/locale/pl/LC_MESSAGES/wget.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/wget.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/wget.mo
%%NLS%%share/locale/ru/LC_MESSAGES/wget.mo
%%NLS%%share/locale/sk/LC_MESSAGES/wget.mo
%%NLS%%share/locale/sl/LC_MESSAGES/wget.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/wget.mo
%%NLS%%share/locale/sv/LC_MESSAGES/wget.mo
%%NLS%%share/locale/tr/LC_MESSAGES/wget.mo
%%NLS%%share/locale/uk/LC_MESSAGES/wget.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/wget.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/wget.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/wget.mo