aboutsummaryrefslogtreecommitdiff
path: root/ftp/yafc
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-01-19 22:23:06 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-01-19 22:23:06 +0000
commit406b340dda57f8a23c726381403fb9a26258794e (patch)
tree4f44df509dccd46c9a948d3ebd6aa8170734d7dc /ftp/yafc
parente5dc855d6045b6dd337ce506857aec01f60f0c5a (diff)
downloadports-406b340dda57f8a23c726381403fb9a26258794e.tar.gz
ports-406b340dda57f8a23c726381403fb9a26258794e.zip
Only install the bash completion file if the newly-added BASH option is set.
No PORTREVISION bump, since BASH is on by default to avoid POLA problems and thus the plist does not change.
Notes
Notes: svn path=/head/; revision=310666
Diffstat (limited to 'ftp/yafc')
-rw-r--r--ftp/yafc/Makefile16
1 files changed, 11 insertions, 5 deletions
diff --git a/ftp/yafc/Makefile b/ftp/yafc/Makefile
index 63d82861d054..3ad8edb52bbb 100644
--- a/ftp/yafc/Makefile
+++ b/ftp/yafc/Makefile
@@ -11,8 +11,8 @@ COMMENT= Yet another ftp client. Similar to ftp(1)
LICENSE= GPLv2 # (or later)
-OPTIONS_DEFINE= NLS SSH EXAMPLES
-OPTIONS_DEFAULT=NLS SSH
+OPTIONS_DEFINE= BASH EXAMPLES NLS SSH
+OPTIONS_DEFAULT=BASH NLS SSH
USE_XZ= yes
USE_OPENSSL= yes
@@ -29,9 +29,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN1= yafc.1
INFO= yafc
PORTEXAMPLES= inputrc yafcrc
-PLIST_FILES= bin/yafc \
- etc/bash_completion.d/yafc
-PLIST_DIRSTRY= etc/bash_completion.d
+PLIST_FILES= bin/yafc
.include <bsd.port.options.mk>
@@ -57,6 +55,14 @@ LIB_DEPENDS+= ssh:${PORTSDIR}/security/libssh
CONFIGURE_ARGS+= --without-ssh
.endif
+.if ${PORT_OPTIONS:MBASH}
+CONFIGURE_ARGS+= --with-bash-completion=yes
+PLIST_FILES+= etc/bash_completion.d/yafc
+PLIST_DIRSTRY= etc/bash_completion.d
+.else
+CONFIGURE_ARGS+= --with-bash-completion=no
+.endif
+
post-install:
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}