aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-04-18 19:21:04 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-04-18 19:21:04 +0000
commit6817641b20a32d519c9f7bf583e685f026631494 (patch)
tree5cf99c313e2fe9a607473d83211a4f5c8bcb7679 /ftp
parent5ba4de1ed7d71d822fd90e2fe91c6599205bc6a3 (diff)
downloadports-6817641b20a32d519c9f7bf583e685f026631494.tar.gz
ports-6817641b20a32d519c9f7bf583e685f026631494.zip
STAGE support, and turn "INSTALL_AS_NCFTP" into an OPTION. Note
that the port still doesn't build.
Notes
Notes: svn path=/head/; revision=351560
Diffstat (limited to 'ftp')
-rw-r--r--ftp/ncftp1/Makefile22
1 files changed, 12 insertions, 10 deletions
diff --git a/ftp/ncftp1/Makefile b/ftp/ncftp1/Makefile
index bc6948d9ccbb..ecabaced2f61 100644
--- a/ftp/ncftp1/Makefile
+++ b/ftp/ncftp1/Makefile
@@ -5,23 +5,25 @@ PORTNAME= ncftp
PORTVERSION= 1.9.5
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.ncftp.com/ncftp/
-DISTNAME= ncftp-${PORTVERSION}
PKGNAMESUFFIX= 1
MAINTAINER= obrien@FreeBSD.org
COMMENT= FTP replacement with advanced user interface
-PLIST_FILES= bin/${LATEST_LINK}
-MAN1= ncftp.1
+OPTIONS_DEFINE= AS_NCFTP
+AS_NCFTP_DESC= Install binary as ncftp instead of ncftp1
-NO_STAGE= yes
-pre-fetch:
- @${ECHO} ""
- @${ECHO} "Use INSTALL_AS_NCFTP=yes to install ncftp1 as ${PREFIX}/bin/ncftp"
- @${ECHO} ""
+.include <bsd.port.options.mk>
+
+NCFTP= ${PORTNAME}
+.if empty(PORT_OPTIONS:MAS_NCFTP)
+NCFTP:= ${NCFTP}${PKGNAMESUFFIX}
+.endif
+
+PLIST_FILES= bin/${NCFTP} man/man1/${NCFTP}.1.gz
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/ncftp ${PREFIX}/bin/${LATEST_LINK}
- cd ${WRKSRC}; ${INSTALL_MAN} ncftp.1 ${PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${NCFTP}
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1/${NCFTP}.1.gz
.include <bsd.port.mk>