aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-04-18 23:19:29 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-04-18 23:19:29 +0000
commitcda1449dce4ebde2f9d1b98818355901a054dcd4 (patch)
tree1faba88ee69d8607317625410ac51b2ac132750e /ftp
parentcc394b56aa766f2fc7d8fa915ea28d22e3d00827 (diff)
downloadports-cda1449dce4ebde2f9d1b98818355901a054dcd4.tar.gz
ports-cda1449dce4ebde2f9d1b98818355901a054dcd4.zip
STAGE support, OPTIONS helpers, strip leading article from
COMMENT. Also, the NLS option was inexplicably being used to determine whether to install PORTEXAMPLES, so that is fixed along with a PORTREVISION bump.
Notes
Notes: svn path=/head/; revision=351574
Diffstat (limited to 'ftp')
-rw-r--r--ftp/spegla/Makefile30
1 files changed, 10 insertions, 20 deletions
diff --git a/ftp/spegla/Makefile b/ftp/spegla/Makefile
index 2c2fe1f812a9..5a76351de278 100644
--- a/ftp/spegla/Makefile
+++ b/ftp/spegla/Makefile
@@ -3,7 +3,7 @@
PORTNAME= spegla
PORTVERSION= 1.1p4
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= ftp ipv6
MASTER_SITES= ftp://subzero.campus.luth.se/pub/spegla/ \
ftp://ftp.luth.se/pub/unix/mirror/
@@ -12,30 +12,20 @@ PATCH_SITES= http://www.mahoroba.org/~ume/ipv6/
PATCHFILES= ${DISTNAME}-ipv6-20020129-3.diff.gz
MAINTAINER= hrs@FreeBSD.org
-COMMENT= A mirror program for FTP sites (written in C)
+COMMENT= Mirror program for FTP sites (written in C)
MAKE_ARGS= MANDIR=${MAN1PREFIX}/man/man
-PLIST_FILES= bin/spegla
+PLIST_FILES= bin/spegla man/man1/spegla.1.gz
PORTEXAMPLES= freebsd.org spegla.conf spegla.sh
-MANCOMPRESSED= yes
-MAN1= spegla.1
+OPTIONS_DEFINE= IPV6
+OPTIONS_DEFAULT=IPV6
+IPV6_MAKE_ARGS= -DINET6
-OPTIONS_DEFINE= IPV6 NLS
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
post-install:
- ${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC} && \
- ${INSTALL_DATA} freebsd.org spegla.conf ${EXAMPLESDIR} && \
- ${INSTALL_SCRIPT} spegla.sh ${EXAMPLESDIR}
-.endif
-
-.if ${PORT_OPTIONS:MIPV6}
-MAKE_ARGS+= -DINET6
-.endif
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/freebsd.org ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/spegla.conf ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/spegla.sh ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>