aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2016-02-05 17:37:29 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2016-02-05 17:37:29 +0000
commitc05148a4ebc9c3581261e33e8ab30bb3a57e5272 (patch)
treeb7d3fe60227f53a24aee5f4d5bb6d60a1ff2a340 /ftp
parent5f510cdf8c39f8e8a3045978ab712f56543cba89 (diff)
downloadports-c05148a4ebc9c3581261e33e8ab30bb3a57e5272.tar.gz
ports-c05148a4ebc9c3581261e33e8ab30bb3a57e5272.zip
libfilezilla is a small and modern C++ library, offering some basic
functionality to build high-performing, platform-independent programs. Some of the highlights include: * A typesafe, multi-threaded event system that's very simple to use yet extremely efficient * Timers for periodic events * A datetime class that not only tracks timestamp but also their accuracy, which simplifies dealing with timestamps originating from different sources * Simple process handling for spawning child processes with redirected I/O WWW: http://lib.filezilla-project.org/ PR: 206861 Submitted by: matthew@reztek.cz
Notes
Notes: svn path=/head/; revision=408237
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/libfilezilla/Makefile21
-rw-r--r--ftp/libfilezilla/distinfo2
-rw-r--r--ftp/libfilezilla/pkg-descr13
-rw-r--r--ftp/libfilezilla/pkg-plist25
5 files changed, 62 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 3585f5e06da0..75bcae58031a 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -39,6 +39,7 @@
SUBDIR += jftp
SUBDIR += jftpgw
SUBDIR += lftp
+ SUBDIR += libfilezilla
SUBDIR += linux-c6-curl
SUBDIR += linux-f10-curl
SUBDIR += llnlxdir
diff --git a/ftp/libfilezilla/Makefile b/ftp/libfilezilla/Makefile
new file mode 100644
index 000000000000..eedab16d1580
--- /dev/null
+++ b/ftp/libfilezilla/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= libfilezilla
+PORTVERSION= 0.3.1
+CATEGORIES= ftp
+MASTER_SITES= SF/filezilla/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= matthew@reztek.cz
+COMMENT= C++ library for building platform-independent programs
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BROKEN_FreeBSD_9= requires C++14 complier, 9.x lacks C++11 standard library
+
+USES= compiler:c++14-lang gmake libtool localbase pathfix pkgconfig tar:bzip2
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>
diff --git a/ftp/libfilezilla/distinfo b/ftp/libfilezilla/distinfo
new file mode 100644
index 000000000000..9a2cea76e5dc
--- /dev/null
+++ b/ftp/libfilezilla/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libfilezilla-0.3.1.tar.bz2) = a4adde9ce2de975e0f8b111705b9f89939466f19edf609efb785a6bf00f050ef
+SIZE (libfilezilla-0.3.1.tar.bz2) = 372673
diff --git a/ftp/libfilezilla/pkg-descr b/ftp/libfilezilla/pkg-descr
new file mode 100644
index 000000000000..9b4f764f97c9
--- /dev/null
+++ b/ftp/libfilezilla/pkg-descr
@@ -0,0 +1,13 @@
+libfilezilla is a small and modern C++ library, offering some basic
+functionality to build high-performing, platform-independent programs.
+
+Some of the highlights include:
+
+* A typesafe, multi-threaded event system that's very simple to use yet
+ extremely efficient
+* Timers for periodic events
+* A datetime class that not only tracks timestamp but also their accuracy,
+ which simplifies dealing with timestamps originating from different sources
+* Simple process handling for spawning child processes with redirected I/O
+
+WWW: http://lib.filezilla-project.org/
diff --git a/ftp/libfilezilla/pkg-plist b/ftp/libfilezilla/pkg-plist
new file mode 100644
index 000000000000..075ab5da321a
--- /dev/null
+++ b/ftp/libfilezilla/pkg-plist
@@ -0,0 +1,25 @@
+include/libfilezilla/apply.hpp
+include/libfilezilla/event.hpp
+include/libfilezilla/event_handler.hpp
+include/libfilezilla/event_loop.hpp
+include/libfilezilla/file.hpp
+include/libfilezilla/glue/wx.hpp
+include/libfilezilla/iputils.hpp
+include/libfilezilla/libfilezilla.hpp
+include/libfilezilla/local_filesys.hpp
+include/libfilezilla/mutex.hpp
+include/libfilezilla/private/defs.hpp
+include/libfilezilla/private/visibility.hpp
+include/libfilezilla/private/windows.hpp
+include/libfilezilla/process.hpp
+include/libfilezilla/recursive_remove.hpp
+include/libfilezilla/string.hpp
+include/libfilezilla/thread.hpp
+include/libfilezilla/time.hpp
+include/libfilezilla/util.hpp
+include/libfilezilla/version.hpp
+lib/libfilezilla.a
+lib/libfilezilla.so
+lib/libfilezilla.so.0
+lib/libfilezilla.so.0.0.0
+libdata/pkgconfig/libfilezilla.pc