aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-11-19 13:26:31 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-11-19 13:26:31 +0000
commit52e42e94a130993c24900e8833269464fca60cc9 (patch)
tree99fc37b6e09bab25330a83f1cf5705eba1683c50 /ftp
parent01a406af17a181dc510b20877e46fe76228b0997 (diff)
downloadports-52e42e94a130993c24900e8833269464fca60cc9.tar.gz
ports-52e42e94a130993c24900e8833269464fca60cc9.zip
- Convert to USES=tcl
- Convert to new LIB_DEPENDS format
Notes
Notes: svn path=/head/; revision=334316
Diffstat (limited to 'ftp')
-rw-r--r--ftp/wzdftpd/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/ftp/wzdftpd/Makefile b/ftp/wzdftpd/Makefile
index 14a3306c9784..362c8038009b 100644
--- a/ftp/wzdftpd/Makefile
+++ b/ftp/wzdftpd/Makefile
@@ -45,9 +45,8 @@ CONFIGURE_ARGS+= --disable-utf8
.endif
.if ${PORT_OPTIONS:MTCL}
-USE_TCL_BUILD= yes
-USE_TCL= yes
-CONFIGURE_ARGS+= --with-tcl=${TCL_LIBDIR}
+USES+= tcl
+CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR}
PLIST_SUB+= TCL=""
.else
PLIST_SUB+= TCL="@comment "
@@ -60,7 +59,7 @@ CONFIGURE_ARGS+= --disable-openssl
.endif
.if ${PORT_OPTIONS:MGNUTLS}
-LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
+LIB_DEPENDS+= libgnutls.so:${PORTSDIR}/security/gnutls
.else
CONFIGURE_ARGS+= --disable-gnutls
.endif
@@ -111,13 +110,13 @@ PLIST_SUB+= ZEROCONF="@comment "
.endif
.if ${PORT_OPTIONS:MAVAHI}
-LIB_DEPENDS+= dbus-1:${PORTSDIR}/devel/dbus \
- avahi-core:${PORTSDIR}/net/avahi-app
+LIB_DEPENDS+= libdbus-1.so:${PORTSDIR}/devel/dbus \
+ libavahi-core.so:${PORTSDIR}/net/avahi-app
CONFIGURE_ARGS+= --with-zeroconf --enable-avahi
.endif
.if ${PORT_OPTIONS:MHOWL}
-LIB_DEPENDS+= howl:${PORTSDIR}/net/howl
+LIB_DEPENDS+= libhowl.so:${PORTSDIR}/net/howl
CPPFLAGS+= -I${LOCALBASE}/include/howl
CONFIGURE_ARGS+= --with-zeroconf --enable-howl
.endif