aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-28 15:44:38 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-28 15:44:38 +0000
commit20ace5f382e4265fe086f6f958cba21234f564d9 (patch)
treeaee814afa35e31e8762260f9abd2e89876afa876 /ftp
parentac1c3bd4d13752ff9c27a28091a96e40d6dbed11 (diff)
downloadports-20ace5f382e4265fe086f6f958cba21234f564d9.tar.gz
ports-20ace5f382e4265fe086f6f958cba21234f564d9.zip
- Update to 3.13.0
PR: 202563 Submitted by: matthew@reztek.cz (maintainer)
Notes
Notes: svn path=/head/; revision=395504
Diffstat (limited to 'ftp')
-rw-r--r--ftp/filezilla/Makefile9
-rw-r--r--ftp/filezilla/distinfo4
-rw-r--r--ftp/filezilla/files/patch-src_interface_Makefile.am11
-rw-r--r--ftp/filezilla/files/patch-src_interface_Makefile.in11
-rw-r--r--ftp/filezilla/files/patch-src_interface_fzputtygen__interface.h43
5 files changed, 72 insertions, 6 deletions
diff --git a/ftp/filezilla/Makefile b/ftp/filezilla/Makefile
index 689fe28b1765..78948c9b4245 100644
--- a/ftp/filezilla/Makefile
+++ b/ftp/filezilla/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= filezilla
-PORTVERSION= 3.12.0.2
+PORTVERSION= 3.13.0
CATEGORIES= ftp
MASTER_SITES= SF/${PORTNAME}/FileZilla_Client/${PORTVERSION}
DISTNAME= FileZilla_${PORTVERSION}_src
@@ -18,10 +18,12 @@ BUILD_DEPENDS:= ${RUN_DEPENDS}
LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
libgnutls.so:${PORTSDIR}/security/gnutls \
libidn.so:${PORTSDIR}/dns/libidn \
- libtinyxml.so:${PORTSDIR}/textproc/tinyxml
+ libpugixml.so:${PORTSDIR}/textproc/pugixml
+
+BROKEN_FreeBSD_9= requires C++14 complier, 9.x lacks C++11 standard library
INSTALLS_ICONS= yes
-USES= compiler:c++11-lib gmake pkgconfig tar:bzip2
+USES= compiler:c++14-lang gmake pkgconfig tar:bzip2
USE_SQLITE= 3
USE_WX= 3.0
WX_CONF_ARGS= relative
@@ -48,7 +50,6 @@ CONFIGURE_ARGS+= --disable-manualupdatecheck
.include <bsd.port.pre.mk>
.if ${CHOSEN_COMPILER_TYPE} == "gcc"
-BROKEN_FreeBSD= GCC dies with Internal Compiler Error
.if ${ARCH} == i386 && ! ${CFLAGS:M-march=*}
# needed for __atomic_exchange_8, __atmoic_fetch_add_8, __atomic_store_8
CFLAGS+= -march=i586
diff --git a/ftp/filezilla/distinfo b/ftp/filezilla/distinfo
index 8f41f76a0c37..30fe21224800 100644
--- a/ftp/filezilla/distinfo
+++ b/ftp/filezilla/distinfo
@@ -1,2 +1,2 @@
-SHA256 (FileZilla_3.12.0.2_src.tar.bz2) = 7a296fc2cd94d00d3a14ad29b84ff081c60a791f4cddc07f0bd8022bd57e1d0d
-SIZE (FileZilla_3.12.0.2_src.tar.bz2) = 4440836
+SHA256 (FileZilla_3.13.0_src.tar.bz2) = e6c21b41b1318d0d75273aca94cfda3039c9847bdb5adc4b9d480ecdcdfa4fc7
+SIZE (FileZilla_3.13.0_src.tar.bz2) = 4542742
diff --git a/ftp/filezilla/files/patch-src_interface_Makefile.am b/ftp/filezilla/files/patch-src_interface_Makefile.am
new file mode 100644
index 000000000000..edeb8b4803f2
--- /dev/null
+++ b/ftp/filezilla/files/patch-src_interface_Makefile.am
@@ -0,0 +1,11 @@
+--- src/interface/Makefile.am.orig 2015-07-31 03:30:02 UTC
++++ src/interface/Makefile.am
+@@ -155,7 +155,7 @@ noinst_HEADERS = aboutdialog.h \
+ filter_conditions_dialog.h \
+ filteredit.h \
+ file_utils.h \
+- fzputtygen_interface.cpp \
++ fzputtygen_interface.h \
+ import.h \
+ inputdialog.h \
+ ipcmutex.h \
diff --git a/ftp/filezilla/files/patch-src_interface_Makefile.in b/ftp/filezilla/files/patch-src_interface_Makefile.in
new file mode 100644
index 000000000000..fd55fdf56de3
--- /dev/null
+++ b/ftp/filezilla/files/patch-src_interface_Makefile.in
@@ -0,0 +1,11 @@
+--- src/interface/Makefile.in.orig 2015-08-18 16:03:24 UTC
++++ src/interface/Makefile.in
+@@ -630,7 +630,7 @@ noinst_HEADERS = aboutdialog.h \
+ filter_conditions_dialog.h \
+ filteredit.h \
+ file_utils.h \
+- fzputtygen_interface.cpp \
++ fzputtygen_interface.h \
+ import.h \
+ inputdialog.h \
+ ipcmutex.h \
diff --git a/ftp/filezilla/files/patch-src_interface_fzputtygen__interface.h b/ftp/filezilla/files/patch-src_interface_fzputtygen__interface.h
new file mode 100644
index 000000000000..42e24692b188
--- /dev/null
+++ b/ftp/filezilla/files/patch-src_interface_fzputtygen__interface.h
@@ -0,0 +1,43 @@
+--- src/interface/fzputtygen_interface.h.orig 2015-08-18 16:02:52 UTC
++++ src/interface/fzputtygen_interface.h
+@@ -0,0 +1,40 @@
++#ifndef FILEZILLA_FZPUTTYGEN_INTERFACE_HEADER
++#define FILEZILLA_FZPUTTYGEN_INTERFACE_HEADER
++
++#include <wx/process.h>
++
++class CFZPuttyGenInterface
++{
++public:
++ CFZPuttyGenInterface(wxWindow* parent);
++ virtual ~CFZPuttyGenInterface();
++ bool LoadKeyFile(wxString& keyFile, bool silent, wxString& comment, wxString& data);
++
++ void EndProcess();
++ void DeleteProcess();
++ bool IsProcessCreated();
++ bool IsProcessStarted();
++
++protected:
++ // return -1 on error
++ int NeedsConversion(wxString keyFile, bool silent);
++
++ // return -1 on error
++ int IsKeyFileEncrypted(wxString keyFile, bool silent);
++
++ wxProcess* m_pProcess{};
++ bool m_initialized{};
++ wxWindow* m_parent;
++
++ enum ReplyCode {
++ success,
++ error,
++ failure
++ };
++
++ bool LoadProcess(bool silent);
++ bool Send(const wxString& cmd);
++ ReplyCode GetReply(wxString& reply);
++};
++
++#endif /* FILEZILLA_FZPUTTYGEN_INTERFACE_HEADER */