aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2000-09-04 00:56:47 +0000
committerKris Kennaway <kris@FreeBSD.org>2000-09-04 00:56:47 +0000
commit2c9f48dec6cc44de6bd732fe4e6131ffe302ed3d (patch)
treef4886c9457727594cb61ac8cbf8fc5304d57ad8b /ftp
parent4cb9edbf17834597ee5a30c7519c12731d650c69 (diff)
downloadports-2c9f48dec6cc44de6bd732fe4e6131ffe302ed3d.tar.gz
ports-2c9f48dec6cc44de6bd732fe4e6131ffe302ed3d.zip
Upgrade to curl 7.2.1
Submitted by: Peter Pentchev <roam@orbitel.bg>
Notes
Notes: svn path=/head/; revision=32234
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile10
-rw-r--r--ftp/curl/distinfo2
-rw-r--r--ftp/curl/pkg-plist10
3 files changed, 20 insertions, 2 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index ab1abcd64fcd..277e77bf4930 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= curl
-PORTVERSION= 6.5.2
+PORTVERSION= 7.2.1
CATEGORIES= ftp www
MASTER_SITES= http://curl.haxx.nu/stuff/ \
ftp://ftp.rhrz.uni-bonn.de/pub-koeln/net/inet/ \
@@ -18,6 +18,13 @@ MASTER_SITES= http://curl.haxx.nu/stuff/ \
MAINTAINER= kris@FreeBSD.org
MAN1= curl.1
+MAN3= curl_easy_cleanup.3 curl_easy_init.3 curl_easy_perform.3 curl_easy_setopt.3 curl_formparse.3 curl_getdate.3 curl_getenv.3 curl_slist_append.3 curl_slist_free_all.3 curl_version.3
+
+INSTALLS_SHLIB= yes
+SHLIB_VER= 0
+
+MAKE_ENV= SHLIB_VER="${SHLIB_VER}"
+PLIST_SUB= SHLIB_VER="${SHLIB_VER}"
.if defined(WITH_SSL)
USE_OPENSSL= RSA
@@ -35,6 +42,7 @@ CONFIGURE_ENV+= LIBS="-L${OPENSSLLIB} -lcrypto -lRSAglue -L${LOCALBASE}/lib -lrs
.endif
GNU_CONFIGURE= yes
+USE_AUTOMAKE= yes
MAKEFILES= Makefile src/Makefile
post-configure:
diff --git a/ftp/curl/distinfo b/ftp/curl/distinfo
index d56dcf6869dd..2c4a1e286d3d 100644
--- a/ftp/curl/distinfo
+++ b/ftp/curl/distinfo
@@ -1 +1 @@
-MD5 (curl-6.5.2.tar.gz) = af75db1f23a81fd8ea262677f870bca1
+MD5 (curl-7.2.1.tar.gz) = f74497cf49e1f61bb1f07e9353606f38
diff --git a/ftp/curl/pkg-plist b/ftp/curl/pkg-plist
index 09783b6111ee..1802e3d7b89b 100644
--- a/ftp/curl/pkg-plist
+++ b/ftp/curl/pkg-plist
@@ -1 +1,11 @@
bin/curl
+include/curl/curl.h
+include/curl/easy.h
+include/curl/mprintf.h
+include/curl/stdcheaders.h
+include/curl/types.h
+@dirrm include/curl
+lib/libcurl.a
+lib/libcurl.la
+lib/libcurl.so.%%SHLIB_VER%%
+@unexec rm -f %B/libcurl.so