aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-28 11:37:41 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-28 11:37:41 +0000
commit3ce84e9871e5be557968a009ad56c180e96faca3 (patch)
tree33a48334de4d1cf20d3ccf446a56948b9500ece3 /ftp
parent464fa85ec7dca14b4d12768ef7d95058eef073d9 (diff)
downloadports-3ce84e9871e5be557968a009ad56c180e96faca3.tar.gz
ports-3ce84e9871e5be557968a009ad56c180e96faca3.zip
- Add IGNORE for LibreSSL
PR: 198397 (based on) Submitted by: Bernard Spil <spil.oss@gmail.com>
Notes
Notes: svn path=/head/; revision=382461
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 5078acb6a1d6..313d94fbf46f 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -158,6 +158,15 @@ IGNORE= only supports LDAPS with SSL
IGNORE= only supports LIBSSH2 with OpenSSL
.endif
+.if ${PORT_OPTIONS:MOPENSSL} && defined(OPENSSL_PORT) && ${OPENSSL_PORT} == "security/libressl"
+.if ${PORT_OPTIONS:MGSSAPI_BASE}
+IGNORE= with GSSAPI_BASE, configure failed to detect OpenSSL/LibreSSL from ports and link against base OpenSSL
+.endif
+.if ${PORT_OPTIONS:MTLS_SRP}
+IGNORE= unsupported TLS-SRP in LibreSSL
+.endif
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS = / s|$$| docs|; /^DIST_SUBDIRS = / s| docs||; /cd docs &&/d' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|\(flags_dbg_off=\)".*"|\1""|; s|\(flags_opt_off=\)".*"|\1""|; s|lib/pkgconfig|libdata/pkgconfig|g' ${WRKSRC}/configure