aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorTorsten Blum <torstenb@FreeBSD.org>1998-06-08 12:41:15 +0000
committerTorsten Blum <torstenb@FreeBSD.org>1998-06-08 12:41:15 +0000
commit116a2abbae7c8218a7c5ca4f56261af1c9bb8eb0 (patch)
treeab6313705edfa143175d722c0fb42f53ac2988a9 /ftp
parent3bb4f98c891f5ce8e00d96358ebc05d18c79b8fe (diff)
downloadports-116a2abbae7c8218a7c5ca4f56261af1c9bb8eb0.tar.gz
ports-116a2abbae7c8218a7c5ca4f56261af1c9bb8eb0.zip
- Upgrade to 2.9
- Use perl5
Notes
Notes: svn path=/head/; revision=11354
Diffstat (limited to 'ftp')
-rw-r--r--ftp/mirror/Makefile10
-rw-r--r--ftp/mirror/distinfo2
-rw-r--r--ftp/mirror/files/patch-aa38
-rw-r--r--ftp/mirror/files/patch-ab68
-rw-r--r--ftp/mirror/files/patch-ac53
-rw-r--r--ftp/mirror/files/patch-ae24
-rw-r--r--ftp/mirror/files/patch-af12
-rw-r--r--ftp/mirror/pkg-plist4
8 files changed, 113 insertions, 98 deletions
diff --git a/ftp/mirror/Makefile b/ftp/mirror/Makefile
index 0d018052995c..77bfe4200f01 100644
--- a/ftp/mirror/Makefile
+++ b/ftp/mirror/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: mirror
-# Version required: 2.8
+# Version required: 2.9
# Date created: 15 May 1995
# Whom: torstenb
#
-# $Id: Makefile,v 1.5 1996/11/18 14:08:35 asami Exp $
+# $Id: Makefile,v 1.6 1996/12/01 01:22:54 obrien Exp $
#
-DISTNAME= mirror-2.8
+DISTNAME= mirror-2.9
CATEGORIES= net
MASTER_SITES= ftp://src.doc.ic.ac.uk/computing/archiving/mirror/
@@ -14,7 +14,9 @@ MAINTAINER= torstenb@FreeBSD.ORG
NO_WRKSUBDIR= yes
MAKEFILE= makefile
-MAN1= mirror.1 mirrormaster.1
+MAN1= mirror.1 mirror-master.1
+
+RUN_DEPENDS= perl5.00404:${PORTSDIR}/lang/perl5
pre-install:
${MKDIR} ${PREFIX}/lib/mirror
diff --git a/ftp/mirror/distinfo b/ftp/mirror/distinfo
index 382496c7f2c5..b2110292d7ed 100644
--- a/ftp/mirror/distinfo
+++ b/ftp/mirror/distinfo
@@ -1 +1 @@
-MD5 (mirror-2.8.tar.gz) = a0a3ffec4b8e0fd71034cab8a0b1b010
+MD5 (mirror-2.9.tar.gz) = 8e527980ac597cfb653bf3686f22a29c
diff --git a/ftp/mirror/files/patch-aa b/ftp/mirror/files/patch-aa
index da43444ff3dd..8cfb9afd12cd 100644
--- a/ftp/mirror/files/patch-aa
+++ b/ftp/mirror/files/patch-aa
@@ -1,24 +1,24 @@
-*** makefile.orig Thu Jun 1 21:26:26 1995
---- makefile Sat Mar 16 16:19:59 1996
+*** makefile.orig Mon Jun 1 20:28:47 1998
+--- makefile Mon Jun 8 13:59:10 1998
***************
-*** 6,12 ****
- support/cyber-patches support/lstest.pl new-patches-by
+*** 41,47 ****
+ $(WEBFILES)
all:
! echo try make mirror.tar
mirror.tar: $(FILES)
- rev=`./mirror -v | perl -ane 'print "$$F[2]\n";'`; echo $rev; \
---- 6,12 ----
- support/cyber-patches support/lstest.pl new-patches-by
+ rev=`./mirror.pl -v | perl -ane 'print "$$F[2]\n";'`; echo $rev; \
+--- 41,47 ----
+ $(WEBFILES)
all:
! # echo try make mirror.tar
mirror.tar: $(FILES)
- rev=`./mirror -v | perl -ane 'print "$$F[2]\n";'`; echo $rev; \
+ rev=`./mirror.pl -v | perl -ane 'print "$$F[2]\n";'`; echo $rev; \
***************
-*** 25,50 ****
+*** 65,89 ****
# mode to install executables
EXMODE = 755
# group to own all the files
@@ -32,20 +32,19 @@
install:
! install -m $(PLMODE) -g $(GRP) lchat.pl $(PLDIR)
-! install -m $(PLMODE) -g $(GRP) chat2.pl $(PLDIR)
! install -m $(PLMODE) -g $(GRP) dateconv.pl $(PLDIR)
! install -m $(PLMODE) -g $(GRP) ftp.pl $(PLDIR)
! install -m $(PLMODE) -g $(GRP) lsparse.pl $(PLDIR)
-! install -m $(EXMODE) -g $(GRP) mirror.pl $(PLDIR)
-! install -m $(EXMODE) -g $(GRP) do_unlinks $(BINDIR)
-! install -m $(EXMODE) -g $(GRP) pkgs_to_mmin $(BINDIR)
-! install -m $(EXMODE) -g $(GRP) mm $(BINDIR)/mirror-master
+! install -m $(EXMODE) -g $(GRP) mirror.pl $(BINDIR)/mirror
+! install -m $(EXMODE) -g $(GRP) do_unlinks.pl $(BINDIR)/do_unlinks
+! install -m $(EXMODE) -g $(GRP) pkgs_to_mmin.pl $(BINDIR)/pkgs_to_mmin
+! install -m $(EXMODE) -g $(GRP) mm.pl $(BINDIR)/mirror-master
! install -m $(PLMODE) -g $(GRP) mirror.man $(MANDIR)/mirror.1
! install -m $(PLMODE) -g $(GRP) mm.man $(MANDIR)/mirror-master.1
# directory to install .pl (perl library) files for rperl
RPLDIR = /usr/local/rperl5/lib/perl5
---- 25,51 ----
+--- 65,89 ----
# mode to install executables
EXMODE = 755
# group to own all the files
@@ -59,16 +58,15 @@
install:
! install -c -m $(PLMODE) -g $(GRP) lchat.pl $(PLDIR)
-! # install -c -m $(PLMODE) -g $(GRP) chat2.pl $(PLDIR)
! install -c -m $(PLMODE) -g $(GRP) dateconv.pl $(PLDIR)
! install -c -m $(PLMODE) -g $(GRP) ftp.pl $(PLDIR)
! install -c -m $(PLMODE) -g $(GRP) lsparse.pl $(PLDIR)
! install -c -m $(EXMODE) -g $(GRP) mirror.pl $(BINDIR)/mirror
-! install -c -m $(EXMODE) -g $(GRP) do_unlinks $(BINDIR)
-! install -c -m $(EXMODE) -g $(GRP) pkgs_to_mmin $(BINDIR)
-! install -c -m $(EXMODE) -g $(GRP) mm $(BINDIR)/mirrormaster
+! install -c -m $(EXMODE) -g $(GRP) do_unlinks.pl $(BINDIR)/do_unlinks
+! install -c -m $(EXMODE) -g $(GRP) pkgs_to_mmin.pl $(BINDIR)/pkgs_to_mmin
+! install -c -m $(EXMODE) -g $(GRP) mm.pl $(BINDIR)/mirror-master
! install -c -m $(PLMODE) -g $(GRP) mirror.man $(MANDIR)/mirror.1
-! install -c -m $(PLMODE) -g $(GRP) mm.man $(MANDIR)/mirrormaster.1
+! install -c -m $(PLMODE) -g $(GRP) mm.man $(MANDIR)/mirror-master.1
! install -c -m $(PLMODE) -g $(GRP) mirror.defaults $(PLDIR)/mirror.defaults.sample
# directory to install .pl (perl library) files for rperl
diff --git a/ftp/mirror/files/patch-ab b/ftp/mirror/files/patch-ab
index 5eece767c7a0..863467fc6598 100644
--- a/ftp/mirror/files/patch-ab
+++ b/ftp/mirror/files/patch-ab
@@ -1,76 +1,80 @@
-*** mirror.defaults.orig Sat Mar 16 15:42:36 1996
---- mirror.defaults Sat Mar 16 15:45:41 1996
+*** mirror.defaults.orig Fri May 29 20:57:46 1998
+--- mirror.defaults Mon Jun 8 14:01:11 1998
***************
-*** 11,37 ****
+*** 11,39 ****
# The LOCAL hostname - if not the same as `hostname`
- # (I advertise the name sunsite.doc.ic.ac.uk but the machine is
- # really phoenix.doc.ic.ac.uk.)
-! hostname=sunsite.doc.ic.ac.uk
+ # (I advertise the name sunsite.org.uk but the machine is
+ # really swallow.sunsite.org.uk.)
+! hostname=sunsite.org.uk
# Keep all local_dirs relative to here
! local_dir=/public/
-! remote_password=ukuug-soft@doc.ic.ac.uk
+ # The local_dir must exist FIRST
+ #local_dir_check=true
+! remote_password=wizards@sunsite.org.uk
mail_to=
# Don't mirror file modes. Set all dirs/files to these
dir_mode=0755
file_mode=0444
-! # By defaults files are owned by root.zero
+ # By defaults files are owned by root.zero
! user=0
! group=0
- # # Keep a log file in each updated directory
- # update_log=.mirror
+ # # Keep a log file in each updated directory
+ # update_log=.mirror
! update_log=
# Don't overwrite my mirror log with the remote one.
# Don't pull back any of their mirror temporary files.
# nor any FSP or gopher files...
- exclude_patt=(^|/)(\.mirror$|core$|\.cap|\.in\..*\.$|MIRROR\.LOG|#.*#|\.FSP|\.cache|\.zipped|\.notar|\.message|lost\+found/|Network Trash Folder)
- # Try to compress everything
- compress_patt=.
+ exclude_patt=(^|/)(\.mirror$|\.mirror\.log|core$|\.cap|\.in\..*\.$|MIRROR\.LOG|#.*#|\.FSP|\.cache|\.zipped|\.notar|\.message|lost\+found/|Network Trash Folder)|suky.mpe?g
+ # Do not to compress anything
+ compress_patt=
! compress_prog=compress
# Don't compress information files, files that don't benifit from
# being compressed, files that tell ftpd, gopher, wais... to do things,
# the sources for compression programs...
---- 11,37 ----
+--- 11,39 ----
# The LOCAL hostname - if not the same as `hostname`
- # (I advertise the name sunsite.doc.ic.ac.uk but the machine is
- # really phoenix.doc.ic.ac.uk.)
-! # hostname=sunsite.doc.ic.ac.uk
+ # (I advertise the name sunsite.org.uk but the machine is
+ # really swallow.sunsite.org.uk.)
+! # hostname=sunsite.org.uk
# Keep all local_dirs relative to here
! local_dir=/home/ftp/pub
-! # remote_password=ukuug-soft@doc.ic.ac.uk
+ # The local_dir must exist FIRST
+ #local_dir_check=true
+! # remote_password=wizards@sunsite.org.uk
mail_to=
# Don't mirror file modes. Set all dirs/files to these
dir_mode=0755
file_mode=0444
-! # By defaults files are owned by root.wheel
+ # By defaults files are owned by root.zero
! # user=0
! # group=0
- # # Keep a log file in each updated directory
- # update_log=.mirror
+ # # Keep a log file in each updated directory
+ # update_log=.mirror
! # update_log=
# Don't overwrite my mirror log with the remote one.
# Don't pull back any of their mirror temporary files.
# nor any FSP or gopher files...
- exclude_patt=(^|/)(\.mirror$|core$|\.cap|\.in\..*\.$|MIRROR\.LOG|#.*#|\.FSP|\.cache|\.zipped|\.notar|\.message|lost\+found/|Network Trash Folder)
- # Try to compress everything
- compress_patt=.
+ exclude_patt=(^|/)(\.mirror$|\.mirror\.log|core$|\.cap|\.in\..*\.$|MIRROR\.LOG|#.*#|\.FSP|\.cache|\.zipped|\.notar|\.message|lost\+found/|Network Trash Folder)|suky.mpe?g
+ # Do not to compress anything
+ compress_patt=
! compress_prog=gzip
# Don't compress information files, files that don't benifit from
# being compressed, files that tell ftpd, gopher, wais... to do things,
# the sources for compression programs...
***************
-*** 44,50 ****
- # shk is multimedia? used on apple2s.
- compress_excl+|-z(\d+)?$|\.tgz|_tgz|\.tar\.Z|\.tar\.gz|\.taz$|\.arc$|\.zip$|\.lzh$|\.zoo$|\.exe$|\.lha$|\.zom$|\.gif$|\.jpeg$|\.jpg$|\.mpeg$|\.au$|\.shk$|read.*me|index|info|faq|gzip|compress|(^|/)\.\.?$
+*** 47,53 ****
+ # rpm and deb are package formats used on RedHat and Debian Linux
+ compress_excl+|-z(\d+)?$|\.tgz|_tgz|\.tar\.Z|\.tar\.gz|\.taz$|\.arc$|\.zip$|\.lzh$|\.zoo$|\.exe$|\.lha$|\.zom$|\.gif$|\.jpeg$|\.jpg$|\.mpeg$|\.au$|\.shk$|rpm$|deb$|read.*me|index|info|faq|gzip|compress|(^|/)\.\.?$
# Don't delete own mirror log, .notar or .cache files (incl in subdirs)
-! # delete_excl=(^|/)\.(mirror|notar|cache)$
+! # delete_excl=(^|/)\.(mirror|notar|cache)$
# Ignore any local readme and .mirror files
local_ignore=README.doc.ic|(^|/)\.(mirror|notar)$
# Automatically delete local copies of files that the
---- 44,50 ----
- # shk is multimedia? used on apple2s.
- compress_excl+|-z(\d+)?$|\.tgz|_tgz|\.tar\.Z|\.tar\.gz|\.taz$|\.arc$|\.zip$|\.lzh$|\.zoo$|\.exe$|\.lha$|\.zom$|\.gif$|\.jpeg$|\.jpg$|\.mpeg$|\.au$|\.shk$|read.*me|index|info|faq|gzip|compress|(^|/)\.\.?$
+--- 47,53 ----
+ # rpm and deb are package formats used on RedHat and Debian Linux
+ compress_excl+|-z(\d+)?$|\.tgz|_tgz|\.tar\.Z|\.tar\.gz|\.taz$|\.arc$|\.zip$|\.lzh$|\.zoo$|\.exe$|\.lha$|\.zom$|\.gif$|\.jpeg$|\.jpg$|\.mpeg$|\.au$|\.shk$|rpm$|deb$|read.*me|index|info|faq|gzip|compress|(^|/)\.\.?$
# Don't delete own mirror log, .notar or .cache files (incl in subdirs)
-! delete_excl=(^|/)\.(mirror|notar|cache)$
+! delete_excl=(^|/)\.(mirror|notar|cache)$
# Ignore any local readme and .mirror files
local_ignore=README.doc.ic|(^|/)\.(mirror|notar)$
# Automatically delete local copies of files that the
diff --git a/ftp/mirror/files/patch-ac b/ftp/mirror/files/patch-ac
index 427f851fb0e9..184a1905f9be 100644
--- a/ftp/mirror/files/patch-ac
+++ b/ftp/mirror/files/patch-ac
@@ -1,24 +1,35 @@
-*** mirror.pl.orig Sat Mar 16 15:46:09 1996
---- mirror.pl Sat Mar 16 15:51:49 1996
+*** mirror.pl.orig Fri May 29 21:01:42 1998
+--- mirror.pl Mon Jun 8 14:36:52 1998
***************
-*** 75,81 ****
-
- # Try to find the default localation of various programs via
+*** 1,4 ****
+! #!/usr/bin/perl
+ # Make local directories mirror images of a remote sites
+ #
+ #
+--- 1,4 ----
+! #!/usr/local/bin/perl5
+ # Make local directories mirror images of a remote sites
+ #
+ #
+***************
+*** 104,110 ****
+ # Try to find the default location of various programs via
# the users PATH then using $extra_path
-! $extra_path = '/usr/local/bin:/usr/new/bin:/usr/public/bin:/usr/ucb:/usr/bin:/bin:/etc:/usr/etc:/usr/local/etc';
- $ENV{ 'PATH' } .= ':' . $extra_path;
-
- &trap_signals();
---- 75,81 ----
-
- # Try to find the default localation of various programs via
+ if( ! $on_win ){
+! $extra_path = '/usr/local/bin:/usr/new/bin:/usr/public/bin:/usr/ucb:/usr/bin:/bin:/etc:/usr/etc:/usr/local/etc';
+ }
+ if( $extra_path ne '' ){
+ $ENV{ 'PATH' } .= $path_sep . $extra_path;
+--- 104,110 ----
+ # Try to find the default location of various programs via
# the users PATH then using $extra_path
-! $extra_path = '/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin';
- $ENV{ 'PATH' } .= ':' . $extra_path;
-
- &trap_signals();
+ if( ! $on_win ){
+! $extra_path = '/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin';
+ }
+ if( $extra_path ne '' ){
+ $ENV{ 'PATH' } .= $path_sep . $extra_path;
***************
-*** 128,146 ****
+*** 159,177 ****
$rm_prog = &find_prog( 'rm' );
# Generate checksums
@@ -37,8 +48,8 @@
! $dir = &real_dir_from_path( $0 );
unshift( @INC, $dir );
- # Make sure that your PERLLIB environment variable can get you
---- 128,147 ----
+ # Debian GNU/Linux stores mirror.defaults in /etc/mirror
+--- 159,178 ----
$rm_prog = &find_prog( 'rm' );
# Generate checksums
@@ -55,7 +66,7 @@
# Put the directory that mirror is actually in at the start of PERLLIB.
! # $dir = &real_dir_from_path( $0 );
-! $dir = "!!PREFIX!!/lib/mirror";
+! $dir = "/usr/local/lib/mirror";
unshift( @INC, $dir );
- # Make sure that your PERLLIB environment variable can get you
+ # Debian GNU/Linux stores mirror.defaults in /etc/mirror
diff --git a/ftp/mirror/files/patch-ae b/ftp/mirror/files/patch-ae
index fbcf0ad24238..281d14cbb23b 100644
--- a/ftp/mirror/files/patch-ae
+++ b/ftp/mirror/files/patch-ae
@@ -1,19 +1,19 @@
-*** ftp.pl.orig Tue May 23 23:53:25 1995
---- ftp.pl Tue Nov 25 09:20:17 1997
+*** ftp.pl.orig Mon Jun 8 14:11:39 1998
+--- ftp.pl Mon Jun 8 14:11:42 1998
***************
-*** 430,436 ****
+*** 486,492 ****
return 0;
}
if( $ret == 1 ) {
-! $response =~ m/^227 Entering Passive Mode \((\d+),(\d+),(\d+),(\d+),(\d+),(\d+)\)$/;
- $newhost = sprintf( "%d.%d.%d.%d", $1, $2, $3, $4 );
- $newport = $5 * 256 + $6;
- }
---- 430,436 ----
+! if( $response =~ m/^227 Entering Passive Mode \((\d+),(\d+),(\d+),(\d+),(\d+),(\d+)\)/ ){
+ $newhost = sprintf( "%d.%d.%d.%d", $1, $2, $3, $4 );
+ $newport = $5 * 256 + $6;
+ }
+--- 486,492 ----
return 0;
}
if( $ret == 1 ) {
-! $response =~ m/^227 .* \((\d+),(\d+),(\d+),(\d+),(\d+),(\d+)\)$/;
- $newhost = sprintf( "%d.%d.%d.%d", $1, $2, $3, $4 );
- $newport = $5 * 256 + $6;
- }
+! if( $response =~ m/^227 .* \((\d+),(\d+),(\d+),(\d+),(\d+),(\d+)\)/ ){
+ $newhost = sprintf( "%d.%d.%d.%d", $1, $2, $3, $4 );
+ $newport = $5 * 256 + $6;
+ }
diff --git a/ftp/mirror/files/patch-af b/ftp/mirror/files/patch-af
index ab7f5db0b877..8a659e1080c1 100644
--- a/ftp/mirror/files/patch-af
+++ b/ftp/mirror/files/patch-af
@@ -1,7 +1,7 @@
-*** lchat.pl.orig Wed Jun 7 22:19:22 1995
---- lchat.pl Tue Nov 25 09:20:20 1997
+*** lchat.pl.orig Fri May 29 21:05:46 1998
+--- lchat.pl Mon Jun 8 14:34:37 1998
***************
-*** 123,129 ****
+*** 161,167 ****
# Similar to open_port, but does less. Used for PASV code with ftp.pl
# -Erez Zadok.
sub open_newport { ## public
@@ -9,7 +9,7 @@
local($serveraddr,$serverproc);
---- 123,129 ----
+--- 161,167 ----
# Similar to open_port, but does less. Used for PASV code with ftp.pl
# -Erez Zadok.
sub open_newport { ## public
@@ -18,7 +18,7 @@
local($serveraddr,$serverproc);
***************
-*** 142,159 ****
+*** 180,197 ****
}
$serverproc = pack($sockaddr, 2, $port, $serveraddr);
@@ -37,7 +37,7 @@
return 1;
}
##############################################################################
---- 142,159 ----
+--- 180,197 ----
}
$serverproc = pack($sockaddr, 2, $port, $serveraddr);
diff --git a/ftp/mirror/pkg-plist b/ftp/mirror/pkg-plist
index 3673f7ebedf1..d419796caeca 100644
--- a/ftp/mirror/pkg-plist
+++ b/ftp/mirror/pkg-plist
@@ -1,11 +1,11 @@
bin/mirror
bin/do_unlinks
bin/pkgs_to_mmin
-bin/mirrormaster
+bin/mirror-master
lib/mirror/lchat.pl
lib/mirror/dateconv.pl
lib/mirror/ftp.pl
lib/mirror/lsparse.pl
lib/mirror/mirror.defaults.sample
man/man1/mirror.1.gz
-man/man1/mirrormaster.1.gz
+man/man1/mirror-master.1.gz