aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-05-20 03:15:26 +0000
committerWill Andrews <will@FreeBSD.org>2001-05-20 03:15:26 +0000
commitf16ad320ace6ae5434af7dc33e8fe83940fc9dfc (patch)
treed9352d1224b97190eb45ddd15d1ffb84ef2167d6 /ftp
parent2ff756d78e3a2dc3acafb39a2cc4097c868af9c5 (diff)
downloadports-f16ad320ace6ae5434af7dc33e8fe83940fc9dfc.tar.gz
ports-f16ad320ace6ae5434af7dc33e8fe83940fc9dfc.zip
Add ftpproxy 1.0.1, a ftp proxy.
PR: 27390 Submitted by: Philippe Le Berre <philippe@le-berre.com>
Notes
Notes: svn path=/head/; revision=42779
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/ftpproxy/Makefile26
-rw-r--r--ftp/ftpproxy/distinfo1
-rw-r--r--ftp/ftpproxy/files/patch-ftp.c19
-rw-r--r--ftp/ftpproxy/files/patch-main.c19
-rw-r--r--ftp/ftpproxy/pkg-comment1
-rw-r--r--ftp/ftpproxy/pkg-descr12
-rw-r--r--ftp/ftpproxy/pkg-list1
-rw-r--r--ftp/ftpproxy/pkg-plist1
9 files changed, 81 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 69ad9151c307..bd5401e65a23 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -13,6 +13,7 @@
SUBDIR += ftpfind
SUBDIR += ftplocate
SUBDIR += ftpmirror
+ SUBDIR += ftpproxy
SUBDIR += ftpq
SUBDIR += ftpsearch
SUBDIR += ftptool
diff --git a/ftp/ftpproxy/Makefile b/ftp/ftpproxy/Makefile
new file mode 100644
index 000000000000..de905ed1cb96
--- /dev/null
+++ b/ftp/ftpproxy/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ftpproxy
+# Date created: 15 May 2001
+# Whom: Philippe Le Berre <philippe@le-berre.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ftpproxy
+PORTVERSION= 1.0.1
+CATEGORIES= ftp
+MASTER_SITES= http://www.quietsche-entchen.de/download/
+DISTNAME= ftpproxy-${PORTVERSION}
+
+MAINTAINER= philippe@le-berre.com
+
+MAN1= ftp.proxy.1
+MANCOMPRESSED= no
+
+pre-build:
+ ${PERL} -pi -e "s@gcc@${CC}@g; s@-O2 -Wall -ggdb@-Wall ${CFLAGS}@g; \
+ s@/usr/local@${PREFIX}@g" ${WRKSRC}/Makefile
+
+post-patch:
+ ${MV} ${WRKSRC}/makefile ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/ftp/ftpproxy/distinfo b/ftp/ftpproxy/distinfo
new file mode 100644
index 000000000000..3e9a8c46f4bc
--- /dev/null
+++ b/ftp/ftpproxy/distinfo
@@ -0,0 +1 @@
+MD5 (ftpproxy-1.0.1.tar.gz) = d9f1ce0a3e028c060a9c5d0d8ae7d6ac
diff --git a/ftp/ftpproxy/files/patch-ftp.c b/ftp/ftpproxy/files/patch-ftp.c
new file mode 100644
index 000000000000..4f424810e4bd
--- /dev/null
+++ b/ftp/ftpproxy/files/patch-ftp.c
@@ -0,0 +1,19 @@
+*** ftp.orig Wed May 16 09:53:13 2001
+--- ftp.c Wed May 16 09:54:08 2001
+***************
+*** 30,36 ****
+
+ #include <time.h>
+ #include <signal.h>
+! #include <wait.h>
+
+ #include <sys/types.h>
+ #include <sys/stat.h>
+--- 30,36 ----
+
+ #include <time.h>
+ #include <signal.h>
+! #include <sys/wait.h>
+
+ #include <sys/types.h>
+ #include <sys/stat.h>
diff --git a/ftp/ftpproxy/files/patch-main.c b/ftp/ftpproxy/files/patch-main.c
new file mode 100644
index 000000000000..8666c128f9f7
--- /dev/null
+++ b/ftp/ftpproxy/files/patch-main.c
@@ -0,0 +1,19 @@
+*** main.orig Wed May 16 09:50:37 2001
+--- main.c Wed May 16 09:50:57 2001
+***************
+*** 29,35 ****
+ #include <stdarg.h>
+
+ #include <signal.h>
+! #include <wait.h>
+
+ #include <sys/types.h>
+ #include <sys/stat.h>
+--- 29,35 ----
+ #include <stdarg.h>
+
+ #include <signal.h>
+! #include <sys/wait.h>
+
+ #include <sys/types.h>
+ #include <sys/stat.h>
diff --git a/ftp/ftpproxy/pkg-comment b/ftp/ftpproxy/pkg-comment
new file mode 100644
index 000000000000..85fdd3290685
--- /dev/null
+++ b/ftp/ftpproxy/pkg-comment
@@ -0,0 +1 @@
+A ftp proxy
diff --git a/ftp/ftpproxy/pkg-descr b/ftp/ftpproxy/pkg-descr
new file mode 100644
index 000000000000..231f962db7fc
--- /dev/null
+++ b/ftp/ftpproxy/pkg-descr
@@ -0,0 +1,12 @@
+ftp.proxy is an application level gateway for FTP.
+It sits between a client and a server forwarding command and data streams
+supporting a subset of the file transfer protocol as described in RFC 959.
+
+Beside this basic function which makes the program useful on firewall
+or masqueraders it offers fixing the FTP server (e.g. for connections
+into a protected LAN) and proxy authentication.
+
+WWW: http://www.quietsche-entchen.de/software/ftp.proxy.html
+
+-Philippe
+philippe@le-berre.com
diff --git a/ftp/ftpproxy/pkg-list b/ftp/ftpproxy/pkg-list
new file mode 100644
index 000000000000..980ec472946d
--- /dev/null
+++ b/ftp/ftpproxy/pkg-list
@@ -0,0 +1 @@
+sbin/ftp.proxy
diff --git a/ftp/ftpproxy/pkg-plist b/ftp/ftpproxy/pkg-plist
new file mode 100644
index 000000000000..980ec472946d
--- /dev/null
+++ b/ftp/ftpproxy/pkg-plist
@@ -0,0 +1 @@
+sbin/ftp.proxy