aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-06-25 02:52:33 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-06-25 02:52:33 +0000
commit4056323dea918ecd83d7d41ab9f81360bd175fe9 (patch)
tree1049862905665b9a13211d785c0450314010f411 /ftp
parentb6dbbfe76598ebeb01cd5dfa11d1879771cb6c2c (diff)
downloadports-4056323dea918ecd83d7d41ab9f81360bd175fe9.tar.gz
ports-4056323dea918ecd83d7d41ab9f81360bd175fe9.zip
- Update to 2.0
Added file(s): - files/patch-Makefile - files/smbftpd.sh.in PR: ports/124363 Submitted by: Jui-Nan Lin <jnlin@csie.nctu.edu.tw> (maintainer)
Notes
Notes: svn path=/head/; revision=215746
Diffstat (limited to 'ftp')
-rw-r--r--ftp/smbftpd/Makefile39
-rw-r--r--ftp/smbftpd/distinfo6
-rw-r--r--ftp/smbftpd/files/patch-Makefile18
-rw-r--r--ftp/smbftpd/files/smbftpd.sh.in30
-rw-r--r--ftp/smbftpd/pkg-plist4
5 files changed, 88 insertions, 9 deletions
diff --git a/ftp/smbftpd/Makefile b/ftp/smbftpd/Makefile
index 6021b55a15ad..8fc654ab12a9 100644
--- a/ftp/smbftpd/Makefile
+++ b/ftp/smbftpd/Makefile
@@ -6,17 +6,46 @@
#
PORTNAME= smbftpd
-PORTVERSION= 0.97
+PORTVERSION= 2.0
CATEGORIES= ftp
-MASTER_SITES= http://www.twbsd.org/download/download.php?file=smbftpd/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www.twbsd.org/download/download.php?file=smbftpd/
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jnlin@csie.nctu.edu.tw
COMMENT= FTP daemon using Samba-like share management mechanism
+OPTIONS= MYSQL "Users database is a MySQL database" off \
+ PGSQL "Users database is a PostgreSQL database" off \
+ SSL "Enable SSL/TLS support" off \
+ ICONV "Enable codepage to unicode conversion for UTF-8 FTP" off
+
HAS_CONFIGURE= yes
-USE_OPENSSL= yes
+MAKE_ENV= OSTYPE=FreeBSD
+CONFIGURE_ARGS= "--prefix=${PREFIX}"
+
+.include <bsd.port.pre.mk>
+
USE_PERL5= yes
+USE_RC_SUBR= smbftpd.sh
-MAKE_ENV= OSTYPE=FreeBSD
+.if defined(WITH_MYSQL)
+USE_MYSQL= yes
+CONFIGURE_ARGS+= "--with-mysql"
+.endif
+
+.if defined(WITH_PGSQL)
+USE_PGSQL= yes
+CONFIGURE_ARGS+= "--with-pgsql"
+.endif
+
+.if defined(WITH_ICONV)
+USE_ICONV= yes
+CONFIGURE_ARGS+= "--with-iconv"
+.endif
+
+.if defined(WITH_SSL)
+CONFIGURE_ARGS+= "--with-ssl"
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/ftp/smbftpd/distinfo b/ftp/smbftpd/distinfo
index f47a1c6d7b9a..e9301f32fe2c 100644
--- a/ftp/smbftpd/distinfo
+++ b/ftp/smbftpd/distinfo
@@ -1,3 +1,3 @@
-MD5 (smbftpd-0.97.tar.gz) = e4c7e4f3b432d79cfd5b3cfafdbff069
-SHA256 (smbftpd-0.97.tar.gz) = 6e4508f885a08e07c744f5861cccdc6d1813e079ce9d6fa9f3eae55cf5635819
-SIZE (smbftpd-0.97.tar.gz) = 123190
+MD5 (smbftpd-2.0.tar.gz) = 771c938073501bb9bb7d1e3e44ae4aae
+SHA256 (smbftpd-2.0.tar.gz) = a3b8aeb444a8fe1275dc243911a206785e83465a87d4f3b89baca0d97cf7d818
+SIZE (smbftpd-2.0.tar.gz) = 138529
diff --git a/ftp/smbftpd/files/patch-Makefile b/ftp/smbftpd/files/patch-Makefile
new file mode 100644
index 000000000000..903b96b9ef8e
--- /dev/null
+++ b/ftp/smbftpd/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile.orig 2008-05-17 11:33:53.160728999 +0800
++++ Makefile 2008-05-17 11:34:04.012697489 +0800
+@@ -126,15 +126,3 @@
+ install -c -m 400 cert/conf/ssl.key/server.key $(CONFIGDIR)/ssl.key/;\
+ fi;
+
+- @if [ "$(OSTYPE)" = "FreeBSD" ]; then \
+- echo "install -c -m 755 os/FreeBSD/smbftpd.sh $(PREFIX)/etc/rc.d/"; \
+- [ -d $(PREFIX)/etc/rc.d ] || install -d $(PREFIX)/etc/rc.d; \
+- install -c -m 755 os/FreeBSD/smbftpd.sh $(PREFIX)/etc/rc.d/; \
+- elif [ "$(OSTYPE)" = "linux" ]; then \
+- if [ ! -f /etc/pam.d/ftpd ]; then \
+- echo "install install -c -m 644 os/linux/ftpd.pam /etc/pam.d/ftpd"; \
+- install -c -m 644 os/linux/ftpd.pam /etc/pam.d/ftpd; \
+- fi; \
+- fi;
+-
+-
diff --git a/ftp/smbftpd/files/smbftpd.sh.in b/ftp/smbftpd/files/smbftpd.sh.in
new file mode 100644
index 000000000000..568929663327
--- /dev/null
+++ b/ftp/smbftpd/files/smbftpd.sh.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+
+# PROVIDE: smbftpd
+# REQUIRE: NETWORKING SERVERS
+# BEFORE: DAEMON
+# KEYWORD: shutdown
+
+#
+# Add the following lines to /etc/rc.conf to enable pure-ftpd:
+#
+# smbftpd_enable="YES"
+#
+
+. %%RC_SUBR%%
+
+name=smbftpd
+rcvar=`set_rcvar`
+
+load_rc_config $name
+
+command=%%PREFIX%%/sbin/smbftpd
+smbftpd_config=${smbftpd_config:-"%%PREFIX%%/etc/smbftpd/smbftpd.conf"}
+required_files=${smbftpd_config}
+pidfile=/var/run/smbftpd.pid
+procname=smbftpd
+
+smbftpd_enable=${smbftpd_enable:-"NO"}
+command_args="-D -s ${smbftpd_config}"
+
+run_rc_command "$1"
diff --git a/ftp/smbftpd/pkg-plist b/ftp/smbftpd/pkg-plist
index a2e7b6b52eb3..48ef75eaa115 100644
--- a/ftp/smbftpd/pkg-plist
+++ b/ftp/smbftpd/pkg-plist
@@ -1,6 +1,8 @@
@comment $FreeBSD$
-etc/rc.d/smbftpd.sh
+bin/smbftpd-user
etc/smbftpd/smbftpd.conf
etc/smbftpd/smbftpd_share.conf
+etc/smbftpd/smbftpd_mysql.conf
+etc/smbftpd/smbftpd_pgsql.conf
sbin/smbftpd
@dirrmtry etc/smbftpd