aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2009-11-30 10:37:59 +0000
committerRenato Botelho <garga@FreeBSD.org>2009-11-30 10:37:59 +0000
commit28015a592ef390fdc40959aa4211837781a8fbdf (patch)
tree95da2b8bf52c2666d363c6cc7d00dfe79a2d2af8 /ftp
parentc8f7339a3c9fa26a197dd4ad61d2da3eebb9de00 (diff)
downloadports-28015a592ef390fdc40959aa4211837781a8fbdf.tar.gz
ports-28015a592ef390fdc40959aa4211837781a8fbdf.zip
Convert --with-virtualchroot to an OPTION, on by default
Sugested by: Jozsef Kovacs <jozsef.kovacs@datira.com>
Notes
Notes: svn path=/head/; revision=245014
Diffstat (limited to 'ftp')
-rw-r--r--ftp/pure-ftpd/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/ftp/pure-ftpd/Makefile b/ftp/pure-ftpd/Makefile
index c3fede52c77e..3e3910169d6c 100644
--- a/ftp/pure-ftpd/Makefile
+++ b/ftp/pure-ftpd/Makefile
@@ -31,7 +31,6 @@ GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --with-everything \
--with-paranoidmsg \
- --with-virtualchroot \
--sysconfdir=${PREFIX}/etc \
--localstatedir=/var
@@ -51,7 +50,8 @@ OPTIONS= LDAP "Support for users in LDAP directories" off \
UPLOADSCRIPT "Support uploadscript daemon" off \
UTF8 "Support for charset conversion (expreimental)" off \
SENDFILE "Support for the sendfile syscall" on \
- LARGEFILE "Support downloading files larger than 2Gb" off
+ LARGEFILE "Support downloading files larger than 2Gb" off \
+ VIRTUALCHROOT "Follow symlinks outside a chroot jail" on
.include <bsd.port.pre.mk>
@@ -135,6 +135,12 @@ CONFIGURE_ARGS+= --enable-largefile
CONFIGURE_ARGS+= --disable-largefile
.endif
+.if defined(WITH_VIRTUALCHROOT)
+CONFIGURE_ARGS+= --with-virtualchroot
+.else
+CONFIGURE_ARGS+= --without-virtualchroot
+.endif
+
PAM_TEMPL?= ${FILESDIR}/pam.conf.5
PAM_DIR?= ${EXAMPLESDIR}/pam
PAM_TARGET?= pure-ftpd