aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-08 10:13:10 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-08 10:13:10 +0000
commit6dc76717347f2b157efbcb4032505f8f579831ce (patch)
treecdff5afb41ea670eb63b2f324d533fb4abdb0afe /ftp
parentfe22788ad9940898223a9d928e18735d4565f640 (diff)
downloadports-6dc76717347f2b157efbcb4032505f8f579831ce.tar.gz
ports-6dc76717347f2b157efbcb4032505f8f579831ce.zip
Add wput 0.3.6,
wput is a tiny program that looks like wget and does as the name suggests exactly the opposite: it uploads files or recursivly whole directories to a ftp-server and supports resuming. PR: 60032 Submitted by: Nosov Artem <chip-set@mail.ru>
Notes
Notes: svn path=/head/; revision=95340
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/wput/Makefile33
-rw-r--r--ftp/wput/distinfo1
-rw-r--r--ftp/wput/files/patch-src::Makefile.in24
-rw-r--r--ftp/wput/files/patch::configure.in11
-rw-r--r--ftp/wput/pkg-descr5
-rw-r--r--ftp/wput/pkg-plist4
7 files changed, 79 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 6b281b44f59c..7251a4093bb8 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -75,6 +75,7 @@
SUBDIR += vsftpd
SUBDIR += wget
SUBDIR += wget+ipv6
+ SUBDIR += wput
SUBDIR += wu-ftpd
SUBDIR += wu-ftpd+ipv6
SUBDIR += xrmftp
diff --git a/ftp/wput/Makefile b/ftp/wput/Makefile
new file mode 100644
index 000000000000..09ef17a46e3a
--- /dev/null
+++ b/ftp/wput/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: wput
+# Date created: 2 December 2003
+# Whom: Nosov Artem <chip-set@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wput
+PORTVERSION= 0.3.6
+CATEGORIES= ftp
+MASTER_SITES= http://itooktheredpill.dyndns.org/wput/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= chip-set@mail.ru
+COMMENT= Uploads files or directories to a ftpserver with support of resuming
+
+GNU_CONFIGURE= yes
+USE_GETOPT_LONG= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in USAGE.examples TODO
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/ftp/wput/distinfo b/ftp/wput/distinfo
new file mode 100644
index 000000000000..6e183b95ea3f
--- /dev/null
+++ b/ftp/wput/distinfo
@@ -0,0 +1 @@
+MD5 (wput-0.3.6.tgz) = f10417823ed61b6f45933203621620cd
diff --git a/ftp/wput/files/patch-src::Makefile.in b/ftp/wput/files/patch-src::Makefile.in
new file mode 100644
index 000000000000..1275f921b2a3
--- /dev/null
+++ b/ftp/wput/files/patch-src::Makefile.in
@@ -0,0 +1,24 @@
+--- src/Makefile.in.orig Tue Dec 2 03:57:48 2003
++++ src/Makefile.in Tue Dec 2 03:58:04 2003
+@@ -4,10 +4,10 @@
+ prefix=@prefix@
+ bindir=@bindir@
+ CC=@CC@
+-CFLAGS= @CFLAGS@
++CFLAGS= @CFLAGS@ @CPPFLAGS@
+ LDFLAGS=@LDFLAGS@
+ EXE=../wput
+-LIBS=
++LIBS= @LIBS@
+ #DEBUG= -DDEBUG
+ DEBUG=
+ OBJ=wput.o ftp.o utils.o progress.o socket.o
+@@ -17,7 +17,7 @@
+
+ all: wput
+ wput: $(OBJ)
+- $(CC) $(LIBS) $(DEBUG) -o $(EXE) $(OBJ)
++ $(CC) $(LIBS) $(DEBUG) -o $(EXE) $(OBJ) $(LDFLAGS)
+ clean:
+ rm -f *.o wput *~ *.bak
+ rm -r msvcpp/Debug msvcpp/Release
diff --git a/ftp/wput/files/patch::configure.in b/ftp/wput/files/patch::configure.in
new file mode 100644
index 000000000000..f35c75daa982
--- /dev/null
+++ b/ftp/wput/files/patch::configure.in
@@ -0,0 +1,11 @@
+--- configure.in.orig Tue Dec 2 03:49:48 2003
++++ configure.in Tue Dec 2 03:50:00 2003
+@@ -9,7 +9,7 @@
+ [AC_MSG_ERROR("You need to get libgnugetopt or a newer GNU libc.")]
+ )]
+ )
+-AC_SEARCH_LIBS(getopt_long, gnugetopt, [],
++AC_SEARCH_LIBS(getopt_long, gnugetopt, [LIBS="-lgnugetopt"],
+ [AC_MSG_ERROR("You need to get libgnugetopt or a newer GNU libc.")]
+ )
+ AC_CONFIG_FILES([Makefile src/Makefile])
diff --git a/ftp/wput/pkg-descr b/ftp/wput/pkg-descr
new file mode 100644
index 000000000000..a688eb78775e
--- /dev/null
+++ b/ftp/wput/pkg-descr
@@ -0,0 +1,5 @@
+wput is a tiny program that looks like wget and does as the name suggests
+exactly the opposite: it uploads files or recursivly whole directories to
+a ftp-server and supports resuming.
+
+WWW: http://itooktheredpill.dyndns.org/wput/
diff --git a/ftp/wput/pkg-plist b/ftp/wput/pkg-plist
new file mode 100644
index 000000000000..5aa21d79ed53
--- /dev/null
+++ b/ftp/wput/pkg-plist
@@ -0,0 +1,4 @@
+bin/wput
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/USAGE.examples
+%%PORTDOCS%%@dirrm %%DOCSDIR%%