aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2007-07-24 21:34:34 +0000
committerBeech Rintoul <beech@FreeBSD.org>2007-07-24 21:34:34 +0000
commitd8cf7c811b6026be1deaba14771bf70acc0cadc8 (patch)
treecdce3f5dc41aab7a8328c25d8039573821d955d0 /ftp
parent94634f398e6dda25e5f2dabcd18593e9c878a3c6 (diff)
downloadports-d8cf7c811b6026be1deaba14771bf70acc0cadc8.tar.gz
ports-d8cf7c811b6026be1deaba14771bf70acc0cadc8.zip
- Add vendor patch to address dirtree issue.
- Bump portrevision Obtained from: TJ Saunders <tj@castaglia.org> (proftpd developer)
Notes
Notes: svn path=/head/; revision=196227
Diffstat (limited to 'ftp')
-rw-r--r--ftp/proftpd-devel/Makefile2
-rw-r--r--ftp/proftpd-devel/files/patch-src_dirtree.c22
-rw-r--r--ftp/proftpd/Makefile2
-rw-r--r--ftp/proftpd/files/patch-src_dirtree.c22
4 files changed, 46 insertions, 2 deletions
diff --git a/ftp/proftpd-devel/Makefile b/ftp/proftpd-devel/Makefile
index a3db00749387..55f1916c0e67 100644
--- a/ftp/proftpd-devel/Makefile
+++ b/ftp/proftpd-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= proftpd
DISTVERSION= 1.3.1rc3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
diff --git a/ftp/proftpd-devel/files/patch-src_dirtree.c b/ftp/proftpd-devel/files/patch-src_dirtree.c
new file mode 100644
index 000000000000..786934a9c139
--- /dev/null
+++ b/ftp/proftpd-devel/files/patch-src_dirtree.c
@@ -0,0 +1,22 @@
+Index: src/dirtree.c
+===================================================================
+RCS file: /cvsroot/proftp/proftpd/src/dirtree.c,v
+retrieving revision 1.184
+diff -u -r1.184 dirtree.c
+--- src/dirtree.c 22 Mar 2007 03:54:20 -0000 1.184
++++ src/dirtree.c 24 Jul 2007 17:13:05 -0000
+@@ -2911,12 +2911,13 @@
+ * this address.
+ */
+ snprintf(ipbuf, sizeof(ipbuf), "::ffff:%s", ipstr);
+- ipstr = ipbuf;
++ ipstr = pstrdup(s->pool, ipbuf);
+ }
+ }
+ #endif /* PR_USE_IPV6 */
+
+- pr_conf_add_server_config_param_str(s, "_bind", 1, ipstr);
++ if (ipstr)
++ pr_conf_add_server_config_param_str(s, "_bind", 1, ipstr);
+ }
+ }
diff --git a/ftp/proftpd/Makefile b/ftp/proftpd/Makefile
index a3db00749387..55f1916c0e67 100644
--- a/ftp/proftpd/Makefile
+++ b/ftp/proftpd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= proftpd
DISTVERSION= 1.3.1rc3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.proftpd.org/distrib/source/ \
ftp://ftp.fastorama.com/mirrors/ftp.proftpd.org/distrib/source/ \
diff --git a/ftp/proftpd/files/patch-src_dirtree.c b/ftp/proftpd/files/patch-src_dirtree.c
new file mode 100644
index 000000000000..786934a9c139
--- /dev/null
+++ b/ftp/proftpd/files/patch-src_dirtree.c
@@ -0,0 +1,22 @@
+Index: src/dirtree.c
+===================================================================
+RCS file: /cvsroot/proftp/proftpd/src/dirtree.c,v
+retrieving revision 1.184
+diff -u -r1.184 dirtree.c
+--- src/dirtree.c 22 Mar 2007 03:54:20 -0000 1.184
++++ src/dirtree.c 24 Jul 2007 17:13:05 -0000
+@@ -2911,12 +2911,13 @@
+ * this address.
+ */
+ snprintf(ipbuf, sizeof(ipbuf), "::ffff:%s", ipstr);
+- ipstr = ipbuf;
++ ipstr = pstrdup(s->pool, ipbuf);
+ }
+ }
+ #endif /* PR_USE_IPV6 */
+
+- pr_conf_add_server_config_param_str(s, "_bind", 1, ipstr);
++ if (ipstr)
++ pr_conf_add_server_config_param_str(s, "_bind", 1, ipstr);
+ }
+ }