aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-03 19:32:37 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-03 19:32:37 +0000
commit806107bb88116fe0e96b6065c5c3e99b0dd35e59 (patch)
treec28066491311606c72fa3dff4d45259a5aac0bef /ftp
parent16bd8cfb604426cb8412b313d36087b050eea4b5 (diff)
downloadports-806107bb88116fe0e96b6065c5c3e99b0dd35e59.tar.gz
ports-806107bb88116fe0e96b6065c5c3e99b0dd35e59.zip
- Fix OPTIONS (they must be before bsd.port.pre.mk)
PR: ports/62296 Submitted by: Sergey Matveychuk <sem@ciam.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=99898
Diffstat (limited to 'ftp')
-rw-r--r--ftp/frox/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/ftp/frox/Makefile b/ftp/frox/Makefile
index 79bdf138e596..dda97e2f07ce 100644
--- a/ftp/frox/Makefile
+++ b/ftp/frox/Makefile
@@ -41,6 +41,15 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
CONFIGURE_ARGS= --enable-configfile=${PREFIX}/etc/frox.conf
+OPTIONS= IPFILTER "Use ipfilter instead of ipfw" off \
+ VIRUS_SCAN "Run external virus scaner on each download" off \
+ HTTP_CACHE "Enable use of external cache" on \
+ LOCAL_CACHE "Enable use of local cache" off \
+ CCP "Ftp-proxy style command control programs" on \
+ ROOT_RUN "Allow frox running as root (not recomended)" off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_IPFILTER)
CONFIGURE_ARGS+= --enable-ipfilter
.endif
@@ -60,15 +69,6 @@ CONFIGURE_ARGS+= --enable-ccp
CONFIGURE_ARGS+= --enable-run-as-root
.endif
-.include <bsd.port.pre.mk>
-
-OPTIONS= IPFILTER "Use ipfilter instead of ipfw" off \
- VIRUS_SCAN "Run external virus scaner on each download" off \
- HTTP_CACHE "Enable use of external cache" on \
- LOCAL_CACHE "Enable use of local cache" off \
- CCP "Ftp-proxy style command control programs" on \
- ROOT_RUN "Allow frox running as root (not recomended)" off
-
pre-patch:
@${SED} ${SED_SCRIPT} ${PKGDIR}/pkg-message >${PKGMESSAGE}
@${SED} ${SED_SCRIPT} ${FILESDIR}/frox.sh > ${WRKDIR}/frox.sh