aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-12-15 09:28:39 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-12-15 09:28:39 +0000
commitb7ab46d7520b4f8d60294ff1315a39acd1ac6798 (patch)
treea8a78d46e31030c9669e228f41e7112eca959882 /ftp
parenta93985a7792a0a20cbcaefb38849fd39af5827f7 (diff)
downloadports-b7ab46d7520b4f8d60294ff1315a39acd1ac6798.tar.gz
ports-b7ab46d7520b4f8d60294ff1315a39acd1ac6798.zip
- "It appears the API has changed in libevent and pftpx is a dead project.
Please remove the port." Submitted by: Scott Ullrich <sullrich@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=245868
Diffstat (limited to 'ftp')
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/pftpx/Makefile31
-rw-r--r--ftp/pftpx/distinfo3
-rw-r--r--ftp/pftpx/files/patch-Makefile11
-rw-r--r--ftp/pftpx/files/patch-pftpx.c206
-rw-r--r--ftp/pftpx/files/pftpx.in25
-rw-r--r--ftp/pftpx/pkg-descr7
7 files changed, 0 insertions, 284 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 94b5807fd993..be3692a642de 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -79,7 +79,6 @@
SUBDIR += pavuk
SUBDIR += pear-Net_FTP
SUBDIR += pftpd
- SUBDIR += pftpx
SUBDIR += php4-curl
SUBDIR += php4-ftp
SUBDIR += php5-curl
diff --git a/ftp/pftpx/Makefile b/ftp/pftpx/Makefile
deleted file mode 100644
index 457f90c732f1..000000000000
--- a/ftp/pftpx/Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
-# New ports collection makefile for: pftpx
-# Date created: 27 June 2005
-# Whom: Scott Ullrich (geekgod@geekgod.com)
-#
-# $FreeBSD$
-
-PORTNAME= pftpx
-PORTVERSION= 0.8
-PORTREVISION= 6
-CATEGORIES= ftp
-MASTER_SITES= http://www.sentia.org/downloads/
-DISTNAME= ${PORTNAME}-${PORTVERSION}
-
-MAINTAINER= sullrich@gmail.com
-COMMENT= Much enhanced ftp proxy for pf that supports most ftp protocols
-
-LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
-
-MAN8= pftpx.8
-
-PLIST_FILES= sbin/pftpx
-USE_RC_SUBR= pftpx
-
-MAKE_ARGS= LOCALBASE="${PREFIX}" OSLEVEL=37
-CFLAGS+= -DHAVE_ALTQ=1
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pftpx ${PREFIX}/sbin
- ${INSTALL_MAN} ${WRKSRC}/pftpx.8 ${PREFIX}/man/man8
-
-.include <bsd.port.mk>
diff --git a/ftp/pftpx/distinfo b/ftp/pftpx/distinfo
deleted file mode 100644
index 85775cb21b38..000000000000
--- a/ftp/pftpx/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (pftpx-0.8.tar.gz) = 6d71baaab87c4ad13949bf7fc5d64f55
-SHA256 (pftpx-0.8.tar.gz) = b76443ac70cf19c2e92d69f51ed12995c582c60584111594ab97431c48e370ce
-SIZE (pftpx-0.8.tar.gz) = 11488
diff --git a/ftp/pftpx/files/patch-Makefile b/ftp/pftpx/files/patch-Makefile
deleted file mode 100644
index 4a6ace634008..000000000000
--- a/ftp/pftpx/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig Mon Jun 27 19:14:36 2005
-+++ Makefile Mon Jun 27 19:30:00 2005
-@@ -5,6 +5,8 @@
- CFLAGS+=-I. -g
- CFLAGS+=-Wall -Wstrict-prototypes -Wmissing-prototypes -Wpointer-arith \
- -Wno-uninitialized
-+CFLAGS+=-I/usr/local/include -L/usr/local/lib
-+INCLUDES+= -I/usr/local/include
- LDADD+= -levent
-
- .include <bsd.prog.mk>
diff --git a/ftp/pftpx/files/patch-pftpx.c b/ftp/pftpx/files/patch-pftpx.c
deleted file mode 100644
index a46f62421121..000000000000
--- a/ftp/pftpx/files/patch-pftpx.c
+++ /dev/null
@@ -1,206 +0,0 @@
---- pftpx.c.orig Mon Jun 27 17:58:30 2005
-+++ pftpx.c Mon Jun 27 18:01:11 2005
-@@ -58,6 +58,58 @@
-
- #define sstosa(ss) ((struct sockaddr *)(ss))
-
-+#include <sys/types.h>
-+
-+#include <ctype.h>
-+#include <limits.h>
-+#include <string.h>
-+
-+#define isoctal(c) (((u_char)(c)) >= '0' && ((u_char)(c)) <= '7')
-+#include <sys/types.h>
-+
-+#define isoctal(c) (((u_char)(c)) >= '0' && ((u_char)(c)) <= '7')
-+#define isvisible(c) (((u_int)(c) <= UCHAR_MAX && isascii((u_char)(c)) && \
-+ isgraph((u_char)(c))) || \
-+ ((flag & VIS_SP) == 0 && (c) == ' ') || \
-+ ((flag & VIS_TAB) == 0 && (c) == '\t') || \
-+ ((flag & VIS_NL) == 0 && (c) == '\n') || \
-+ ((flag & VIS_SAFE) && ((c) == '\b' || \
-+ (c) == '\007' || (c) == '\r' || \
-+ isgraph((u_char)(c)))))
-+
-+#define _VIS_H_
-+
-+#include <sys/types.h>
-+#include <limits.h>
-+
-+/*
-+ * to select alternate encoding format
-+ */
-+#define VIS_OCTAL 0x01 /* use octal \ddd format */
-+#define VIS_CSTYLE 0x02 /* use \[nrft0..] where appropriate */
-+
-+/*
-+ * to alter set of characters encoded (default is to encode all
-+ * non-graphic except space, tab, and newline).
-+ */
-+#define VIS_SP 0x04 /* also encode space */
-+#define VIS_TAB 0x08 /* also encode tab */
-+#define VIS_NL 0x10 /* also encode newline */
-+#define VIS_WHITE (VIS_SP | VIS_TAB | VIS_NL)
-+#define VIS_SAFE 0x20 /* only encode "unsafe" characters */
-+
-+/*
-+ * other
-+ */
-+#define VIS_NOSLASH 0x40 /* inhibit printing '\' */
-+
-+#define LIST_FIRST(head) ((head)->lh_first)
-+#define LIST_END(head) NULL
-+#define LIST_NEXT(elm, field) ((elm)->field.le_next)
-+
-+char *vis(char *, int, int, int);
-+int strnvis(char *, const char *, size_t, int);
-+
- enum { CMD_NONE = 0, CMD_PORT, CMD_EPRT, CMD_PASV, CMD_EPSV };
-
- struct session {
-@@ -1037,3 +1089,143 @@
- "[-p address] [-q queue] [-t timeout]\n", __progname);
- exit(1);
- }
-+
-+
-+/*
-+ * vis - visually encode characters
-+ */
-+char *
-+vis(dst, c, flag, nextc)
-+ register char *dst;
-+ int c, nextc;
-+ register int flag;
-+{
-+ if (isvisible(c)) {
-+ *dst++ = c;
-+ if (c == '\\' && (flag & VIS_NOSLASH) == 0)
-+ *dst++ = '\\';
-+ *dst = '\0';
-+ return (dst);
-+ }
-+
-+ if (flag & VIS_CSTYLE) {
-+ switch(c) {
-+ case '\n':
-+ *dst++ = '\\';
-+ *dst++ = 'n';
-+ goto done;
-+ case '\r':
-+ *dst++ = '\\';
-+ *dst++ = 'r';
-+ goto done;
-+ case '\b':
-+ *dst++ = '\\';
-+ *dst++ = 'b';
-+ goto done;
-+ case '\a':
-+ *dst++ = '\\';
-+ *dst++ = 'a';
-+ goto done;
-+ case '\v':
-+ *dst++ = '\\';
-+ *dst++ = 'v';
-+ goto done;
-+ case '\t':
-+ *dst++ = '\\';
-+ *dst++ = 't';
-+ goto done;
-+ case '\f':
-+ *dst++ = '\\';
-+ *dst++ = 'f';
-+ goto done;
-+ case ' ':
-+ *dst++ = '\\';
-+ *dst++ = 's';
-+ goto done;
-+ case '\0':
-+ *dst++ = '\\';
-+ *dst++ = '0';
-+ if (isoctal(nextc)) {
-+ *dst++ = '0';
-+ *dst++ = '0';
-+ }
-+ goto done;
-+ }
-+ }
-+ if (((c & 0177) == ' ') || (flag & VIS_OCTAL)) {
-+ *dst++ = '\\';
-+ *dst++ = ((u_char)c >> 6 & 07) + '0';
-+ *dst++ = ((u_char)c >> 3 & 07) + '0';
-+ *dst++ = ((u_char)c & 07) + '0';
-+ goto done;
-+ }
-+ if ((flag & VIS_NOSLASH) == 0)
-+ *dst++ = '\\';
-+ if (c & 0200) {
-+ c &= 0177;
-+ *dst++ = 'M';
-+ }
-+ if (iscntrl(c)) {
-+ *dst++ = '^';
-+ if (c == 0177)
-+ *dst++ = '?';
-+ else
-+ *dst++ = c + '@';
-+ } else {
-+ *dst++ = '-';
-+ *dst++ = c;
-+ }
-+done:
-+ *dst = '\0';
-+ return (dst);
-+}
-+
-+int
-+strnvis(dst, src, siz, flag)
-+ char *dst;
-+ const char *src;
-+ size_t siz;
-+ int flag;
-+{
-+ char c;
-+ char *start, *end;
-+ char tbuf[5];
-+ int i;
-+
-+ i = 0;
-+ for (start = dst, end = start + siz - 1; (c = *src) && dst < end; ) {
-+ if (isvisible(c)) {
-+ i = 1;
-+ *dst++ = c;
-+ if (c == '\\' && (flag & VIS_NOSLASH) == 0) {
-+ /* need space for the extra '\\' */
-+ if (dst < end)
-+ *dst++ = '\\';
-+ else {
-+ dst--;
-+ i = 2;
-+ break;
-+ }
-+ }
-+ src++;
-+ } else {
-+ i = vis(tbuf, c, flag, *++src) - tbuf;
-+ if (dst + i <= end) {
-+ memcpy(dst, tbuf, i);
-+ dst += i;
-+ } else {
-+ src--;
-+ break;
-+ }
-+ }
-+ }
-+ if (siz > 0)
-+ *dst = '\0';
-+ if (dst + i > end) {
-+ /* adjust return value for truncation */
-+ while ((c = *src))
-+ dst += vis(tbuf, c, flag, *++src) - tbuf;
-+ }
-+ return (dst - start);
-+}
-+
-
diff --git a/ftp/pftpx/files/pftpx.in b/ftp/pftpx/files/pftpx.in
deleted file mode 100644
index 8375fa93d330..000000000000
--- a/ftp/pftpx/files/pftpx.in
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/bin/sh
-#
-# PROVIDE: pftpx
-# REQUIRE: DAEMON pf
-#
-# Add the following lines to /etc/rc.conf to enable pftpx:
-#
-# pftpx_enable (bool): Set to "YES" to enable pftpx.
-# Default is "NO".
-# pftpx_flags (flags): Set extra flags to pftpx.
-# Default is "". See pftpx(8).
-#
-
-. %%RC_SUBR%%
-
-name="pftpx"
-rcvar=${name}_enable
-
-load_rc_config $name
-
-: ${pftpx_enable="NO"}
-
-command="%%PREFIX%%/sbin/pftpx"
-
-run_rc_command "$1"
diff --git a/ftp/pftpx/pkg-descr b/ftp/pftpx/pkg-descr
deleted file mode 100644
index e5dc4862141a..000000000000
--- a/ftp/pftpx/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-pftpx is a ftp proxy with many advanced features such as:
-
-1) it handles all ftp modes: PORT, PASV, EPRT, EPSV
-2) it handles ipv6
-3) it should scale: one process handles all sessions using libevent
-4) it works with "strict" ftp clients (clients that want data connections
- to the same IP as the control connection)