aboutsummaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /ftp
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'ftp')
-rw-r--r--ftp/curl/Makefile4
-rw-r--r--ftp/curlpp/Makefile4
-rw-r--r--ftp/filezilla/Makefile2
-rw-r--r--ftp/frox/Makefile2
-rw-r--r--ftp/gftp/Makefile4
-rw-r--r--ftp/gwget/Makefile4
-rw-r--r--ftp/kbear/Makefile3
-rw-r--r--ftp/pavuk/Makefile5
-rw-r--r--ftp/pureadmin/Makefile5
-rw-r--r--ftp/quftp/Makefile1
-rw-r--r--ftp/rexx-curl/Makefile3
-rw-r--r--ftp/urlgfe/Makefile2
-rw-r--r--ftp/vsftpd-ext/Makefile2
-rw-r--r--ftp/vsftpd/Makefile2
-rw-r--r--ftp/wgetpro/Makefile1
-rw-r--r--ftp/wput/Makefile5
-rw-r--r--ftp/wzdftpd/Makefile4
17 files changed, 21 insertions, 32 deletions
diff --git a/ftp/curl/Makefile b/ftp/curl/Makefile
index 842c414eed45..bc437ae9c503 100644
--- a/ftp/curl/Makefile
+++ b/ftp/curl/Makefile
@@ -151,7 +151,6 @@ CONFIGURE_ARGS+= --enable-ldap
USE_OPENLDAP= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-ADDFLAGS= true
.if defined(WITH_LDAPS)
CONFIGURE_ARGS+= --enable-ldaps
.else
@@ -205,9 +204,6 @@ CONFIGURE_ARGS+= --disable-proxy
.endif
CONFIGURE_ENV+= LOCALBASE="${LOCALBASE}"
-.if defined(ADDFLAGS)
-CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
-.endif
DOCS= BINDINGS BUGS CONTRIBUTE DISTRO-DILEMMA FAQ FEATURES \
HISTORY INSTALL INSTALL.devcpp INTERNALS KNOWN_BUGS \
diff --git a/ftp/curlpp/Makefile b/ftp/curlpp/Makefile
index 8e2596fe34b5..5ff5a95352b4 100644
--- a/ftp/curlpp/Makefile
+++ b/ftp/curlpp/Makefile
@@ -19,8 +19,8 @@ COMMENT= A C++ wrapper for libcurl
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --disable-ewarning --without-boost
USE_LDCONFIG= yes
diff --git a/ftp/filezilla/Makefile b/ftp/filezilla/Makefile
index 806488734f9c..d56becf9fc68 100644
--- a/ftp/filezilla/Makefile
+++ b/ftp/filezilla/Makefile
@@ -33,7 +33,7 @@ WX_CONF_ARGS= relative
WX_UNICODE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+LDFLAGS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAN1= filezilla.1 fzputtygen.1 fzsftp.1
diff --git a/ftp/frox/Makefile b/ftp/frox/Makefile
index ba51e0174412..86c5eca2a881 100644
--- a/ftp/frox/Makefile
+++ b/ftp/frox/Makefile
@@ -57,7 +57,7 @@ WITH_CCP= yes
CONFIGURE_ARGS+= --enable-ipfilter
.endif
.if defined(WITH_PF)
-CONFIGURE_ENV+= "CPPFLAGS=-DPF"
+CPPFLAGS+= -DPF
.endif
.if defined(WITH_VIRUS_SCAN)
CONFIGURE_ARGS+= --enable-virus-scan
diff --git a/ftp/gftp/Makefile b/ftp/gftp/Makefile
index c027a1ba645f..5fa5eb572e49 100644
--- a/ftp/gftp/Makefile
+++ b/ftp/gftp/Makefile
@@ -19,8 +19,8 @@ COMMENT= A free multithreaded GTK-based GUI ftp and sftp client
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-included-gettext
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
WANT_GNOME= yes
diff --git a/ftp/gwget/Makefile b/ftp/gwget/Makefile
index 760bedad7565..607229f7b77c 100644
--- a/ftp/gwget/Makefile
+++ b/ftp/gwget/Makefile
@@ -28,8 +28,8 @@ USE_GNOME= gnomeprefix gnomehack gtk20 gconf2 libgnomeui \
desktopfileutils
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
GCONF_SCHEMAS= ${PORTNAME}.schemas
diff --git a/ftp/kbear/Makefile b/ftp/kbear/Makefile
index 286118a9e8e4..187a10ce67ca 100644
--- a/ftp/kbear/Makefile
+++ b/ftp/kbear/Makefile
@@ -24,7 +24,8 @@ USE_KDELIBS_VER=3
USE_BZIP2= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-CONFIGURE_ENV= XML2POT=${TRUE} PO2XML=${TRUE} LDFLAGS="${PTHREAD_LIBS}"
+CONFIGURE_ENV= XML2POT=${TRUE} PO2XML=${TRUE}
+LDFLAGS+= ${PTHREAD_LIBS}
post-patch:
@${REINPLACE_CMD} -e 's|-O2|-fPIC|g; s|-lpthread|${PTHREAD_LIBS}|g' \
diff --git a/ftp/pavuk/Makefile b/ftp/pavuk/Makefile
index 6ead7bedb296..2f361b6cb280 100644
--- a/ftp/pavuk/Makefile
+++ b/ftp/pavuk/Makefile
@@ -18,15 +18,14 @@ USE_BZIP2= yes
WANT_GNOME= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-locale-dir=${PREFIX}/share/locale \
--disable-debug --disable-gnome --disable-js \
--enable-utf-8 --enable-threads
MAN1= pavuk.1
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
diff --git a/ftp/pureadmin/Makefile b/ftp/pureadmin/Makefile
index 95cc57d9ffab..ef05507d142c 100644
--- a/ftp/pureadmin/Makefile
+++ b/ftp/pureadmin/Makefile
@@ -20,11 +20,10 @@ USE_FAM= yes
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_ICONS= yes
-CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
PORTDOCS= index.txt introduction.txt main_window.txt \
preferences.txt user_manager.txt
diff --git a/ftp/quftp/Makefile b/ftp/quftp/Makefile
index 3efcfa01ecd4..e212ac85fa34 100644
--- a/ftp/quftp/Makefile
+++ b/ftp/quftp/Makefile
@@ -19,7 +19,6 @@ LIB_DEPENDS= readline.6:${PORTSDIR}/devel/readline
GNU_CONFIGURE= yes
CFLAGS+= ${PTHREAD_CFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}
-CONFIGURE_ENV= CFLAGS="${CFLAGS}"
MAN1= quftp.1
PLIST_FILES= bin/quftp
diff --git a/ftp/rexx-curl/Makefile b/ftp/rexx-curl/Makefile
index da0bf73fa233..bd4057e051ea 100644
--- a/ftp/rexx-curl/Makefile
+++ b/ftp/rexx-curl/Makefile
@@ -23,7 +23,8 @@ RUN_DEPENDS= rexx:${PORTSDIR}/lang/rexx-regina
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
+CPPFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
CONFIGURE_ARGS= --with-rexx=regina
USE_LDCONFIG= yes
diff --git a/ftp/urlgfe/Makefile b/ftp/urlgfe/Makefile
index e3376c9f3dc6..ab08b4b65f10 100644
--- a/ftp/urlgfe/Makefile
+++ b/ftp/urlgfe/Makefile
@@ -20,7 +20,7 @@ USE_GNOME= gtk20 lthack
WANT_GNOME= yes
USE_OPENSSL= yes
USE_AUTOTOOLS= libtool
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include"
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
diff --git a/ftp/vsftpd-ext/Makefile b/ftp/vsftpd-ext/Makefile
index 8ae8bf2f907c..8d32a735e703 100644
--- a/ftp/vsftpd-ext/Makefile
+++ b/ftp/vsftpd-ext/Makefile
@@ -51,8 +51,6 @@ WITH_OPENSSL_PORT= yes
SSL_SUFFIX= -ssl
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
-.else
-MAKE_ENV+= LDFLAGS="${LDFLAGS}"
.endif
do-configure:
diff --git a/ftp/vsftpd/Makefile b/ftp/vsftpd/Makefile
index 4a9d2ece1d53..bf112a31b176 100644
--- a/ftp/vsftpd/Makefile
+++ b/ftp/vsftpd/Makefile
@@ -40,8 +40,6 @@ USE_RC_SUBR= vsftpd.sh
SSL_SUFFIX= -ssl
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
-.else
-MAKE_ENV+= LDFLAGS="${LDFLAGS}"
.endif
.if defined(WITH_PIDFILE)
diff --git a/ftp/wgetpro/Makefile b/ftp/wgetpro/Makefile
index 421a7d31818d..405f937c13ba 100644
--- a/ftp/wgetpro/Makefile
+++ b/ftp/wgetpro/Makefile
@@ -20,7 +20,6 @@ RESTRICTED= "may implement United States Patent 6,041,345"
USE_OPENSSL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
diff --git a/ftp/wput/Makefile b/ftp/wput/Makefile
index 9e7675c981e0..bea0d7535b2b 100644
--- a/ftp/wput/Makefile
+++ b/ftp/wput/Makefile
@@ -20,9 +20,8 @@ PORTEXAMPLES= USAGE.examples USAGE.resumehandling USAGE.urlhandling \
passwordfile wputrc
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="${LDFLAGS}" \
- LIBS="${LDFLAGS}"
+CONFIGURE_ENV= LIBS="${LDFLAGS}"
+CFLAGS+= -I${LOCALBASE}/include
MAKE_JOBS_UNSAFE=yes
OPTIONS= TLS "Enable TLS support" On \
diff --git a/ftp/wzdftpd/Makefile b/ftp/wzdftpd/Makefile
index 7081df973aed..a7004582f3b2 100644
--- a/ftp/wzdftpd/Makefile
+++ b/ftp/wzdftpd/Makefile
@@ -21,8 +21,8 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GNOME= pkgconfig ltverhack
CONFIGURE_ARGS+= --without-pam --disable-pgsql --disable-bonjour
-CONFIGURE_ENV= CPPFLAGS="${CPPLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS= UTF8 "Enable UTF8 support" off \