aboutsummaryrefslogtreecommitdiff
path: root/games/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-08-13 23:16:03 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-08-13 23:16:03 +0000
commit22ff391bac32f3541240678b3da9753420e9d765 (patch)
tree9fcf07c6668e55ed016e5df4267b5db3132360cd /games/Makefile
parente544af77b2cf4dfe81d8c96a78aad2dc1c74bf5c (diff)
downloadports-22ff391bac32f3541240678b3da9753420e9d765.tar.gz
ports-22ff391bac32f3541240678b3da9753420e9d765.zip
The goal of this project is to add Cell Shading capabilities to the Quake III
engine with Real-time performance. In order to provide such feature we have decided to use Kuwahara filter. Kuwahara filter is a noise-reduction filter that preserves edges. It uses four subquadrants to calculate the mean and variance and chooses the mean value for the region with the smallest variance. To increase the hand-painted effect we have decided to apply a simple blur filter to reduce hard-edges on textures and increase the flatness effect. To produce the cell shading effect we use no graphics card shaders, so our implementation could run with almost any gfx card. The edge effect is produced by painting backface polygons with a thick wireframe without textures and repaint all the scene, but this time, with textures. We have also implemented a different algorithm (we call it White Texture), which uses white textures. It looks like this and this, you can set the console variable r_celshadalgo to 2, and load another map, or run using the appropiate link that came with the release. WWW: http://q3cellshading.sourceforge.net/ PR: ports/101677
Notes
Notes: svn path=/head/; revision=170500
Diffstat (limited to 'games/Makefile')
-rw-r--r--games/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 55a16a01881a..725ac19dd14a 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -539,6 +539,7 @@
SUBDIR += pythonchess
SUBDIR += q15
SUBDIR += q3base
+ SUBDIR += q3cellshading
SUBDIR += linux-quake3
SUBDIR += quake2max
SUBDIR += quake3-excessive