aboutsummaryrefslogtreecommitdiff
path: root/games/alienarena
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-03-30 17:47:33 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-03-30 17:47:33 +0000
commit1905cdee0c0c48b29ea986a9a583ddd16fa5fc39 (patch)
treeefceda5a4bf998e90618644c23d1b53311f6826c /games/alienarena
parent155a9e7669308c79511d00b61d826b4d4f48b9d0 (diff)
downloadports-1905cdee0c0c48b29ea986a9a583ddd16fa5fc39.tar.gz
ports-1905cdee0c0c48b29ea986a9a583ddd16fa5fc39.zip
- fix build for jpeg-8
PR: 145204
Notes
Notes: svn path=/head/; revision=251843
Diffstat (limited to 'games/alienarena')
-rw-r--r--games/alienarena/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/games/alienarena/Makefile b/games/alienarena/Makefile
index 88f53477cec5..695ed9527193 100644
--- a/games/alienarena/Makefile
+++ b/games/alienarena/Makefile
@@ -45,9 +45,11 @@ LIBDIR= ${PREFIX}/lib/${PORTNAME}
.include <bsd.port.pre.mk>
.if defined(WITH_CLIENT)
+BUILD_DEPENDS+= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS+= curl.5:${PORTSDIR}/ftp/curl \
jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png
+ png.6:${PORTSDIR}/graphics/png \
+ vorbis.4:${PORTSDIR}/audio/libvorbis
USE_GL= yes
USE_OPENAL= soft alut
USE_XORG= xxf86dga
@@ -82,6 +84,9 @@ MAKE_ENV+= OPTIMIZED_CFLAGS=no
post-patch:
@${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|g" ${WRKSRC}/client/snd_openal.c
@${REINPLACE_CMD} -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/Makefile
+# Resolve name collision with jpeg-8
+ ${REINPLACE_CMD} -e 's|jpeg_mem_src|local_jpeg_mem_src|' \
+ ${WRKSRC}/ref_gl/r_image.c
do-install:
${MKDIR} ${LIBDIR}/arena ${LIBDIR}/data1